View Issue Details

This issue affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
15061Bug reportsInstallationpublic2026-09-14 15:46
Reporterrjpinto Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.17.x 
Summary15061: complex password failed to work
Description

Usage of complex passwords for the database connection with special caracteres always fails.

If the database user has a complex passwrd like >:8n@u;x8;|~ , the authentication will always fail.

Steps To Reproduce

Create a database and user for limesurvey to use:
CREATE ROLE limesurvey WITH PASSWORD '>:8n@u;x8;|~' LOGIN
CREATE DATABASE limesurvey WITH OWNER limesurvey

When you go through the web installation process it will always fail to authenticate. Changing the password to something more simple works with an ALTER ROLE will solve it. So I would guess there is a character in the password that is messing up the connection string.

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3.17.7-190627
I will donate to the project if issue is resolvedNo
BrowserFirefox
Database type & versionPostgresql 10
Server OS (if known)Ubuntu 18.04 LTS
Webserver software & version (if known)Apache
PHP Version7.2

Users monitoring this issue

There are no users monitoring this issue.

Activities

ollehar

ollehar

2021-03-10 22:57

reporter   ~63229

Please update to the latest version and check if the bug can still be reproduced. Thank you.

c_schmitz

c_schmitz

2021-05-10 10:19

administrator   ~64309

I don't see a quick way to resolve this.
The semicolon is breaking it but there is no proper way to quote the related value in the connection string.
We could forbid certain characters in the connection string, like semicolons and quotes.

c_schmitz

c_schmitz

2026-09-13 23:08

administrator   ~85709

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=40320

LimeBot

LimeBot

2026-09-14 15:46

administrator   ~85733

Fixed in Release 7.1.1+260914

Related Changesets

LimeSurvey: master 820c2085

2026-09-13 23:08

c_schmitz


Details Diff
Fixed issue 15061: Complex Postgres password cannot be used during installation Affected Issues
15061
mod - application/config/config-sample-pgsql.php Diff File
mod - application/models/InstallerConfigForm.php Diff File

Issue History

Date Modified Username Field Change
2019-07-19 16:59 rjpinto New Issue
2021-03-10 22:57 ollehar Status new => feedback
2021-03-10 22:57 ollehar Note Added: 63229
2021-05-10 10:19 c_schmitz Assigned To => c_schmitz
2021-05-10 10:19 c_schmitz Status feedback => acknowledged
2021-05-10 10:19 c_schmitz Note Added: 64309
2026-09-13 23:08 c_schmitz Changeset attached => LimeSurvey master 820c2085
2026-09-13 23:08 c_schmitz Note Added: 85709
2026-09-13 23:08 c_schmitz Status acknowledged => resolved
2026-09-13 23:08 c_schmitz Resolution open => fixed
2026-09-14 15:46 LimeBot Note Added: 85733
2026-09-14 15:46 LimeBot Status resolved => closed
2026-09-14 15:46 LimeBot Bug heat 4 => 6