View Issue Details

IDProjectCategoryView StatusLast Update
15023Bug reports[All Projects] Securitypublic2019-08-14 23:40
ReportergreilingAssigned ToJHoeck 
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version3.17.x 
Target VersionFixed in Version 
Summary15023: Umfrage Quoten -> Forwarded URL -> fail
Description

Der vorzeitige Abbruch einer Umfrage nach einer spezifischen Antwort scheitert- der XHR-Aufruf geht los, es gibt eine Antwort von dem entfernten Server - immerhin der Aufruf wird ausgeführt. Es wird aber letztendlich trotz 302 und Location auf die Startseite der Umfrage zurückgeleitet. Um die same-origin-Richtlinien zu umschiffen, habe ich eine Datei auf dem gleichen www-Mount angelegt, die garantiert aufgerufen hätte werden sollen.

Steps To Reproduce

Umfrage anlegen, Frage mit spezifischer Antwort anlegen, Quote anlegen, die URL auf beliebigen Server zeigen lassen - fertig. Dann erhalte ich bei 200 vom entfernten Server den Screenschot von 18.51.03.
Mit beliebiger Datei auf gleichem System 18.51.28

POST

HTTP/1.1 302 Found
Date: Wed, 03 Jul 2019 17:06:47 GMT
Server: Apache
Expires: Mon, 26 Jul 1997 05:00:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
P3P: CP="IDC DSP COR ADM DEVi TAIi PSA PSD IVAi IVDi CONi HIS OUR IND CNT"
Last-Modified: Wed, 03 Jul 2019 17:06:47 GMT
Cache-Control: post-check=0, pre-check=0
Location: https://umfrage.uni-wuppertal.de/ff.php
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=utf-8

GET von definierter Location

HTTP/1.1 200 OK
Date: Wed, 03 Jul 2019 17:06:47 GMT
Server: Apache
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 24836
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Content-Type: text/html; charset=UTF-8

Ergebnis: Gewechselt zu https://umfrage.uni-wuppertal.de/index.php/979434

Kein Fehler in der Konsole

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.17.7+190627
I will donate to the project if issue is resolvedNo
BrowserFirefox 67.0.4 on macOS 10.14.5
Database & DB-VersionMySQL 5.5.62
Server OS (if known)debian
Webserver software & version (if known)apache 2
PHP VersionPHP Version 5.6.40-0+deb8u1

Activities

greiling

greiling

2019-07-03 19:11

reporter  

Bildschirmfoto 2019-07-03 um 18.51.03.png (111,818 bytes)
Bildschirmfoto 2019-07-03 um 18.54.39.png (113,318 bytes)
greiling

greiling

2019-07-04 15:33

reporter   ~52730

works as expected with Microsoft Edge on WIN10 - but not in firefox or chrome



Bildschirmfoto 2019-07-04 um 15.32.23.png (141,182 bytes)
DenisChenu

DenisChenu

2019-07-30 10:02

developer   ~53040

It's not related to security ? Unsure because i don't understand German …

Else : try to deactivate Ajax Mode in theme if i understand right.

greiling

greiling

2019-08-14 14:01

reporter   ~53175

It is an AJAX-issue, misinterpreted by my browser - problem does not exist anymore in Firefox 68 on macOS or limesurvey Version 3.17.9.
One thing: in firefox you will directly redirected to "end url". In edge there will "end message" shown with the link beneath it.

jelo

jelo

2019-08-14 23:40

partner   ~53178

@greiling: Did you deactivate the AJAX-Mode via theme options?
The edge redirection info looks important. Might be a new redirection protection.
Can you check again? Which Edge version was used?

Issue History

Date Modified Username Field Change
2019-07-03 19:11 greiling New Issue
2019-07-03 19:11 greiling File Added: Bildschirmfoto 2019-07-03 um 18.51.03.png
2019-07-03 19:11 greiling File Added: Bildschirmfoto 2019-07-03 um 18.51.28.png
2019-07-03 19:11 greiling File Added: Bildschirmfoto 2019-07-03 um 18.54.39.png
2019-07-04 15:33 greiling File Added: Bildschirmfoto 2019-07-04 um 15.32.23.png
2019-07-04 15:33 greiling Note Added: 52730
2019-07-30 10:02 DenisChenu Note Added: 53040
2019-08-14 14:01 greiling Note Added: 53175
2019-08-14 14:50 JHoeck Assigned To => JHoeck
2019-08-14 14:50 JHoeck Status new => assigned
2019-08-14 23:40 jelo Note Added: 53178