View Issue Details

IDProjectCategoryView StatusLast Update
14975Bug reports[All Projects] User/User groupspublic2019-07-04 15:58
ReporterMaziAssigned Todominikvitt 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14975: Limesurvey users with limited rights get "undefined" error message when trying to upload a file at the survey theme options
Description

If a user with limited rights (see screenshot for details) tries uploading a new logo file at the theme options of his survey, he gets a meaningless "undefined" error. The file is a simple png file.
If I take the same file and log in as a different user with extended rights uploading that file at the survey's theme options works fine.

Steps To Reproduce

Set a user with limited rights (see screenshot).
Create a survey.
Assign it a custom template.
Make sure that the user has rights to use the template (see screenshot 2)
Try uploading a logo file at the theme options.

Additional Information

At the affected system, there are two custom themes available to all users, see second screenshot.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.0+190402
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2

Activities

Mazi

Mazi

2019-06-14 12:30

partner  

template_rights.png (72,980 bytes)
template_rights.png (72,980 bytes)
template_rights_user.png (14,582 bytes)
template_rights_user.png (14,582 bytes)
Mazi

Mazi

2019-06-14 13:19

partner   ~52414

@c_schmitz, FYI, this is a rather urgent issue since it prevents a large organization from using the themes we created for them. Would be awesome to see a fix at the next release.

Mazi

Mazi

2019-07-04 11:53

partner   ~52725

@cdorin, can you reproduce this one? It would be great if this can be fixed soon. I am visiting that customer on Tuesday and it would be nice to be able to tell them something like "We have tracked it down, a fix will be available at the next release.".

dominikvitt

dominikvitt

2019-07-04 13:03

developer   ~52728

@Mazi: I'll test it now.

dominikvitt

dominikvitt

2019-07-04 15:58

developer   ~52731

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.

https://github.com/LimeSurvey/LimeSurvey/commit/387c667fea5452bbde34ede862b3b32e85a2fe91

Issue History

Date Modified Username Field Change
2019-06-14 12:30 Mazi New Issue
2019-06-14 12:30 Mazi File Added: template_rights.png
2019-06-14 12:30 Mazi File Added: template_rights_user.png
2019-06-14 12:31 Mazi Relationship added related to 14717
2019-06-14 13:19 Mazi Note Added: 52414
2019-06-15 20:06 c_schmitz Assigned To => dominikvitt
2019-06-15 20:06 c_schmitz Status new => assigned
2019-07-04 11:52 Mazi Relationship deleted related to 14717
2019-07-04 11:53 Mazi Note Added: 52725
2019-07-04 13:03 dominikvitt Note Added: 52728
2019-07-04 15:58 dominikvitt Status assigned => resolved
2019-07-04 15:58 dominikvitt Resolution open => fixed
2019-07-04 15:58 dominikvitt Fixed in Version => 3.17.x
2019-07-04 15:58 dominikvitt Note Added: 52731