View Issue Details

IDProjectCategoryView StatusLast Update
14963Bug reports[All Projects] Survey editingpublic2019-06-19 14:09
Reportercdorin Assigned ToLouisGac  
PriorityimmediateSeveritymajor 
Status resolvedResolutionno change required 
Product Version3.17.x 
Target VersionFixed in Version 
Summary14963: Mobile phone - Display Arrays - Issues
Description

The following questions are not displayed correctly at the moment:

Space issues:

  • Array
  • Array by column
  • Array Increase Decrease
  • Array Yes/No
  • Array Dual Scale

Answer options not displayed:

  • Array 5 point choice
  • Array 10 point choice
  • Array Numbers (checkbox layout -> not sure if buggy, please see how it looks like)

The following issues have been replicated on both iOS and Android (different browsers such as Firefox, Safari, Brave)

The issue applies to both themes vanilla and fruity

Additional Information

Everything will have to be checked again after fix is applied.

Perhaps someone else can test and confirm if the list from above is correc/any other question type needs to be added?

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.4 (PRO)
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

duplicate of 14961 closedLouisGac Text is overlayed with the Radio Button on FF,Chrome tect … 
related to 14187 resolvedmarkusfluer In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack. 

Activities

cdorin

cdorin

2019-06-05 14:23

manager  

Screenshot_20190605-141108.png (110,491 bytes)
Screenshot_20190605-140824.png (213,150 bytes)
Screenshot_20190605-140859.png (133,455 bytes)
limesurvey_survey_282267.lss (562,381 bytes)
LouisGac

LouisGac

2019-06-05 15:07

manager   ~52304

it was working fine on Release 3.17.3+190429

LouisGac

LouisGac

2019-06-05 15:34

manager   ~52305

Last edited: 2019-06-05 15:37

View 2 revisions

that commit broke it:
https://github.com/LimeSurvey/LimeSurvey/commit/1a9cabec5cbeb53cd4942662ade89df2cce36f10

DenisChenu

DenisChenu

2019-06-06 08:52

developer   ~52309

Already reported … and reopen original issue …

DenisChenu

DenisChenu

2019-06-06 08:53

developer   ~52310

Last edited: 2019-06-06 08:56

View 2 revisions

@LouisGac : at same time : https://bugs.limesurvey.org/view.php?id=14962 maybe ?

Unsure it work in 3.17.3

Oups : included here

DenisChenu

DenisChenu

2019-06-06 17:19

developer   ~52323

@LouisGac : Array Numbers (checkbox layout -> not sure if buggy, please see how it looks like) : i take it. Not same issue, seems only in 3.17.4 not before

jelo

jelo

2019-06-12 09:36

partner   ~52351

Is this issue fixed or still open? A week has passed. 3.17.5 is the latest release.

dominikvitt

dominikvitt

2019-06-19 14:09

developer   ~52457

This issue is fixed, since the commit that created this issue was reverted.

Issue History

Date Modified Username Field Change
2019-06-05 14:23 cdorin New Issue
2019-06-05 14:23 cdorin Status new => assigned
2019-06-05 14:23 cdorin Assigned To => LouisGac
2019-06-05 14:23 cdorin File Added: Screenshot_20190605-141108.png
2019-06-05 14:23 cdorin File Added: Screenshot_20190605-140824.png
2019-06-05 14:23 cdorin File Added: Screenshot_20190605-140859.png
2019-06-05 14:23 cdorin File Added: limesurvey_survey_282267.lss
2019-06-05 14:24 cdorin Priority none => immediate
2019-06-05 14:25 cdorin Description Updated View Revisions
2019-06-05 14:25 cdorin Additional Information Updated View Revisions
2019-06-05 15:07 LouisGac Note Added: 52304
2019-06-05 15:34 LouisGac Note Added: 52305
2019-06-05 15:37 LouisGac Note Edited: 52305 View Revisions
2019-06-06 08:52 DenisChenu Relationship added duplicate of 14961
2019-06-06 08:52 DenisChenu Relationship added related to 14187
2019-06-06 08:52 DenisChenu Note Added: 52309
2019-06-06 08:53 DenisChenu Note Added: 52310
2019-06-06 08:56 DenisChenu Note Edited: 52310 View Revisions
2019-06-06 17:19 DenisChenu Note Added: 52323
2019-06-12 09:36 jelo Note Added: 52351
2019-06-19 14:09 dominikvitt Status assigned => resolved
2019-06-19 14:09 dominikvitt Resolution open => no change required
2019-06-19 14:09 dominikvitt Note Added: 52457
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing