View Issue Details

IDProjectCategoryView StatusLast Update
14187Bug reportsSurvey editingpublic2020-03-09 15:36
Reporterniwong Assigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.12.x 
Fixed in Version3.17.x 
Summary14187: In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack.
DescriptionLS 3.12.3 in IE11, for an Array type question with 6 answers, when the screen is resized to a point where the answers start to stack, the radio button disappears. In Chrome the radio buttons appear as expected.
Steps To ReproduceCreated a test survey using a core theme (vanilla) with 1 group and 1 question of type Array with 6 answers. Previewed the question in IE11, the question displays across the page. Resized the page to the point the answers start to stack. The radio button does not appear anymore. Note: this works as expected in Chrome.
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.12.3 (180627)
I will donate to the project if issue is resolvedNo
BrowserIE11
Database & DB-Versionsqlsrv { "DriverDllName": "msodbcsql11.dll", "DriverODBCVer": "03.80", "DriverVer": "12.00.5543", "ExtensionVer": "3.2.0.0" }
Server OS (if known)Windows NT RD0004FF9DAB63 10.0 build 14393 (Windows Server 2016) i586
Webserver software & version (if known)ls.dev.myontarioicu.net / Microsoft-IIS/10.0
PHP Version5.6.37

Relationships

related to 14961 closedLouisGac Text is overlayed with the Radio Button on FF,Chrome tect … 
related to 14963 closedLouisGac Mobile phone - Display Arrays - Issues 

Activities

jelo

jelo

2018-10-27 02:32

partner   ~49458

https://www.limesurvey.org/forum/design-issues/116788-in-ie,-for-an-array-question-the-radio-buttons-disappear-when-resizing-the-page#175968

Tony was able to reproduce issue with 3.15.1 and IE11.
alibert

alibert

2019-04-24 16:09

reporter   ~51573

I to was able to reproduce the issue with 3.17.0 and IE11 on our hosted version at limequery.org.
DenisChenu

DenisChenu

2019-04-24 16:39

developer   ~51574

If someone with IE11 can check with https://extensions.sondages.pro/themes-and-templates/skelvanilla-a11y-and-usuability/download.html ?
jelo

jelo

2019-05-17 18:14

partner   ~51987

Is this bug reproducible with every shipped theme?
The bug sits there since 2018-10-29. The IE11 support on client side seems to come to an end too.
markusfluer

markusfluer

2019-05-29 16:12

administrator   ~52165

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=28892
alibert

alibert

2019-06-04 07:59

reporter   ~52284

@markusfluer: This fix breaks every other browser (Firefox, Chrome on Win & Android). The Text is overlayed with the Radio Button (see attachement). Tested on 3.17.4 on our hosted version at limequery.org.
Our active Surveys are affected!

Possible flaw in template-core.css:
In second attachment (new template-core.css (left) vs old (right)) looks like yellow marked lines are executed for IE only, which triggers the flaw.
radio.PNG (12,574 bytes)   
radio.PNG (12,574 bytes)   
radio_flaw.png (72,446 bytes)   
radio_flaw.png (72,446 bytes)   
DenisChenu

DenisChenu

2019-06-05 08:37

developer   ~52302

Reported as new : https://bugs.limesurvey.org/view.php?id=14961
Mazi

Mazi

2019-06-17 09:58

partner   ~52428

This issue affects many users, hopefully, there will be a new release with a fix soon. I am attaching a screenshot based on using the vanilla theme with an iPhone.
iphone_issue.png (22,805 bytes)   
iphone_issue.png (22,805 bytes)   
Mazi

Mazi

2019-06-24 09:22

partner   ~52492

@markusfluer, two short questions by our customer: a) Will the fix for this issue be available at the next release? b) When will the next release be available?
dominikvitt

dominikvitt

2019-06-25 17:33

developer   ~52551

This issue is fixed.
The patch is available now on GitHub and would be available on next LimeSurvey release.

https://github.com/LimeSurvey/LimeSurvey/commit/57493216cfab0ad3be1b48faf664d45514cdfdca
markusfluer

markusfluer

2019-06-28 12:27

administrator   ~52621

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29031

Related Changesets

LimeSurvey: master 1a9cabec

2019-05-17 22:32:00

markusfluer

Details Diff
Fixed issue 14187: In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack. Affected Issues
14187
mod - assets/packages/template-core/template-core.css Diff File

LimeSurvey: master 4a99f402

2019-05-17 22:32:00

markusfluer


Committer: LouisGac Details Diff
Revert "Fixed issue 14187: In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack."

This reverts commit 1a9cabec5cbeb53cd4942662ade89df2cce36f10.
Affected Issues
14187
mod - assets/packages/template-core/template-core.css Diff File

LimeSurvey: master b9a7a63d

2019-05-20 13:18:00

markusfluer

Details Diff
Fixed issue 14187: (Revisited) In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack. Affected Issues
14187
mod - assets/packages/template-core/template-core.css Diff File

LimeSurvey: master 57493216

2019-06-25 17:29:55

Dominik Vitt

Details Diff
Fixed issue 14187: In IE, for an Array question the radio buttons disappear when resizing the page to the point the answers start to stack Affected Issues
14187
mod - assets/packages/template-core/template-core.css Diff File

Issue History

Date Modified Username Field Change
2018-10-26 18:36 niwong New Issue
2018-10-27 02:32 jelo Note Added: 49458
2018-10-29 11:01 LouisGac Assigned To => markusfluer
2018-10-29 11:01 LouisGac Status new => assigned
2019-04-24 16:09 alibert Note Added: 51573
2019-04-24 16:39 DenisChenu Note Added: 51574
2019-05-17 18:14 jelo Note Added: 51987
2019-05-29 16:12 markusfluer Changeset attached => LimeSurvey master b9a7a63d
2019-05-29 16:12 markusfluer Changeset attached => LimeSurvey master 1a9cabec
2019-05-29 16:12 markusfluer Note Added: 52165
2019-05-29 16:12 markusfluer Resolution open => fixed
2019-06-04 07:59 alibert File Added: radio.PNG
2019-06-04 07:59 alibert File Added: radio_flaw.png
2019-06-04 07:59 alibert Note Added: 52284
2019-06-05 08:37 DenisChenu Note Added: 52302
2019-06-05 08:40 DenisChenu Relationship added related to 14961
2019-06-06 08:52 DenisChenu Relationship added related to 14963
2019-06-17 09:58 Mazi File Added: iphone_issue.png
2019-06-17 09:58 Mazi Note Added: 52428
2019-06-24 09:22 Mazi Note Added: 52492
2019-06-25 17:33 dominikvitt Assigned To markusfluer => dominikvitt
2019-06-25 17:33 dominikvitt Status assigned => resolved
2019-06-25 17:33 dominikvitt Fixed in Version => 3.17.x
2019-06-25 17:33 dominikvitt Note Added: 52551
2019-06-28 12:27 Changeset attached => LimeSurvey master 57493216
2019-06-28 12:27 LouisGac Changeset attached => LimeSurvey master 4a99f402
2019-06-28 12:27 markusfluer Note Added: 52621
2019-06-28 12:27 markusfluer Assigned To dominikvitt => markusfluer
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2020-03-09 15:36 c_schmitz Status resolved => closed