View Issue Details

IDProjectCategoryView StatusLast Update
14921Bug reports[All Projects] Survey takingpublic2019-08-14 12:36
ReportermaxersloanAssigned Tomarkusfluer 
PrioritynoneSeveritymajor 
Status resolvedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version3.17.x 
Summary14921: Ranking question on mobile devices (problem with dragging/scrolling)
Description

I found an issue with the ranking question when I tested the survey on my iPhone (any browser). It will only let me drag and drop directly across (horizontally) from the "choices" to the "ranking". If I try to move it up or down, it scrolls the page. The same thing happens if I try to move answers in the "ranking" section up or down. So I'm unable to properly rank them. It is especially problematic if the answer options are long and you need the ability to scroll.

Also, the "ranking_advanced" option is actually impossible to answer on my iPhone. (I'm unsure if these problems also exist for Android, I don't have a device to test with).

Here is an example. I've also attached the survey. The first group has long answers. The second group has short answers. It happens with both versions that I'm using: 3.17.3+190429 and 2.6.7-lts Build 171212.

www.datamaxsurveys.net/survey/index.php/442798?lang=en

I'm new to 3.0, so I'm not sure if there's maybe just a setting or a template/theme adjustment that I need to make? But based on previous posts on this issue, it seems like a difficult one to solve. The issue is the same using 2.6lts (using a mobile-optimized template I purchased from LimeSurvey Template Shop).

Steps To Reproduce

Take survey on iPhone. It may also be an issue for mobile devices in general.

Additional Information

https://www.limesurvey.org/forum/design-issues/118457-ranking-question-on-mobile-devices-problem-with-dragging-scrolling

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.3+190429
I will donate to the project if issue is resolvedNo
BrowserAny
Database & DB-VersionUnknown
Server OS (if known)Unknown
Webserver software & version (if known)Unknown
PHP VersionUnknown

Activities

maxersloan

maxersloan

2019-05-21 16:30

reporter  

limesurvey_survey_442798.lss (27,684 bytes)
cdorin

cdorin

2019-06-27 18:10

manager   ~52600

ranking_Advanced causes me issues on my Android mobile (the same issues as described above).

However, I do not have any problem ranking the answer options from the standard question type.

Mazi

Mazi

2019-08-14 09:04

partner   ~53173

@cdorin, can you please assign this to a dev to have a look? It looks like it affects quite a few users, see https://www.limesurvey.org/forum/design-issues/118457-ranking-question-on-mobile-devices-problem-with-dragging-scrolling

markusfluer

markusfluer

2019-08-14 12:36

administrator   ~53174

Tested with iphone emulator
Version iPhone X, iPhone 8 and IPhone SE

Issue History

Date Modified Username Field Change
2019-05-21 16:30 maxersloan New Issue
2019-05-21 16:30 maxersloan File Added: limesurvey_survey_442798.lss
2019-05-21 22:31 jelo Description Updated View Revisions
2019-05-21 22:31 jelo Additional Information Updated View Revisions
2019-06-27 18:10 cdorin Note Added: 52600
2019-08-14 09:04 Mazi Note Added: 53173
2019-08-14 09:31 cdorin Assigned To => markusfluer
2019-08-14 09:31 cdorin Status new => assigned
2019-08-14 12:36 markusfluer Status assigned => resolved
2019-08-14 12:36 markusfluer Resolution open => fixed
2019-08-14 12:36 markusfluer Fixed in Version => 3.17.x
2019-08-14 12:36 markusfluer Note Added: 53174