View Issue Details

IDProjectCategoryView StatusLast Update
14908Bug reports[All Projects] Data Entry (non public)public2019-08-26 14:31
Reporterthuenen_agraroekonomie Assigned Top_teichmann  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version3.17.x 
Target VersionFixed in Version 
Summary14908: The Button "exit and clear survey entrys" on the last page (endmessage)
Description

If a patricipiant fill out the survey and submit the answers, he comes to the last page, the end message. In the right upper corner exist the button "exit and clear survey". If the user push the button, the message appears "answers cleared", restart the survey.
In reality the response is not cleared in the database. The response is only cleared in online-formular. If you restart the survey this is a new answer, with a new entry in the database.

Steps To Reproduce

The survey language is English. The survey is not public listed. There is no cookie set, to prevent double answers, The template is "Bootswatch" . The participiants need no key, only the url of the survey.

Additional Information

I'm not sure, wether it is a bug or a feature, because in the case of the survey, the option "Set cookie and allow only one answer" is set to FALSE.
But if it is a feature, the wording leads to missinterpretation.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.17.3 190429
I will donate to the project if issue is resolvedNo
BrowserFirefox 66.05 (x64)
Database & DB-VersionMySQL mysqlnd 5.0.12-dev - 20150407
Server OS (if known)Linux ubuntu 18.04 LTS
Webserver software & version (if known)Apache
PHP Version7.2.18

Activities

thuenen_agraroekonomie

thuenen_agraroekonomie

2019-05-17 12:26

reporter   ~51985

I think, the standard should be, that after "submit" the button "exit and clear survey" should not appear.

cdorin

cdorin

2019-07-31 13:25

manager   ~53053

Last edited: 2019-07-31 13:26

View 2 revisions

@DenisChenu, do you know anything about the correct behaviour? I personally do not see the purpose of "exit and clear survey" after submitting a form. If the wording is wrong, then we should have: restart survey.

DenisChenu

DenisChenu

2019-08-04 10:14

developer   ~53081

@cdorin : it's a new issue, i'm sure it was already reported (and fixed) in 2.5X
I think it not shown in 3.0 , didn't known when it shown.

p_teichmann

p_teichmann

2019-08-09 16:23

administrator   ~53159

The intended behaviour is that the button should not be shown on the first and last page of the survey.

fixed in https://github.com/LimeSurvey/LimeSurvey/commit/3deda90f665caab5a1d74082ff47ab670fbef903

lime_release_bot

lime_release_bot

2019-08-26 14:31

administrator   ~53257

Fixed in Release 3.17.10+190821

Issue History

Date Modified Username Field Change
2019-05-17 12:20 thuenen_agraroekonomie New Issue
2019-05-17 12:26 thuenen_agraroekonomie Note Added: 51985
2019-05-20 18:14 dominikvitt Assigned To => dominikvitt
2019-05-20 18:14 dominikvitt Status new => assigned
2019-07-15 11:41 dominikvitt Assigned To dominikvitt => cdorin
2019-07-31 13:22 cdorin Assigned To cdorin => p_teichmann
2019-07-31 13:22 cdorin Priority none => normal
2019-07-31 13:25 cdorin Note Added: 53053
2019-07-31 13:26 cdorin Note Edited: 53053 View Revisions
2019-08-04 10:14 DenisChenu Note Added: 53081
2019-08-09 16:23 p_teichmann Status assigned => resolved
2019-08-09 16:23 p_teichmann Resolution open => fixed
2019-08-09 16:23 p_teichmann Note Added: 53159
2019-08-26 14:31 lime_release_bot Note Added: 53257
2019-08-26 14:31 lime_release_bot Status resolved => closed