View Issue Details

IDProjectCategoryView StatusLast Update
14680Bug reportsSurvey editingpublic2021-05-10 13:32
ReporterDeusdeorum Assigned Togabrieljenik  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version4.4.1 
Summary14680: Set condition on token attribute does not work in GUI
DescriptionIf you head over to the "set condition" and to "Survey participant attributes" and try to set condition on any of those field names it will still set the condition on what you marked in "Previous questions".
Steps To Reproducei) Create a survey with a question or two.
ii) Add a token table
iii) Go to one of your questions and to the "Survey participant attributes" select "usesleft" and constant equals to 0 or something.

Then the condition will still be set on what you marked on "Previous questions".
TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.15.8
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmysqlnd 5.0.12-dev latest DB for LS
Server OS (if known)
Webserver software & version (if known)
PHP Version 7.0.27-0+deb9u1

Activities

cdorin

cdorin

2021-02-03 10:18

manager   ~61873

Hey @Deusdeorum - can you test in latest LTS? Couldn't reproduce the issue
Deusdeorum

Deusdeorum

2021-02-03 10:50

reporter   ~61878

I can confirm this in the demo.limesurvey.org version, maybe im missing something obvious?
cdorin

cdorin

2021-02-03 14:35

manager   ~61890

I confirm I could reproduce it in 4.4.1 (not in LTS)
gabrieljenik

gabrieljenik

2021-05-10 13:32

manager   ~64316

Not reproducible. Probably fixed with 15051

Issue History

Date Modified Username Field Change
2019-03-22 15:38 Deusdeorum New Issue
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2019-11-26 18:05 cdorin Assigned To => cdorin
2019-11-26 18:05 cdorin Status new => assigned
2020-02-22 21:56 cdorin Status assigned => confirmed
2020-12-28 18:53 cdorin Assigned To cdorin => adamzammit
2020-12-28 18:53 cdorin Priority none => normal
2020-12-29 09:37 cdorin Assigned To adamzammit =>
2021-02-03 10:18 cdorin Status confirmed => feedback
2021-02-03 10:18 cdorin Note Added: 61873
2021-02-03 10:50 Deusdeorum Note Added: 61878
2021-02-03 10:50 Deusdeorum Status feedback => new
2021-02-03 14:35 cdorin Product Version 3.15.x => 4.4.1
2021-02-03 14:35 cdorin Note Added: 61890
2021-02-03 14:36 cdorin Status new => confirmed
2021-04-30 16:12 gabrieljenik Assigned To => gabrieljenik
2021-04-30 16:12 gabrieljenik Status confirmed => assigned
2021-05-10 13:32 gabrieljenik Status assigned => closed
2021-05-10 13:32 gabrieljenik Resolution open => fixed
2021-05-10 13:32 gabrieljenik Note Added: 64316