View Issue Details

IDProjectCategoryView StatusLast Update
14453Bug reports[All Projects] Response browsingpublic2019-04-30 09:11
Reporteroleggorfinkel Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.15.x 
Summary14453: Deletion of responses broken in 3.15.6+190108
Description

Responses can no longer be deleted either by selecting them in the list and then pressing "Selected Response(s)..."->Delete (the confirmation dialog never comes up), or clicking on the trash can icon for an individual response (in this case, the confirmation dialog does come up, but clicking on OK has no effect at all).

Steps To Reproduce

Display responses for an active survey, then either select one or more responses in the list and click "Selected Response(s)..."->Delete, or click the trash can icon for a single response.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.15.6+190108
I will donate to the project if issue is resolvedNo
BrowserChrome or Edge
Database & DB-Version10.0.27-MariaDB-cll-lve
Server OS (if known)Linux
Webserver software & version (if known)Apache 2.4.18
PHP Version5.5.36

Relationships

has duplicate 14481 closedDenisChenu Filter of answers not working 
has duplicate 14493 closedDenisChenu In Show responses the filters do not work 
has duplicate 14696 closedDenisChenu Answer can not be deleted 
has duplicate 14697 closedDenisChenu Total view of answers in list is not shown correctly 

Activities

DenisChenu

DenisChenu

2019-01-27 19:41

developer   ~50322

Confirm
See console.log



DenisChenu

DenisChenu

2019-01-27 19:50

developer   ~50323

Oh non, not exactly : reloading page : it's OK …

Seems to be due to ajax system ?

DenisChenu

DenisChenu

2019-01-27 19:58

developer  

DenisChenu

DenisChenu

2019-01-27 19:58

developer   ~50324

@markusfluer : seems jquery.yiigridview.js are not loaded at good time.

Reproduce :

  1. Goes to browse response
  2. Click on Summary
  3. Click on Display response
    3.a : have the console error about yiiGridView
  4. Click on trash
    4.a : settings in undefined
  5. Reload page
  6. All is OK
DenisChenu

DenisChenu

2019-01-28 08:52

developer   ~50326

Last edited: 2019-01-28 08:54

View 2 revisions

Updating grid by click on id fix the issue too

ScreenCast : https://framadrop.org/r/pcat3vR1vU#XwI4UnD1nTYau3nwx/rTXReR+DIZjdmcwk0EyhmHgwo=

DenisChenu

DenisChenu

2019-01-28 11:10

developer   ~50328

git checkout b14e8fc1fc458dbe1c1e570c21b16fb91810a2e4 : same issue : https://github.com/LimeSurvey/LimeSurvey/commit/b14e8fc1fc458dbe1c1e570c21b16fb91810a2e4#diff-0967a202cf1e202f8edf00125da7ce6a
Resetting cache after all checkout to be sure to have the last one, and

  1. goes to Survey Overview
  2. Survey response
  3. Browse response
  4. Click on delete : 2 dialog boxes

Reloading always fix the issue

DenisChenu

DenisChenu

2019-02-04 08:17

developer   ~50391

Seems to be since 3.15.6+190108

DenisChenu

DenisChenu

2019-02-04 09:19

developer   ~50392

https://github.com/LimeSurvey/LimeSurvey/commit/463f274f567e6e4c4307527c0feb73883b285f9e

Issue History

Date Modified Username Field Change
2019-01-27 13:07 oleggorfinkel New Issue
2019-01-27 19:41 DenisChenu File Added: Capture d’écran du 2019-01-27 19-40-44.png
2019-01-27 19:41 DenisChenu Note Added: 50322
2019-01-27 19:41 DenisChenu Assigned To => DenisChenu
2019-01-27 19:41 DenisChenu Status new => assigned
2019-01-27 19:50 DenisChenu Note Added: 50323
2019-01-27 19:55 DenisChenu Assigned To DenisChenu => markusfluer
2019-01-27 19:58 DenisChenu File Added: Capture d’écran du 2019-01-27 19-54-51.png
2019-01-27 19:58 DenisChenu Note Added: 50324
2019-01-28 08:52 DenisChenu Note Added: 50326
2019-01-28 08:54 DenisChenu Note Edited: 50326 View Revisions
2019-01-28 11:10 DenisChenu Note Added: 50328
2019-02-02 18:51 DenisChenu Relationship added related to 14481
2019-02-04 08:17 DenisChenu Note Added: 50391
2019-02-04 09:15 DenisChenu Assigned To markusfluer => DenisChenu
2019-02-04 09:19 DenisChenu Status assigned => resolved
2019-02-04 09:19 DenisChenu Resolution open => fixed
2019-02-04 09:19 DenisChenu Fixed in Version => 3.15.x
2019-02-04 09:19 DenisChenu Note Added: 50392
2019-02-04 09:20 DenisChenu Relationship deleted related to 14481
2019-02-04 09:20 DenisChenu Relationship added has duplicate 14481
2019-02-06 08:57 DenisChenu Relationship added has duplicate 14493
2019-03-27 14:25 DenisChenu Relationship added has duplicate 14696
2019-03-27 14:26 DenisChenu Relationship added has duplicate 14697
2019-04-30 09:11 c_schmitz Status resolved => closed