View Issue Details

IDProjectCategoryView StatusLast Update
14443Bug reports[All Projects] _ Unknownpublic2019-08-26 14:32
Reporterritapas Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version3.15.x 
Target VersionFixed in Version3.17.x 
Summary14443: "Go to survey" menu icon not working in collapsed menu mode
Description

When the menu is collapsed, there are four new icons in the left menu:
-Stop (or Activate) this survey
-Go to survey
-Survey logic file
-Central participant database

The "Go to survey" icon does not work: you get a "403 Forbidden - Invalid survey id" in our 3.15.5.181115-1 version while in the official demo version it takes you the home page demo.limesurvey.org

Steps To Reproduce

Create a survey
Collapse the left menu
click on the "Go to survey" icon

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.5+181115
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Version MariaDB 5.5.60
Server OS (if known)
Webserver software & version (if known)
PHP Versionrh-php71-1-1

Activities

ritapas

ritapas

2019-01-18 15:56

reporter  

GoToSurvey.PNG (69,872 bytes)
GoToSurvey.PNG (69,872 bytes)
DenisChenu

DenisChenu

2019-01-18 19:11

developer   ~50282

And in mine : http://limesurvey.local/master/survey/index/ 404 :)

DenisChenu

DenisChenu

2019-01-18 19:14

developer   ~50283

The issue is : it must be an external link (to open in blank) but external link disable sid added at end.

fradeff

fradeff

2019-08-08 08:28

reporter   ~53146

bug confirmed on many limesurveys, v. 3.17.8 - by me it's a 403 too

lime_release_bot

lime_release_bot

2019-08-26 14:32

administrator   ~53258

Fixed in Release 3.17.10+190821

Issue History

Date Modified Username Field Change
2019-01-18 15:56 ritapas New Issue
2019-01-18 15:56 ritapas File Added: GoToSurvey.PNG
2019-01-18 19:11 DenisChenu Note Added: 50282
2019-01-18 19:14 DenisChenu Note Added: 50283
2019-02-07 16:12 dominikvitt Assigned To => dominikvitt
2019-02-07 16:12 dominikvitt Status new => assigned
2019-02-08 10:28 dominikvitt Assigned To dominikvitt => markusfluer
2019-08-08 08:28 fradeff Note Added: 53146
2019-08-08 16:51 markusfluer Status assigned => resolved
2019-08-08 16:51 markusfluer Resolution open => fixed
2019-08-08 16:51 markusfluer Fixed in Version => 3.17.x
2019-08-26 14:32 lime_release_bot Note Added: 53258
2019-08-26 14:32 lime_release_bot Status resolved => closed