View Issue Details

IDProjectCategoryView StatusLast Update
14423Bug reports[All Projects] MenuSystempublic2019-05-23 14:48
ReporterKompetenzZAssigned Toc_schmitz 
PrioritynoneSeveritytext 
Status closedResolutionduplicate 
Product Version3.15.x 
Target VersionFixed in Version 
Summary14423: ambiguous terms in the options of the multiple numeric input question
Description

I don’t know if I can answer to a closed issue. Therefore, I opened a new one. My following comment is related to this issue:

https://bugs.limesurvey.org/view.php?id=14189

Two months ago I didn't understand Denis answer to the concerning closed issue. But now I read it again because I have got an e-mail that this issue has been closed. I understand now what is meant by Denis answer, thank you, Denis.

However, the option name "Text input size" in "Edit" of a multiple numeric input question is confusing. I thought all the time that you can change the font size with the option "Text input size". Using the term "size", when actually "width" is meant here is substantially ambiguous. This option should be changed to "Width of the text input box" or something. This term would also be more consistent with the other relevant option here "label column width". But even then it is questionable why the term “text” is used, when the respondent should type in numbers here. I guess “Width of the numerical input box” would be more appropriate.
Even when I hover over the option "Text input size" it is said:
“Set the size to the input or textarea [sic], the input will be displayed with approximately this size in width.”
Same here, make the sentence shorter and replace “size” with “width”, then it would be clearer. And by the way there is a space missing in: textarea.

Steps To Reproduce

screenshot is attached.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.15.5
I will donate to the project if issue is resolvedYes
Browser
Database & DB-Version?
Server OS (if known)
Webserver software & version (if known)
PHP Version?

Relationships

duplicate of 13589 assignedcdorin Label column width - misleading name 

Activities

KompetenzZ

KompetenzZ

2019-01-11 16:46

reporter  

asdfasdf.PNG (193,198 bytes)
KompetenzZ

KompetenzZ

2019-01-13 16:24

reporter   ~50184

Hi,

I tinkered around with these options and this sentence of my previous post should be deleted, sorry: "But even then it is questionable why the term “text” is used, when the respondent should type in numbers here. I guess “Width of the numerical input box” would be more appropriate."

Because it's actually the text width of the subquestion that changes with this option.

I realized that that this term might be better: "width of the subquestion text"

And: A unit for this option would also be good.

DenisChenu

DenisChenu

2019-01-14 01:50

developer   ~50185

We already have width for "wrapper" : label and input box part.

Size is really size input size="2" : https://duckduckgo.com/?q=input+size => https://www.w3.org/TR/html401/interact/forms.html#adef-size-INPUT . It's not related to view , it's related to semantic.
Width is related to view : related to width of the box : https://getbootstrap.com/docs/3.3/css/#grid-options (it's the reason why you have 12 size).

See screenshot for multiple text. And remind : same settings => same help (for short text, long text, numeric, multiple text and multiple numeric : https://github.com/LimeSurvey/LimeSurvey/blob/f722577fb856ac0e9392146d9fcbd63937f028e4/application/helpers/questionHelper.php#L729).



Issue History

Date Modified Username Field Change
2019-01-11 16:46 KompetenzZ New Issue
2019-01-11 16:46 KompetenzZ Status new => assigned
2019-01-11 16:46 KompetenzZ Assigned To => markusfluer
2019-01-11 16:46 KompetenzZ File Added: asdfasdf.PNG
2019-01-13 16:24 KompetenzZ Note Added: 50184
2019-01-14 01:50 DenisChenu File Added: Capture d’écran du 2019-01-14 01-33-25.png
2019-01-14 01:50 DenisChenu File Added: Capture d’écran du 2019-01-14 01-41-02.png
2019-01-14 01:50 DenisChenu Note Added: 50185
2019-01-14 01:50 DenisChenu Assigned To markusfluer => c_schmitz
2019-05-23 14:48 c_schmitz Relationship added duplicate of 13589
2019-05-23 14:48 c_schmitz Status assigned => closed
2019-05-23 14:48 c_schmitz Resolution open => duplicate