View Issue Details

IDProjectCategoryView StatusLast Update
14311Bug reports[All Projects] Import/Exportpublic2019-03-22 17:56
Reporterdatamunger Assigned ToLouisGac  
PrioritynoneSeveritymajor 
Status feedbackResolutionreopened 
Product Version3.0.x 
Target VersionFixed in Version 
Summary14311: Attribute values beginning with a "<"-sign are omitted during SPSS export
Description

When using the functionality SPSS-export to export survey results, attributes are usually exported as string variables. If the string begins with a "<" (less-than) sign, the result is omitted for that case.

Steps To Reproduce

Create a survey with participant list, assign an attribute, give the attribute a string value beginning with "<", fill in the surveys, then export the responses for SPSS.
The .dat file will have empty cells where the "<" should be, and the resulting .sav file will show these cells as missing values.

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.73.1+171220
I will donate to the project if issue is resolvedNo
Browserall browsers
Database & DB-Versionunknown
Server OS (if known)
Webserver software & version (if known)
PHP Versionunknown

Activities

LouisGac

LouisGac

2019-01-10 16:28

manager   ~50162

2.74 is not maintened anymore.
Do you face the same problem in 3.x?

datamunger

datamunger

2019-02-18 08:44

reporter   ~50589

Hi! We have updated our Limesurvey installation to version 3.15.6+190108 and it appears that the problem still persists.

Issue History

Date Modified Username Field Change
2018-12-03 12:46 datamunger New Issue
2019-01-10 16:28 LouisGac Assigned To => LouisGac
2019-01-10 16:28 LouisGac Status new => feedback
2019-01-10 16:28 LouisGac Note Added: 50162
2019-01-18 16:06 LouisGac Status feedback => closed
2019-01-18 16:06 LouisGac Resolution open => unable to reproduce
2019-02-18 08:44 datamunger Status closed => feedback
2019-02-18 08:44 datamunger Resolution unable to reproduce => reopened
2019-02-18 08:44 datamunger Note Added: 50589
2019-03-22 17:56 datamunger Issue cloned: 14681