View Issue Details

IDProjectCategoryView StatusLast Update
14077Bug reports[All Projects] Survey designpublic2019-08-30 13:25
Reportermarcgold Assigned Toc_schmitz  
PrioritynoneSeveritymajor 
Status closedResolutionunable to reproduce 
Product Version3.13.x 
Target VersionFixed in Version 
Summary14077: Browser Crash when attempting to ad images CKImage
Description

When trying to add images to the question or sub question and uploading these images to the server when selecting the browse server button the webpage physically crashes.

you need to restart the browser page to bring this back.

Steps To Reproduce

Add Question - Switch To HTML edit mode, add image, browse server.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.9+180917
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Server OS (if known)Linux 2.6.32-696.28.1.el6.x86_64 #1
Webserver software & version (if known)Apache
PHP Version7.2.29

Activities

marcgold

marcgold

2018-09-18 17:10

reporter  

Screen Shot 2018-09-18 at 16.06.22.png (196,276 bytes)
marcgold

marcgold

2018-10-12 14:44

reporter   ~49311

Any News with this, none of my users are able to upload images for use in the surveys. The only way is to manually upload them directly to the server.

LouisGac

LouisGac

2018-10-12 15:02

manager   ~49314

in ls4 we'll remove CK4 to update to CK5

DenisChenu

DenisChenu

2018-10-14 19:05

developer   ~49320

Work but badly with firefox



c_schmitz

c_schmitz

2018-10-16 16:23

administrator   ~49339

I cannot reproduce this at all - Chrome & Firefox works here just fine. Maybe missing permissions?

DenisChenu

DenisChenu

2018-10-16 17:22

developer   ~49341

Last edited: 2018-10-16 17:22

View 2 revisions

Confirm it seems fixed on last git version .
No permission issue, but sometimes my internet are really slow :)

Deusdeorum

Deusdeorum

2018-10-18 14:14

reporter   ~49360

I can confirm that this happens for some mac users when using chrome. When you click "browse server" the screen freezes and you'll have to reload the page. It works for me, but I tried another computer where it does not work, same chrome version, only different osx.

DenisChenu

DenisChenu

2018-10-19 09:24

developer   ~49367

@Deusdeorum : can you have a look at "console" when it's happen ?

Deusdeorum

Deusdeorum

2018-10-19 09:44

reporter   ~49368

@DenisChenu I cannot access the log of the KCfinder popup because it's freezing. Any suggestion to see that log?

DenisChenu

DenisChenu

2018-10-19 10:03

developer   ~49369

Last edited: 2018-10-19 10:07

View 3 revisions

Arg … solution :

  1. Open a new tab
  2. activate console on this tab
  3. copy link (and open) of the popup inside this tab
  4. If you can't copy : it's somethink like this ./index.php?r=admin/htmleditor_pop/sa/index/name/question_en/text/[Question:](en)/type/question-text/action/editquestion/sid/282267/gid/10/qid/26/lang/en

Else : if it doesn't work inline too : activate console before open question editor maybe …

marcgold

marcgold

2018-10-19 17:39

reporter   ~49383

Someone mentioned it may have been a permissions problem. So this is an interesting development.

LS has been updated to latest 3.15.1 and have just updated the OS to Mojave OSX 10.14 and Chrome Version is 70.0.3538.67 (Official Build) (64-bit).

Now when trying to invoke the Browser getting permission denied (Issue is consistent on Safari, FF and Chrome).



marcgold

marcgold

2018-10-19 17:48

reporter   ~49384

Sorry, Please ignore the last post, just realised that i was in the create survey screen and had not saved so there was no Survey ID Yet. This is going to be a prerequisite as it uses the ID to create folder in the upoads/surveys folder.

marcgold

marcgold

2018-10-19 18:46

reporter   ~49385

I can confirm that this seems to be working in the current Git Build (ie post commit of build 3.15.1).
Tested in Latest MAMP PRO 5.1.1 with PHP 7.2.8 and Apache 2

DenisChenu

DenisChenu

2018-11-05 19:28

developer   ~49543

@marcgold : i have no idea of this error : i don't have error on 4 different system …

marcgold

marcgold

2019-03-26 16:38

reporter   ~51138

I know this has been open for a little while, but just needed to use this again. And it's still failing. This is on a new instance NginX, Postgresql, LS 13.16.1 Latest.
Desktop is still OSX 10.14.3 Chrome Version 72.0.3626.121 (Official Build) (64-bit). Interestingly same error in Windows 10 with same Chrome Build (VM Machine)

Works without issue in Safari.

c_schmitz

c_schmitz

2019-08-30 13:25

administrator   ~53352

I am sorry but nobody else can reproduce this.
There were also no other users reporting a similar problem. We cannot fix it if we cannot reproduce it.
I will therefore close this issue for now. If you have new insight on the cause of this issue please feel free to re-open it.

Issue History

Date Modified Username Field Change
2018-09-18 17:10 marcgold New Issue
2018-09-18 17:10 marcgold File Added: Screen Shot 2018-09-18 at 16.06.22.png
2018-10-12 14:44 marcgold Note Added: 49311
2018-10-12 15:02 LouisGac Note Added: 49314
2018-10-14 19:05 DenisChenu File Added: Capture du 2018-10-14 19-03-23.png
2018-10-14 19:05 DenisChenu Note Added: 49320
2018-10-16 16:23 c_schmitz Note Added: 49339
2018-10-16 16:25 c_schmitz Assigned To => c_schmitz
2018-10-16 16:25 c_schmitz Status new => feedback
2018-10-16 17:22 DenisChenu Note Added: 49341
2018-10-16 17:22 DenisChenu Note Edited: 49341 View Revisions
2018-10-18 14:14 Deusdeorum Note Added: 49360
2018-10-19 09:24 DenisChenu Note Added: 49367
2018-10-19 09:44 Deusdeorum Note Added: 49368
2018-10-19 10:03 DenisChenu Note Added: 49369
2018-10-19 10:07 DenisChenu Note Edited: 49369 View Revisions
2018-10-19 10:07 DenisChenu Note Edited: 49369 View Revisions
2018-10-19 17:39 marcgold File Added: Screenshot 2018-10-19 at 16.33.17.png
2018-10-19 17:39 marcgold Note Added: 49383
2018-10-19 17:39 marcgold Status feedback => assigned
2018-10-19 17:48 marcgold Note Added: 49384
2018-10-19 18:46 marcgold Note Added: 49385
2018-11-05 19:28 DenisChenu Note Added: 49543
2019-03-26 16:38 marcgold Note Added: 51138
2019-08-30 13:25 c_schmitz Status assigned => closed
2019-08-30 13:25 c_schmitz Resolution open => unable to reproduce
2019-08-30 13:25 c_schmitz Note Added: 53352