View Issue Details

IDProjectCategoryView StatusLast Update
14033Bug reports[All Projects] _ Unknownpublic2018-09-26 12:54
ReportergeraldCAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.13.x 
Target VersionFixed in Version3.14.x 
Summary14033: Re-ordering groups when a group is open using Structure drag & drop fails
Description

Re-ordering a group using drag & drop facilities when another group is open and contains at least 1 question,

Steps To Reproduce

Create a survey.
Create some groups (G1-G2-G3-G4-...).
Add questions to a group.
Open this group in Structure (drag and drop).
Try to move another group.
Results : groups that have not been selected have moved
(for example, opening G2 (that has q1-q2-q3-...) and trying to move G3 modifies the sequence of groups from G1-G2-G3-G4-G5-G6-G7-G8-...) to G1-G2-G5-G4-G3-G6-G7-G8-G9

Additional Information

It seems that the size of the opened group (i.e. the number of questions) has an impact on which group will be moved erroneously.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.8
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Operating System (Server)not relevant
Webserver software & versionnot relevant
PHP Versionnot relevant

Relationships

has duplicate 14059 resolvedmarkusfluer Reordering groups on the "Structure" tab fails and causes questions to be lost 

Activities

geraldC

geraldC

2018-09-05 15:08

reporter   ~48976

See https://demo.limesurvey.org/index.php?r=admin/survey/sa/view&surveyid=894918 for an example

DenisChenu

DenisChenu

2018-09-07 15:53

developer   ~48988

demo is resetted each night. Please : send the exported lss file

LouisGac

LouisGac

2018-09-10 10:52

manager   ~48993

same bug?
https://github.com/LimeSurvey/LimeSurvey/commit/70b8ec370daa449acbba084d3427694ab9a35323

geraldC

geraldC

2018-09-14 08:14

reporter   ~49030

Within this questionnaire, open group 2 (G2) and try for instance to move g5 after g7



limesurvey_survey_618349.lss (17,999 bytes)
markusfluer

markusfluer

2018-09-14 12:53

manager   ~49035

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27951

geraldC

geraldC

2018-09-19 08:50

reporter   ~49082

Sorry. Still doesn't work.
To reproduce :

  1. open g2
  2. select g5 in order to move it
  3. as soon as the mouse begin to move, g9 takes the g5 position


limesurvey_survey_618349-2.lss (17,999 bytes)
geraldC

geraldC

2018-09-19 08:51

reporter   ~49083

Sorry. Still doesn't work.
To reproduce :

  1. open g2
  2. select g5 in order to move it
  3. as soon as the mouse begin to move, g9 takes the g5 position
LouisGac

LouisGac

2018-09-19 10:55

manager   ~49085

wait for the release...

geraldC

geraldC

2018-09-19 17:34

reporter   ~49093

Although I replaced the files on our server with those from github ?

markusfluer

markusfluer

2018-09-26 12:54

manager   ~49134

Can't reproduce the issue anymore so this stays closed for now.
(tested Chrome 69, FF 62, IE 11)

Related Changesets

LimeSurvey: master c38748ad

2018-09-14 12:52:27

markusfluer

Details Diff
Fixed issue 14033: Re-ordering groups when a group is open using Structure drag & drop fails
mod - application/controllers/admin/questiongroups.php Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.debug.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.min.js Diff File
mod - assets/packages/adminpanel/src/components/subcomponents/_questionsgroups.vue Diff File

Issue History

Date Modified Username Field Change
2018-09-05 15:04 geraldC New Issue
2018-09-05 15:08 geraldC Note Added: 48976
2018-09-07 15:53 DenisChenu Note Added: 48988
2018-09-10 10:51 LouisGac Assigned To => markusfluer
2018-09-10 10:51 LouisGac Status new => assigned
2018-09-10 10:52 LouisGac Note Added: 48993
2018-09-14 08:14 geraldC File Added: limesurvey_survey_618349.lss
2018-09-14 08:14 geraldC Note Added: 49030
2018-09-14 12:53 markusfluer Changeset attached => LimeSurvey master c38748ad
2018-09-14 12:53 markusfluer Note Added: 49035
2018-09-14 12:53 markusfluer Resolution open => fixed
2018-09-17 16:54 markusfluer Relationship added has duplicate 14059
2018-09-17 16:54 markusfluer Status assigned => resolved
2018-09-17 16:54 markusfluer Fixed in Version => 3.14.x
2018-09-19 08:50 geraldC File Added: limesurvey_survey_618349-2.lss
2018-09-19 08:50 geraldC Note Added: 49082
2018-09-19 08:51 geraldC Status resolved => feedback
2018-09-19 08:51 geraldC Resolution fixed => reopened
2018-09-19 08:51 geraldC Note Added: 49083
2018-09-19 10:55 LouisGac Note Added: 49085
2018-09-19 17:34 geraldC Note Added: 49093
2018-09-19 17:34 geraldC Status feedback => assigned
2018-09-26 12:54 markusfluer Status assigned => closed
2018-09-26 12:54 markusfluer Note Added: 49134