View Issue Details

IDProjectCategoryView StatusLast Update
13925Bug reports[All Projects] Survey designpublic2018-08-01 13:49
ReporterDenisChenuAssigned ToLouisGac 
PrioritynoneSeverityminor 
Status feedbackResolutionreopened 
Product Version3.13.x 
Target Version4.0.0devFixed in Version 
Summary13925: Unable to use QID SGQ … in validation equation tip
Description

When using QID in validation equation tip : show as error

Steps To Reproduce

Import included survey and test

Additional Information

Since answer pass by EM currently : some other part are fixed (example : see class or prefix (this must be fixed too for https://github.com/LimeSurvey/LimeSurvey/pull/1105)

2.73 have same issue and behaviour

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.14.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13913 closedDenisChenu Some replacementfieds not accessible in help-text 
related to 13001 closedDenisChenu Expression Manager evaluates answers to free text questions enclosed by "{" and "}" 

Activities

DenisChenu

DenisChenu

2018-08-01 10:23

developer  

limesurvey_survey_testQIDqndGID.lss (13,742 bytes)
LouisGac

LouisGac

2018-08-01 11:48

manager   ~48639

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27736

DenisChenu

DenisChenu

2018-08-01 13:49

developer   ~48640

Not fixed : EM already parse it : https://github.com/LimeSurvey/LimeSurvey/blob/3e3b0b1492aa805a22ccf16804dd165b3d498abf/application/helpers/expressions/em_manager_helper.php#L6777

And more

  1. I think it's a minor issue (since QID/SGQ are more used for javascript, and don't see how make javascript in tips …)
  2. This is related to https://bugs.limesurvey.org/view.php?id=13001 : and this one must be in 4.0/develop
  3. I think best solution is EM send array of tips (currently send whole string) + event setError/setSuccess (this OK) etc … core have a default behaviour , and this can be replaced by twig file

Related Changesets

LimeSurvey: master 3e3b0b14

2018-08-01 11:48:29

LouisGac

Details Diff
Fixed issue 13925: Unable to use QID SGQ … in validation equation tip Affected Issues
13925
mod - application/helpers/SurveyRuntimeHelper.php Diff File

Issue History

Date Modified Username Field Change
2018-08-01 10:23 DenisChenu New Issue
2018-08-01 10:23 DenisChenu Status new => assigned
2018-08-01 10:23 DenisChenu Assigned To => DenisChenu
2018-08-01 10:23 DenisChenu File Added: limesurvey_survey_testQIDqndGID.lss
2018-08-01 10:23 DenisChenu File Added: Capture du 2018-08-01 10-15-28.png
2018-08-01 10:23 DenisChenu Relationship added related to 13913
2018-08-01 10:24 DenisChenu Relationship added related to 13001
2018-08-01 11:48 LouisGac Changeset attached => LimeSurvey master 3e3b0b14
2018-08-01 11:48 LouisGac Note Added: 48639
2018-08-01 11:48 LouisGac Assigned To DenisChenu => LouisGac
2018-08-01 11:48 LouisGac Resolution open => fixed
2018-08-01 11:49 LouisGac Status assigned => resolved
2018-08-01 13:49 DenisChenu Note Added: 48640
2018-08-01 13:49 DenisChenu Status resolved => feedback
2018-08-01 13:49 DenisChenu Resolution fixed => reopened