View Issue Details

IDProjectCategoryView StatusLast Update
13402Bug reports[All Projects] Import/Exportpublic2018-02-27 14:23
ReporterYuVeRe Assigned Tomarkusfluer  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.x 
Summary13402: Export result not work
Description

When i click on the "Export" button (PDF, Word...), the file whith the output is not generated.

Steps To Reproduce

1) Select a survey
2) Responses: Responses & statistics
3) Export: Export responses
4) Format: Export Format: PDF, CSV, Word, Excel or HTML
5) Press "Export" button

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.4.1+180221
I will donate to the project if issue is resolvedNo
BrowserGoogle Chrome 64.0.3282.167 (Build oficial) (64 bits), Microsoft Edge 41.16299.248.0, Mozilla Firefox 58.0.2 (64-bit)
Database & DB-VersionMySQL 5.7.20-0 & LimeDBVersion 347
Server OS (if known)Ubuntu 16.04.3 LTS
Webserver software & version (if known)Apache/2.4.18
PHP Version7.0.22

Relationships

has duplicate 13408 closedollehar Export stats impossible version 3.41 

Activities

YuVeRe

YuVeRe

2018-02-22 00:56

reporter  

ExportResult.png (80,630 bytes)
ExportResult.png (80,630 bytes)
oneterralive

oneterralive

2018-02-22 09:01

reporter   ~46715

And I have problem with export from statistic page. Excel files is corrupted.

jansch2015

jansch2015

2018-02-22 09:20

reporter   ~46716

Same problem here... But on our End, it seems to be broken since version 3.

Additionaly, this is the browser console log, which appears on click "Export".

We are on PHP 7.



Capture.JPG (44,737 bytes)
Capture.JPG (44,737 bytes)
Deusdeorum

Deusdeorum

2018-02-22 12:01

reporter   ~46718

Last edited: 2018-02-22 12:02

View 2 revisions

Sounds like this is related to 13316 and 13394

markusfluer

markusfluer

2018-02-22 12:18

administrator   ~46719

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26552

oneterralive

oneterralive

2018-02-22 12:42

reporter   ~46721

Good day, what about problem in statistics ? Excel files not open in MS Excel but in Libreoffice it open but empty.
PHP 7.2.2
LimeSurvey 3.4.1



statistic-survey913942.xls (4,096 bytes)
limesurvey_survey_913942.lss (13,641 bytes)
bug_excel_statistics.png (29,242 bytes)
bug_excel_statistics.png (29,242 bytes)
markusfluer

markusfluer

2018-02-22 15:59

administrator   ~46722

Not the same issue.
It is a different export system.

c_schmitz

c_schmitz

2018-02-27 14:23

administrator   ~46793

Version 3.4.3 Build 180227 released.

Related Changesets

LimeSurvey: master 61525cec

2018-02-22 12:18:30

markusfluer

Details Diff
Fixed issue 13402: Export result not work Affected Issues
13402
mod - application/views/admin/export/exportresults_view.php Diff File

Issue History

Date Modified Username Field Change
2018-02-22 00:56 YuVeRe New Issue
2018-02-22 00:56 YuVeRe File Added: ExportResult.png
2018-02-22 09:01 oneterralive Note Added: 46715
2018-02-22 09:20 jansch2015 File Added: Capture.JPG
2018-02-22 09:20 jansch2015 Note Added: 46716
2018-02-22 12:01 Deusdeorum Note Added: 46718
2018-02-22 12:02 Deusdeorum Note Edited: 46718 View Revisions
2018-02-22 12:18 markusfluer Assigned To => markusfluer
2018-02-22 12:18 markusfluer Status new => resolved
2018-02-22 12:18 markusfluer Resolution open => fixed
2018-02-22 12:18 markusfluer Fixed in Version => 3.4.x
2018-02-22 12:18 markusfluer Changeset attached => LimeSurvey master 61525cec
2018-02-22 12:18 markusfluer Note Added: 46719
2018-02-22 12:42 oneterralive File Added: statistic-survey913942.xls
2018-02-22 12:42 oneterralive File Added: limesurvey_survey_913942.lss
2018-02-22 12:42 oneterralive File Added: bug_excel_statistics.png
2018-02-22 12:42 oneterralive Note Added: 46721
2018-02-22 15:59 markusfluer Note Added: 46722
2018-02-26 15:24 ollehar Relationship added has duplicate 13408
2018-02-27 14:23 c_schmitz Note Added: 46793
2018-02-27 14:23 c_schmitz Status resolved => closed