View Issue Details

IDProjectCategoryView StatusLast Update
13394Bug reports[All Projects] Import/Exportpublic2018-03-03 11:36
Reportersebuin Assigned Toollehar  
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.4.x 
Summary13394: Excel-Export is broken (.xls file is not to open)
Description

When exporting the survey results as Excel, the created .xsl file is broken.
An export as HTML and PDF works.

No error found in logs.

Steps To Reproduce

Simply export results as Excel.

TagsNo tags attached.
Complete LimeSurvey version number (& build)LimeSurvey Version 3.4.0+180219
I will donate to the project if issue is resolvedNo
BrowserFirefox 58.0.2, Chromium,..
Database & DB-VersionMySQL 5.5.59
Server OS (if known)Ubuntu 14.04.5 LTS‬
Webserver software & version (if known)Apache
PHP VersionPHP 5.6.33 (first) and 7.0.27 (now)

Activities

c_schmitz

c_schmitz

2018-02-21 12:37

administrator   ~46648

I am sorry but I cannot reproduce it.
Do you change any settings on export or you just select Excel.
Can you attach such a broken xsl file?
Can you please attach a small survey archive (.lsa) to reproduce the issue?

Deusdeorum

Deusdeorum

2018-02-21 13:16

reporter   ~46659

Last edited: 2018-02-21 14:01

View 2 revisions

If you are referring to the statistics export I can confirm that it is generating a broken .xls file, see bug 13316.

sebuin

sebuin

2018-03-01 18:15

reporter   ~46856

Thanks! Yes, indeed that seems to be the same issue as in bug 13316.
I'll update to 3.4.3 and test if this solves the Excel-Export.

ollehar

ollehar

2018-03-02 10:08

administrator   ~46859

Please let us know if this issue is solved by updating to 3.4.3.

sebuin

sebuin

2018-03-02 21:10

reporter   ~46877

Updated to 3.4.3 and the excel export is working. You may close this issue. Thanks!

Issue History

Date Modified Username Field Change
2018-02-21 12:11 sebuin New Issue
2018-02-21 12:37 c_schmitz Assigned To => c_schmitz
2018-02-21 12:37 c_schmitz Status new => feedback
2018-02-21 12:37 c_schmitz Note Added: 46648
2018-02-21 13:16 Deusdeorum Note Added: 46659
2018-02-21 14:01 c_schmitz Note Edited: 46659 View Revisions
2018-03-01 18:15 sebuin Note Added: 46856
2018-03-01 18:15 sebuin Status feedback => assigned
2018-03-02 10:08 ollehar Assigned To c_schmitz => ollehar
2018-03-02 10:08 ollehar Status assigned => feedback
2018-03-02 10:08 ollehar Note Added: 46859
2018-03-02 21:10 sebuin Note Added: 46877
2018-03-02 21:10 sebuin Status feedback => assigned
2018-03-03 11:36 c_schmitz Status assigned => closed
2018-03-03 11:36 c_schmitz Resolution open => fixed
2018-03-03 11:36 c_schmitz Fixed in Version => 3.4.x