View Issue Details

IDProjectCategoryView StatusLast Update
13302Bug reports[All Projects] Survey takingpublic2019-04-30 09:13
Reportertpartner Assigned ToDenisChenu  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version3.2.x 
Target Version3.2.xFixed in Version3.16.x 
Summary13302: Slider "Slider starts at the middle position" and "Slider initial value" settings not working
Description

Neither of these settings has any affect - see screenshots and attached survey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.2.0
I will donate to the project if issue is resolvedNo
Browsern/a
Database & DB-Versionmysqlnd 5.0.12-dev
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.27 (Win32) OpenSSL/1.0.2l PHP/7.1.9
PHP Version7.1.9

Relationships

related to 14618 closedDenisChenu slider resets when moving backwards with a starting value 
related to 14016 closedDenisChenu Multiple numerical input resets back to initial value when slider is set zero 
related to 13593 closedDenisChenu Slider reset not working 

Activities

tpartner

tpartner

2018-02-06 13:14

developer  

capture-4.png (14,229 bytes)
capture-4.png (14,229 bytes)
capture-3.png (30,739 bytes)
capture-3.png (30,739 bytes)
limesurvey_survey_556928.lss (15,756 bytes)
zserban

zserban

2018-12-08 11:09

reporter   ~49911

This bug is still present, if you set the initial value to 0, neither setting the slider to middle or start value will work.

Strange is that if you save survey and resume it later the 0 value is taken into account.

Mazi

Mazi

2019-01-15 09:16

partner   ~50195

@markusfluer, this one is causing quite some issues. It is the issue we discussed on Skype recently: "Ich glaube ich weiß woran es liegt, da die mitte den Wert '0' hat wird das falsch interpretiert, das liegt a der php version".
Please have another look if possible.

tammo

tammo

2019-01-16 17:42

developer   ~50242

I can confirm that setting the initial value at 0 results in showing the initial position to be at 5 (scale 0 - 100)



slider2.png (64,094 bytes)
slider2.png (64,094 bytes)
slider1.png (43,256 bytes)
slider1.png (43,256 bytes)
tammo

tammo

2019-01-16 17:56

developer   ~50245

Here sample survey



limesurvey_survey_479531.lss (21,593 bytes)
DenisChenu

DenisChenu

2019-03-11 08:15

developer   ~50886

I think all is fixed now
https://bugs.limesurvey.org/view.php?id=14618
https://bugs.limesurvey.org/view.php?id=14016

DenisChenu

DenisChenu

2019-03-11 08:20

developer   ~50887

Last edited: 2019-03-11 09:20

View 3 revisions

@tammo : on 479531 : you have the 2 settings : middle position + slider start at.
<s>Strangely : middle position is set at end … then it get the priority. I add a information about that in help text.</s>
I didn't update it, because it broke existing survey.



DenisChenu

DenisChenu

2019-03-11 08:41

developer   ~50888

OK, think i fixed whole, please review

DenisChenu

DenisChenu

2019-03-11 08:42

developer   ~50889

https://github.com/LimeSurvey/LimeSurvey/commit/97750a52dbf22fd858ba62213ba6938de6460e81

jelo

jelo

2019-03-11 08:50

partner   ~50890

Did every release since Feb 2018 had this "major" issue? Or is this issue a reoccurring one?

DenisChenu

DenisChenu

2019-03-11 09:14

developer   ~50891

@jelo : personnaly : i don't know …

jelo

jelo

2019-03-29 11:18

partner   ~51193

The value "Slider initial value set at start: 0 " seem to be kept in the system, even when you remove the value and save the options again. The overview still shows the value set.

Sidenote: The slider question should be a separate questiontype. Will ease debugging and helps to build a coherent set of options for a question type. Questions like Gender and Yes/No are separate question types, but a slider is inside a Multiple numerical input.

DenisChenu

DenisChenu

2019-03-29 11:29

developer   ~51194

About SideNote : must be moved to Question Theme i thin, since data saved is exactly the same than multiple numeric.

DenisChenu

DenisChenu

2019-03-29 11:41

developer   ~51195

The value "Slider initial value set at start: 0 " seem to be kept in the system, even when you remove the value and save the options again. The overview still shows the value set.

Slider initial value set at start: 0 mean it's OFF
Default is 1 , then when it‘s ON : nothing is shown.

Since Question edit was rewritten (with another maybe biggest issue) : no need to work on it.

c_schmitz

c_schmitz

2019-04-30 09:13

administrator   ~51686

Fixed in version 3.17.3

Issue History

Date Modified Username Field Change
2018-02-06 13:14 tpartner New Issue
2018-02-06 13:14 tpartner File Added: capture-4.png
2018-02-06 13:14 tpartner File Added: capture-3.png
2018-02-06 13:14 tpartner File Added: limesurvey_survey_556928.lss
2018-02-07 11:06 LouisGac Assigned To => markusfluer
2018-02-07 11:06 LouisGac Status new => assigned
2018-12-08 11:09 zserban Note Added: 49911
2019-01-15 09:16 Mazi Note Added: 50195
2019-01-16 17:42 tammo File Added: slider2.png
2019-01-16 17:42 tammo File Added: slider1.png
2019-01-16 17:42 tammo Note Added: 50242
2019-01-16 17:56 tammo File Added: limesurvey_survey_479531.lss
2019-01-16 17:56 tammo Note Added: 50245
2019-03-11 08:15 DenisChenu Note Added: 50886
2019-03-11 08:15 DenisChenu Assigned To markusfluer => DenisChenu
2019-03-11 08:20 DenisChenu File Added: Capture d’écran du 2019-03-11 08-18-54.png
2019-03-11 08:20 DenisChenu Note Added: 50887
2019-03-11 08:37 DenisChenu Note Edited: 50887 View Revisions
2019-03-11 08:41 DenisChenu Status assigned => resolved
2019-03-11 08:41 DenisChenu Resolution open => fixed
2019-03-11 08:41 DenisChenu Fixed in Version => 3.16.x
2019-03-11 08:41 DenisChenu Note Added: 50888
2019-03-11 08:42 DenisChenu Note Added: 50889
2019-03-11 08:42 DenisChenu Relationship added related to 14618
2019-03-11 08:50 jelo Note Added: 50890
2019-03-11 09:11 DenisChenu Relationship added related to 14016
2019-03-11 09:14 DenisChenu Note Added: 50891
2019-03-11 09:20 DenisChenu Note Edited: 50887 View Revisions
2019-03-29 11:18 jelo Note Added: 51193
2019-03-29 11:29 DenisChenu Note Added: 51194
2019-03-29 11:41 DenisChenu Note Added: 51195
2019-03-29 12:58 DenisChenu Relationship added related to 13593
2019-04-30 09:13 c_schmitz Note Added: 51686
2019-04-30 09:13 c_schmitz Status resolved => closed