View Issue Details

IDProjectCategoryView StatusLast Update
13204Bug reports[All Projects] Survey designpublic2018-06-02 14:02
ReporterDenisChenu Assigned Tomarkusfluer  
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.0.x 
Target VersionFixed in Version3.4.x 
Summary13204: Even with good settings : browse ressources show "You don't have Permission to browse this server"
Description

Import a survey, go on Settings/Ressources : see the alert()

Steps To Reproduce

See Description

Additional Information

With same survey, goes to edit any question, add an image : Settings/Ressources work as expected.

Doing this way create the directory. At foirst time we surely don't have the upload/surveys/sid/

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0.4
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 13734 closedLouisGac image upload is not possible - You don't have permissions to browse server. 

Activities

c_schmitz

c_schmitz

2018-01-25 10:01

administrator   ~46067

Looks like /uplodas/surveys was missing.

DenisChenu

DenisChenu

2018-01-25 10:13

developer   ~46071

No, /uploads/surveys was here , but not /uploads/surveys/XXXX except using question edit/text edit before going to Browse ressource.

Whith text edit : we create /uploads/surveys/XXXX/(images|files) if don't exist, not with browse ressources.

DenisChenu

DenisChenu

2018-01-25 10:14

developer   ~46072

Reproduce step:
Create a new survey
Save
Go to browse ressource



c_schmitz

c_schmitz

2018-02-16 18:15

administrator   ~46567

I can reproduce.

markusfluer

markusfluer

2018-03-09 14:23

administrator   ~46971

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=26708

c_schmitz

c_schmitz

2018-03-09 16:36

administrator   ~46977

Version 3.5.0 180309 released

Related Changesets

LimeSurvey: master c484af66

2018-03-09 14:22:55

markusfluer

Details Diff
Fixed issue 13204: Even with good settings : browse ressources show "You don't have Permission to browse this server" Affected Issues
13204
mod - application/controllers/admin/surveyadmin.php Diff File

Issue History

Date Modified Username Field Change
2018-01-18 15:41 DenisChenu New Issue
2018-01-25 10:01 c_schmitz Assigned To => c_schmitz
2018-01-25 10:01 c_schmitz Status new => resolved
2018-01-25 10:01 c_schmitz Resolution open => fixed
2018-01-25 10:01 c_schmitz Note Added: 46067
2018-01-25 10:13 DenisChenu Status resolved => feedback
2018-01-25 10:13 DenisChenu Resolution fixed => reopened
2018-01-25 10:13 DenisChenu Note Added: 46071
2018-01-25 10:14 DenisChenu File Added: Capture du 2018-01-25 10-11-35.png
2018-01-25 10:14 DenisChenu Note Added: 46072
2018-01-25 10:14 DenisChenu Status feedback => assigned
2018-02-16 18:15 c_schmitz Assigned To c_schmitz => markusfluer
2018-02-16 18:15 c_schmitz Note Added: 46567
2018-03-09 14:23 markusfluer Changeset attached => LimeSurvey master c484af66
2018-03-09 14:23 markusfluer Note Added: 46971
2018-03-09 14:23 markusfluer Status assigned => resolved
2018-03-09 14:23 markusfluer Fixed in Version => 3.4.x
2018-03-09 16:36 c_schmitz Note Added: 46977
2018-03-09 16:36 c_schmitz Status resolved => closed
2018-06-02 14:02 DenisChenu Relationship added related to 13734