View Issue Details

IDProjectCategoryView StatusLast Update
13194Bug reportsSurvey editingpublic2018-01-25 08:00
ReporterDenisChenu Assigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version3.0.x 
Summary13194: Bad question type shown when preview
DescriptionWhen previewing a just updated question : it's the previous shown
Steps To ReproduceImport this lss : https://bugs.limesurvey.org/view.php?id=12240#c45861
Test the survey, close at the question view
In admin page : update to Arry (simple) question type
Save
Preview the question : still the Array by column shown.
Additional InformationSurely an EM session issue
In 2.6lts or 3.72 : previewing for EM session reset.
But more : save a question must reset the EM session (in fact : EM session for admin is … :/ buggy a lot)
TagsNo tags attached.
Complete LimeSurvey version number (& build) 3.0.4
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

duplicate of 13185 closedmarkusfluer Rendering issue when adding new questions (Preview) 
has duplicate 13229 closedmarkusfluer Question text changes not visible in perviews 

Activities

DenisChenu

DenisChenu

2018-01-18 14:42

developer   ~45892

It's wotrth of this …

Import any survey, go to any question, preview : no question is shwon. Preview group : no question is shown …
ollehar

ollehar

2018-01-18 15:04

administrator   ~45893

This is a newtest=Y related problem?
DenisChenu

DenisChenu

2018-01-18 15:11

developer   ~45894

No a preview problem :)

Second Steps To Reproduce
1. Log in on admin GUI
2. Go to any survey
3. Go to any valid question in admin
4. Click on preview question : nothing is shown

Surely related to $_SESSION['survey_'.$sid], but NOT related to newtest.
DenisChenu

DenisChenu

2018-01-18 15:12

developer   ~45895

PS: we already have a lot of issue with this EM session, we must fiox it before think we can move it in cache ;)
DenisChenu

DenisChenu

2018-01-18 16:21

developer   ~45896

Another outdated part:
Create a list question+ other, add {list(self)} in text + preview
Showing list(Q0,Q0_other) : OK
Update question type to array, add 2 subquestion : SQ001 and SQ002 : save : still shown list(Q0,Q0_other) … bad

Issue History

Date Modified Username Field Change
2018-01-17 15:47 DenisChenu New Issue
2018-01-17 16:19 ollehar Assigned To => ollehar
2018-01-17 16:19 ollehar Status new => assigned
2018-01-18 14:42 DenisChenu Note Added: 45892
2018-01-18 15:04 ollehar Note Added: 45893
2018-01-18 15:11 DenisChenu File Added: Capture du 2018-01-18 15-09-19.png
2018-01-18 15:11 DenisChenu Note Added: 45894
2018-01-18 15:12 DenisChenu Note Added: 45895
2018-01-18 16:21 DenisChenu File Added: Capture du 2018-01-18 16-18-18.png
2018-01-18 16:21 DenisChenu Note Added: 45896
2018-01-19 08:30 DenisChenu Relationship added duplicate of 13185
2018-01-19 08:30 DenisChenu Assigned To ollehar => markusfluer
2018-01-19 08:30 DenisChenu Status assigned => closed
2018-01-19 08:30 DenisChenu Resolution open => duplicate
2018-01-25 08:00 DenisChenu Relationship added has duplicate 13229
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing