View Issue Details

IDProjectCategoryView StatusLast Update
11697Bug reports[All Projects] Survey editingpublic2017-07-21 17:07
ReporterMazi Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.52.x 
Target VersionFixed in Version3.0.x 
Summary11697: Default template - Columns at answer tables of array questions misaliged
Description

Most array types use table layouts. At some question types, the last column is significantly smaller than the other columns, see attached screen shot.
I noticed this for at least the "Array Numbers" question type using input fields.
It may also affect other array question types with lots of answer options.

Steps To Reproduce
  1. Import the attached test survey.
  2. Run the survey using the shipped default template.
  3. Page 1 contains the array questions
Additional Information

This can be fixed using this CSS for such tables:
table-layout: fixed;

^- Please do NOT apply this to Array Dual Scale (Drop Down) questions, the results is a step back.

Note that (older) IE versions may behave different so please test a fix with the oldest IE version supported by Limesurvey.

TagsNo tags attached.
Complete LimeSurvey version number (& build)160920
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Linux
Webserver software & version (if known)Apache 2
PHP Version5.5

Relationships

related to 11726 closedDenisChenu Feature requests Default column width and table header width 

Activities

Mazi

Mazi

2016-09-21 15:10

partner  

table_layout.png (20,324 bytes)
table_layout.png (20,324 bytes)
Mazi

Mazi

2016-09-21 15:10

partner  

limesurvey_survey_939178.lss (359,572 bytes)
DenisChenu

DenisChenu

2016-09-21 15:14

developer   ~40887

About : ^- Please do NOT apply this to Array Dual Scale (Drop Down) questions, the results is a step back.

See https://github.com/LimeSurvey/LimeSurvey/commit/36a3788d9ed58ff0a5fe9783720e4566c08b2a89

Readding column width

mfavetti

mfavetti

2016-09-28 21:58

developer   ~41016

Cannot reproduce with the test survey on latest chrome and latest firefox with latest git. The array with numbers looks fine for me.

Mazi

Mazi

2016-09-29 08:22

partner   ~41026

mfavetti, can you share a test link?

DenisChenu

DenisChenu

2016-09-29 09:35

developer   ~41027

PS : the old default template don't have fixed table-layout, i think it's a must have (by default)

mfavetti

mfavetti

2016-09-30 00:16

developer   ~41037

@Mazi, I used the attached survey on latest master in both Chrome and Firefox and didn't see the issue with the last column being a different width. What test link do you need? To my LS installation?

Mazi

Mazi

2016-09-30 09:23

partner   ~41041

@mfavetti: Weird, this is the link to my installation using latest release (build 160920): http://ls25.mysurveyhosting.com/index.php/939178?newtest=Y&lang=en

It shows the same as at the attached screenshot: Different box sizes at question "7 arrayNumArray (Numbers)".
Browser I use is Chrome (latest version).

DenisChenu

DenisChenu

2016-09-30 09:43

developer   ~41042

Last edited: 2016-09-30 09:43

View 2 revisions

I can reproduce : http://testing.sondages.pro/masterall/index.php/13413?lang=fr&encode=

Surely because of the "col-xs-12 col-sm-6" added to the tbody > th: removing it fix the issue

col-sm-6 force at 50%, but col width is set at 20%

mfavetti

mfavetti

2016-10-01 00:33

developer   ~41051

Very strange. I see the problem on both of your installations. However, on mine it's fine. http://169.237.123.37:8081/939178

This is running latest git as of this note.

Mazi

Mazi

2016-10-07 13:46

partner   ~41185

If anyone else is having the same problems, add this at the end of your template.css file:
/ 2016-10-07: Fixing different column width for array-multi-flexi questions/
.array-multi-flexi table.dropdown-list,
.array-multi-flexi table.numeric-item
{
table-layout: fixed;
}

DenisChenu

DenisChenu

2016-10-07 14:53

developer   ~41191

Already in template-core part http://testing.sondages.pro/answershtml/index.php/13413?lang=fr&encode=

Don't set it in package, some template can want something other (to be confirmed).

DenisChenu

DenisChenu

2016-10-17 12:14

developer   ~41393

Already in template-core (not editable) of default + basic.

Do you want in in limesurvey package by default ?

c_schmitz

c_schmitz

2017-07-21 17:07

administrator   ~44128

Version 3.0.0-beta.1 released

Issue History

Date Modified Username Field Change
2016-09-21 15:10 Mazi New Issue
2016-09-21 15:10 Mazi File Added: table_layout.png
2016-09-21 15:10 Mazi File Added: limesurvey_survey_939178.lss
2016-09-21 15:14 DenisChenu Note Added: 40887
2016-09-28 21:58 mfavetti Note Added: 41016
2016-09-29 08:22 Mazi Note Added: 41026
2016-09-29 09:30 DenisChenu Relationship added related to 11726
2016-09-29 09:35 DenisChenu Note Added: 41027
2016-09-30 00:16 mfavetti Note Added: 41037
2016-09-30 09:23 Mazi Note Added: 41041
2016-09-30 09:43 DenisChenu Note Added: 41042
2016-09-30 09:43 DenisChenu Note Edited: 41042 View Revisions
2016-10-01 00:33 mfavetti Note Added: 41051
2016-10-07 13:46 Mazi Note Added: 41185
2016-10-07 14:53 DenisChenu Note Added: 41191
2016-10-17 12:09 ollehar Assigned To => DenisChenu
2016-10-17 12:09 ollehar Status new => assigned
2016-10-17 12:14 DenisChenu Status assigned => resolved
2016-10-17 12:14 DenisChenu Resolution open => fixed
2016-10-17 12:14 DenisChenu Fixed in Version => 3.0.x
2016-10-17 12:14 DenisChenu Note Added: 41393
2017-07-21 17:07 c_schmitz Note Added: 44128
2017-07-21 17:07 c_schmitz Status resolved => closed
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing