View Issue Details

IDProjectCategoryView StatusLast Update
10546Bug reports[All Projects] Survey designpublic2018-05-30 18:48
ReporterhanoAssigned To 
PrioritylowSeverityminor 
Status feedbackResolutionreopened 
Product Version2.50.x 
Target VersionFixed in Version 
Summary10546: Passthrough field displays as undefined variable
Description

Using either {PASSTHRU:parent_url} directly in a template, or entering it as the End URL and using {URL} the template, it renderes as an error message.

Steps To Reproduce
  1. Add parent_url as a url paremeter in Panel Integration
  2. Set End URL of survey to {PASSTHRU:parent_url}
  3. Use {URL} in a custom template
Additional Information

Also detailed here
https://www.limesurvey.org/forum/design-issues/103644-passthrough-field-displays-as-undefined-variable#131881

TagsNo tags attached.
Complete LimeSurvey version number (& build)Build 160219
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5.6.21-70.1
Server OS (if known)ubuntu
Webserver software & version (if known)apache
PHP Version5.5.9

Relationships

related to 08824 new Feature requests Never show error with {TOKEN:} 

Activities

hano

hano

2016-02-22 11:56

reporter  

limesurvey_survey_584678.lss (178,804 bytes)
DenisChenu

DenisChenu

2016-02-22 12:37

developer   ~35526

HI,

You don't need to add Add parent_url as a url paremeter in Panel Integration .

PASSTHRU is enabled with any GET parameters.

Old issue here :)

DenisChenu

DenisChenu

2016-02-24 15:52

developer  

DenisChenu

DenisChenu

2016-02-24 15:53

developer   ~35664

Last edited: 2016-02-24 15:54

View 2 revisions

To be more clear :
https://manual.limesurvey.org/URL_fields#Passthrough_fields_.28LimeSurvey_2.x_or_later.29

{PASSTHRU:foobar} can be used : only in endsurveyurl. But actually EM show as an error.

Send it in the array it's not the solution : because {PASSTHRU:anythink} is OK.

Related to 08824 : same issue with {TOKEN:attribute_X}

DenisChenu

DenisChenu

2016-03-10 11:08

developer   ~36257

Error is steal here. Must be fixed (hard to fix)

Issue History

Date Modified Username Field Change
2016-02-22 11:56 hano New Issue
2016-02-22 11:56 hano File Added: limesurvey_survey_584678.lss
2016-02-22 12:37 DenisChenu Note Added: 35526
2016-02-24 15:52 DenisChenu File Added: Capture du 2016-02-24 15-51-47.png
2016-02-24 15:53 DenisChenu Note Added: 35664
2016-02-24 15:54 DenisChenu Relationship added related to 08824
2016-02-24 15:54 DenisChenu Note Edited: 35664 View Revisions
2016-03-10 10:59 LouisGac Status new => closed
2016-03-10 10:59 LouisGac Assigned To => LouisGac
2016-03-10 10:59 LouisGac Resolution open => fixed
2016-03-10 11:08 DenisChenu Note Added: 36257
2016-03-10 11:08 DenisChenu Status closed => feedback
2016-03-10 11:08 DenisChenu Resolution fixed => reopened
2016-03-10 11:24 LouisGac Priority normal => low
2016-05-12 18:26 LouisGac Assigned To LouisGac =>
2018-05-30 18:48 LouisGac Sticky Issue No => Yes