View Issue Details

IDProjectCategoryView StatusLast Update
10177Feature requests[All Projects] Conditionspublic2016-10-04 16:51
Reporteruser14106Assigned To 
PrioritynormalSeverityfeature 
Status newResolutionreopened 
Product Version 
Target VersionFixed in Version2.5+ 
Summary10177: have a checkbox on Survey settings to to enforce or not checking quota
Description

A discussion started here:

https://www.limesurvey.org/en/forum/development/103174-quota-checking-logic

one should be able to decide how quota checking logic works. Whether one needs really strict quotas (if quota is full, all respondents in the same quota group being in the middle of the interview will be thrown out) OR to use quotas like in v1 where respondent - once quota question is passed - will be allowed to submit the interview in all cases (meaning actual counts can be higher than quotas if multiple interviews are started at the same time in same quota).

The checkbox should say whether to check quotas in each and every question submission (current) or only on the pages where there are some quota related questins (like in v1).

The checkbox preferrably would be survey-specific - somewhere in general survey settings.

TagsNo tags attached.

Relationships

related to 10051 closedDenisChenu enable / disable quotas 

Activities

DenisChenu

DenisChenu

2016-01-05 09:01

developer   ~34144

Think 2.06 fix : enforce only oif there are a hidden quetion.
2.5 : hva more option.

Marksom

Marksom

2016-01-19 20:19

reporter   ~34288

I have past similar situations. Even developed a plugin for Limesurvey 1 increase in the limit and redirect to the survey when LastPage greater than LastPage quota.

But that has not worked well in all cases.
It would be essential that implementation.

DenisChenu

DenisChenu

2016-01-20 08:49

developer   ~34289

Actually , for deactivate quota you can set "number" to 1000000. It's not a major issue here, no ?

user14106

2016-01-20 09:58

  ~34294

Technically of course, in real life it will create confusion and extra work.

  1. Extra work. While using Lime for CATI projects we often need to temporarily seek for a certain target group (eg young people). Seek for them for a while until we reach our model goal, and then carry on with the rest of the work re-enabling original qoutas. By changing the number i need to change it back to what it was before -> its all extra work. The idea of this request is to have a switch to be able to go back a and forth, not just disable and not re-enable.

  2. Confusing - again while using it for cati - we display the active quotas to interviewers so that they understand the status, what groups are "closed" etc. Putting dummy numbers that work technically will confuse users that are using the quota info for informational purposes.

Of course, its not a major issue. All can be achieved with current versions, but it would be more convenient to be able to switch on/off

Thanks for LimeSurvey!

Marksom

Marksom

2016-01-20 15:24

reporter   ~34297

The problem is not the number of shares. 1000000 exemption increases to the purpose of the quota.

Ideally Limesurvey check which page is the survey, if you are ahead of the quota, so users can complete the survey.

Example: I need 2 respondents aged between 15 and 20 years. Three start the survey at the same time, Limesurvey the third block, even if it is at the end. This is not good for cati.

Thank you all.

DenisChenu

DenisChenu

2016-01-20 16:21

developer   ~34299

Hi,

For "complete can move to Quota out" => It's another issue, can be done only with token answer persitance + allow edit .
This can happen even before the patch to take 'hidden' question.

I make a patch for 'set enforce' only for hidden question. This fix like the old system and don't break user who use hidden question for Quota :).

The other "bug" must be put apart.

Not part of feature request : this is a bug :)

DenisChenu

DenisChenu

2016-01-21 09:58

developer   ~34311

Last edited: 2016-01-21 09:58

View 2 revisions

This patch : https://github.com/LimeSurvey/LimeSurvey/commit/77e4454bd7098f8f980fb3987f34c9e1aa80c7ca fix your issue with $POST.

1st : a question is not hidden in quota : quota is set ONLY when a question of quota is submitted
2nd : if all question his hidden in the quota : enforce the quota.

We can do some test with step maybe for 2.5 too .

PLease : test the patch

Marksom

Marksom

2016-01-21 21:45

reporter   ~34331

Last edited: 2016-01-22 00:39

View 3 revisions

Working perfectly. For me, it solved 100%.
Many thanks to all Limesurvey team.

DenisChenu

DenisChenu

2016-01-22 08:10

developer   ~34333

@Marksom : foir the reprort before editing ( ;) ).

Remind when you testing to do a test with "newtest=Y" ;)

user14106

2016-01-22 08:37

  ~34336

Excellent. Working also for me. Thanks a million!

DenisChenu

DenisChenu

2016-05-08 17:43

developer   ~38252

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=18913

DenisChenu

DenisChenu

2016-05-09 10:41

developer   ~38256

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=18915

DenisChenu

DenisChenu

2016-05-09 10:42

developer   ~38257

Reverted

Related Changesets

LimeSurvey: master 77e4454b

2016-01-21 08:53:55

DenisChenu

Details Diff
Dev: Feature 10177 partial : Enforce quota only if all question is hidden
Dev: this do the same than 2.00/2.05 for "no hidden question"
Dev: but allow to use Equation to set an (or more) hidden question(s)
Affected Issues
10177
mod - application/helpers/frontend_helper.php Diff File

LimeSurvey: master 7b9f2c3d

2016-05-08 15:42:59

DenisChenu

Details Diff
New feature 10177: have a checkbox on Survey settings to to enforce or not checking quota
Dev: adding management of unused active attribute. Set to 1 by default
Affected Issues
10177
mod - application/controllers/admin/quotas.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - application/models/Quota.php Diff File
mod - application/views/admin/quotas/editquota_view.php Diff File
mod - application/views/admin/quotas/newquota_view.php Diff File

LimeSurvey: master bda940c5

2016-05-09 08:41:03

DenisChenu

Details Diff
Revert "New feature 10177: have a checkbox on Survey settings to to enforce or not checking quota"

This reverts commit 7b9f2c3debe043b16c0b716e270d11aba7b6f436.
Affected Issues
10177
mod - application/controllers/admin/quotas.php Diff File
mod - application/helpers/frontend_helper.php Diff File
mod - application/models/Quota.php Diff File
mod - application/views/admin/quotas/editquota_view.php Diff File
mod - application/views/admin/quotas/newquota_view.php Diff File

Issue History

Date Modified Username Field Change
2015-12-22 12:39 user14106 New Issue
2015-12-22 14:37 DenisChenu Relationship added related to 10051
2016-01-05 09:00 DenisChenu Assigned To => DenisChenu
2016-01-05 09:00 DenisChenu Status new => assigned
2016-01-05 09:01 DenisChenu Note Added: 34144
2016-01-19 20:19 Marksom Note Added: 34288
2016-01-20 08:49 DenisChenu Note Added: 34289
2016-01-20 09:58 user14106 Note Added: 34294
2016-01-20 15:24 Marksom Note Added: 34297
2016-01-20 16:21 DenisChenu Note Added: 34299
2016-01-21 09:54 DenisChenu Changeset attached => LimeSurvey master 77e4454b
2016-01-21 09:58 DenisChenu Note Added: 34311
2016-01-21 09:58 DenisChenu Note Edited: 34311 View Revisions
2016-01-21 21:45 Marksom Note Added: 34331
2016-01-21 21:47 Marksom Note Edited: 34331 View Revisions
2016-01-22 00:39 Marksom Note Edited: 34331 View Revisions
2016-01-22 08:10 DenisChenu Note Added: 34333
2016-01-22 08:37 user14106 Note Added: 34336
2016-05-08 17:43 DenisChenu Changeset attached => LimeSurvey master 7b9f2c3d
2016-05-08 17:43 DenisChenu Note Added: 38252
2016-05-08 17:43 DenisChenu Resolution open => fixed
2016-05-08 17:43 DenisChenu Relationship replaced has duplicate 10051
2016-05-08 17:44 DenisChenu Status assigned => resolved
2016-05-08 17:44 DenisChenu Fixed in Version => 2.5+
2016-05-09 10:41 DenisChenu Changeset attached => LimeSurvey master bda940c5
2016-05-09 10:41 DenisChenu Note Added: 38256
2016-05-09 10:42 DenisChenu Assigned To DenisChenu =>
2016-05-09 10:42 DenisChenu Note Added: 38257
2016-05-09 10:42 DenisChenu Status resolved => feedback
2016-05-09 10:42 DenisChenu Resolution fixed => reopened
2016-05-09 10:42 DenisChenu Status feedback => new
2016-05-12 10:11 DenisChenu Relationship deleted has duplicate 10051
2016-05-12 10:11 DenisChenu Relationship added related to 10051