View Issue Details

IDProjectCategoryView StatusLast Update
09774Bug reportsSurvey takingpublic2020-03-13 19:41
ReporterDenisChenu Assigned To 
PrioritynormalSeverityminor 
Status newResolutionreopened 
Product Version3.22.9 
Summary09774: No PHP control on answer filtered for radio and ranking
Description

Without JS : in radio question type (and ranking) : user can choose any answer, even if filtered, and validate survey

Steps To Reproduce

Import survey from https://bugs.limesurvey.org/view.php?id=9773, start survey without JS, check 1 at first group, choose 2 at second on radio, next and validate .....

Additional Information

All EM are check in JS and PHP except this one, validate question must validate this !

TagsNo tags attached.
Complete LimeSurvey version number (& build)150712
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 09773 closedDenisChenu Bug reports Ranking question with filter are not resetted when come back to question 
related to 09941 new Feature requests Need a subquestion/answer relevance equation option for ranking questions and different question types on dual scale array. 

Activities

hvgard

hvgard

2016-02-10 21:16

reporter   ~34871

Any progress on this? I have long anwer-lists of healthcare location (different types like hospitals and hospices and fysio-therapy locations) that I would love to filter using relevance. The only way now is to have different Q's for each type with a seperate list.

DenisChenu

DenisChenu

2016-02-11 08:32

developer   ~34877

Last edited: 2018-02-21 12:58

View 2 revisions

Hi hvgard : here it's not another 'filter' on radio list wiuth answer relevance.

It's a bug : no PHP control for existing array_filter.

The feature you want is 09941

c_schmitz

c_schmitz

2020-03-13 18:46

administrator   ~56470

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.

DenisChenu

DenisChenu

2020-03-13 18:47

developer   ~56479

Never fixed

Issue History

Date Modified Username Field Change
2015-07-12 11:04 DenisChenu New Issue
2015-07-12 11:05 DenisChenu Relationship added related to 09773
2015-10-10 13:05 DenisChenu Relationship added related to 09941
2016-02-10 21:16 hvgard Note Added: 34871
2016-02-11 08:32 DenisChenu Note Added: 34877
2018-02-21 12:58 c_schmitz Note Edited: 34877 View Revisions
2019-03-08 11:21 cdorin Status new => confirmed
2020-03-13 18:46 c_schmitz Note Added: 56470
2020-03-13 18:46 c_schmitz Status confirmed => closed
2020-03-13 18:47 DenisChenu Assigned To => DenisChenu
2020-03-13 18:47 DenisChenu Status closed => new
2020-03-13 18:47 DenisChenu Resolution open => reopened
2020-03-13 18:47 DenisChenu Note Added: 56479
2020-03-13 18:47 DenisChenu Product Version 2.06+ => 3.22.9
2020-03-13 19:41 DenisChenu Assigned To DenisChenu =>