View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
08946Bug reportsConditionspublic2014-06-18 16:40
ReporterLuk3C41 Assigned ToDenisChenu  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version2.05+ 
Fixed in Version2.06+ 
Summary08946: mandatory numerical input shows numerical only validation error
Descriptionvalidation error if empty, even on loading, because of empty field.
other fields, like multiple numerical value, don't do it
Additional Informationin the attached survey "d4" shows the bug
TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)140320
I will donate to the project if issue is resolvedNo
Browser
Database type & version177
Server OS (if known)Ubuntu 12.04
Webserver software & version (if known)Apache/2.2.22
PHP Version5.3.10

Relationships

child of 08335 new Development  Move Mandatory to EM system 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Luk3C41

Luk3C41

2014-04-09 12:06

reporter  

DenisChenu

DenisChenu

2014-04-10 08:32

developer   ~29704

Think it's not a bug for numerical but only for "multi numerical".

If you use a text question and set "Question validation" to this=="AA", you have the same thing.
DenisChenu

DenisChenu

2014-06-04 18:11

developer   ~30050

Fix committed to 2.06 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14237
DenisChenu

DenisChenu

2014-06-04 18:13

developer   ~30052

Not sure it must be fixed but ...
c_schmitz

c_schmitz

2014-06-18 16:40

administrator   ~30173

LimeSurvey 2.05+ Build 140618 released.

Related Changesets

LimeSurvey: 2.06 11ebc7d7

2014-06-04 16:09:36

DenisChenu

Details Diff
Fixed issue 08946: mandatory numerical input shows numerical only validation error
Fixed issue 08672: Sub question min_value_n attribute in mandatory question Filtered can not be answered
Dev: like other : leave mandatory for mandatory attribute
Dev: don't fix DATE question type
Dev: maybe same fix to apply elsewhere
Dev: we leave the 'red' color BUT : see bug(dev) 08335
Affected Issues
08672, 08946
mod - application/helpers/expressions/em_manager_helper.php Diff File

Issue History

Date Modified Username Field Change
2014-04-09 12:06 Luk3C41 New Issue
2014-04-09 12:06 Luk3C41 File Added: limesurvey_survey_195587.lss
2014-04-10 08:26 DenisChenu Assigned To => DenisChenu
2014-04-10 08:26 DenisChenu Status new => assigned
2014-04-10 08:32 DenisChenu Note Added: 29704
2014-06-04 18:11 DenisChenu Changeset attached => LimeSurvey 2.06 11ebc7d7
2014-06-04 18:11 DenisChenu Note Added: 30050
2014-06-04 18:11 DenisChenu Resolution open => fixed
2014-06-04 18:13 DenisChenu Note Added: 30052
2014-06-04 18:13 DenisChenu Status assigned => resolved
2014-06-04 18:13 DenisChenu Status resolved => feedback
2014-06-04 18:13 DenisChenu Resolution fixed => reopened
2014-06-04 18:13 DenisChenu Relationship added child of 08335
2014-06-04 18:14 DenisChenu Status feedback => resolved
2014-06-04 18:14 DenisChenu Fixed in Version => 2.06+
2014-06-04 18:14 DenisChenu Resolution reopened => fixed
2014-06-18 16:40 c_schmitz Note Added: 30173
2014-06-18 16:40 c_schmitz Status resolved => closed