View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
08932Bug reportsSurvey takingpublic2014-04-16 14:31
Reporterduvemyster Assigned ToDenisChenu  
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Product Version2.05+ 
Summary08932: When questions conditional on token attributes eliminate an entire group, the full index still shows that group at the start.
DescriptionIF show question index / allow jumping is set to full,
and all questions in a group are conditional on token attributes,
and conditions and attributes are such that no questions in a given group are to be displayed,
THEN the question index still includes this group until you jump to it or get to it, then it disappears.

And, if Resume Later is utilized, this question group will appear again when resuming, until you get to it again, and then it disappears again.
Steps To Reproduce1. Set question index / allow jumping to full, and make all questions in a group are conditional on token attributes such that no questions should show in the text case.
2. Load the survey and note the group that isn't applicable does appear.
3. Jump to the group that isn't applicable, and note that it disappears.
----
4. Resume later.
5. Resume and observe that the group that isn't applicable is back again in the question index.
TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)Build 140320
I will donate to the project if issue is resolvedNo
BrowserFirefox 28.0
Database type & versionMySQL 5.1
Server OS (if known)Linux
Webserver software & version (if known)Apache/2.2
PHP Version5.4.10

Relationships

duplicate of 08300 assignedgalads Feature requests Group complete index show group without testing relevance (and other think) 

Users monitoring this issue

User List duvemyster

Activities

c_schmitz

c_schmitz

2014-04-08 09:58

administrator   ~29690

Fixing this would mean that all questions needs to be evaluated at all times.
This would be way to slow so this is a no-fix.
duvemyster

duvemyster

2014-04-08 16:36

reporter   ~29695

Last edited: 2014-04-08 16:39

View 2 revisions

Could consideration be given to evaluating questions one-time, at the first time the survey loads?

c_schmitz

c_schmitz

2014-04-14 15:08

administrator   ~29738

Can you attach a sample survey with two groups and a couple questions demonstrating the issue?
duvemyster

duvemyster

2014-04-14 22:19

reporter  

duvemyster

duvemyster

2014-04-14 22:21

reporter   ~29757

Additional explanation is included in the survey description, going along with the made-up example uploaded (survey_archive_214374.lsa)
duvemyster

duvemyster

2014-04-14 22:28

reporter   ~29758

(Note: Regarding resume, the way that behaves depends on which group in the survey was active when "resume later" was selected.)
DenisChenu

DenisChenu

2014-04-16 14:31

developer   ~29814

Full index actual version don't test relevance if step < index group.

It's a Feautre here, and already reported.

Hard to fix, cause we need more option (and think we need to move it to Plugin)

Issue History

Date Modified Username Field Change
2014-04-02 16:59 duvemyster New Issue
2014-04-02 17:11 duvemyster Issue Monitored: duvemyster
2014-04-08 09:58 c_schmitz Note Added: 29690
2014-04-08 09:58 c_schmitz Status new => closed
2014-04-08 09:58 c_schmitz Assigned To => c_schmitz
2014-04-08 09:58 c_schmitz Resolution open => won't fix
2014-04-08 16:36 duvemyster Note Added: 29695
2014-04-08 16:36 duvemyster Status closed => feedback
2014-04-08 16:36 duvemyster Resolution won't fix => reopened
2014-04-08 16:39 duvemyster Note Edited: 29695 View Revisions
2014-04-14 15:08 c_schmitz Note Added: 29738
2014-04-14 22:19 duvemyster File Added: survey_archive_214374.lsa
2014-04-14 22:21 duvemyster Note Added: 29757
2014-04-14 22:21 duvemyster Status feedback => assigned
2014-04-14 22:28 duvemyster Note Added: 29758
2014-04-16 14:19 c_schmitz Assigned To c_schmitz =>
2014-04-16 14:19 c_schmitz Status assigned => new
2014-04-16 14:29 DenisChenu Relationship added duplicate of 08300
2014-04-16 14:31 DenisChenu Note Added: 29814
2014-04-16 14:31 DenisChenu Status new => closed
2014-04-16 14:31 DenisChenu Assigned To => DenisChenu
2014-04-16 14:31 DenisChenu Resolution reopened => duplicate
2021-08-02 19:51 duvemyster Bug heat 6 => 8