View Issue Details

IDProjectCategoryView StatusLast Update
08247Bug reports[All Projects] Survey takingpublic2019-03-14 11:31
ReportermadflowAssigned Todominikvitt 
PrioritynormalSeverityminor 
Status closedResolutionreopened 
Product Version2.00+ 
Target VersionFixed in Version2.05+ 
Summary08247: Javascript autocorrection of numerical values
Description

When you create a numerical input question, you can define that the input should be an integer.

What we expected is, that there is a input validation on this question type.

But - the software seems only to perform an input filtering. When the user activates Javascript an input like 100.000 (german "Tausendertrenner") the script autocorrects to 100000. This itself arguably problematic - since a survey engine should not autocorrect.

Steps To Reproduce
  • Create a new question "Numerical Input".
  • Activate "Integer Only"
  • An input of 100.000 will be auto-corrected to 100000
Additional Information

http://bugs.limesurvey.org/view.php?id=8217

TagsNo tags attached.
Complete LimeSurvey version number (& build)Latest Master Branch
I will donate to the project if issue is resolvedNo
BrowserALL
Database & DB-VersionN.A.
Server OS (if known)N.A.
Webserver software & version (if known)N.A.
PHP VersionN.A.

Relationships

related to 08217 closedDenisChenu Bug reports "Numerical Input" question validation only client side 
related to 08253 closedDenisChenu Development  Move checkconditions from HTML to external file 

Activities

DenisChenu

DenisChenu

2013-10-09 17:27

developer   ~26675

In 2.05 : you can replace function fixnum_checkconditions by your own because teplate.js is at end.

DenisChenu

DenisChenu

2013-10-21 12:47

developer   ~26871

Use js var bFixNumAuto= 0 in template.js
Use js var bNumRealValue= 1 in template.js

DenisChenu

DenisChenu

2013-10-22 18:52

developer   ~26929

Added in config-default too

c_schmitz

c_schmitz

2013-10-23 14:39

administrator   ~26947

2.05RC3 released

dominikvitt

dominikvitt

2019-02-13 09:44

developer   ~50538

@DenisChenu:
This bug can't be reproduced on versions 2.73 and 3.15.8, so there isn't a need to be reopened.

DenisChenu

DenisChenu

2019-02-13 09:49

developer   ~50539

You don't read : «his itself arguably problematic - since a survey engine should not autocorrect.»

dominikvitt

dominikvitt

2019-03-14 11:27

developer   ~50978

@DenisChenu:
Can this issue be closed?

DenisChenu

DenisChenu

2019-03-14 11:31

developer   ~50980

Yes, since moved to template now :)

Related Changesets

LimeSurvey: 2.05 8f5dd6ad

2013-10-14 13:31:28

DenisChenu

Details Diff
New feature 08247: Allow deactivate of autocorrection of numerical values Affected Issues
08247
mod - scripts/expressions/em_javascript.js Diff File
mod - scripts/survey_runtime.js Diff File

LimeSurvey: 2.05 1c644b9e

2013-10-21 10:40:12

DenisChenu

Details Diff
Merge pull request #148 from Shnoulle/2.05

2.05 : fix 3 issue with numeric question type (javascript and php)
Affected Issues
08247, 08253
mod - application/helpers/SurveyRuntimeHelper.php Diff File
mod - application/helpers/expressions/em_core_helper.php Diff File
mod - application/helpers/expressions/em_manager_helper.php Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - scripts/expressions/em_javascript.js Diff File
mod - scripts/survey_runtime.js Diff File

Issue History

Date Modified Username Field Change
2013-10-08 17:10 madflow New Issue
2013-10-09 10:46 c_schmitz Assigned To => DenisChenu
2013-10-09 10:46 c_schmitz Status new => assigned
2013-10-09 10:48 c_schmitz Relationship added related to 08217
2013-10-09 17:27 DenisChenu Note Added: 26675
2013-10-09 17:28 DenisChenu Relationship added related to 08253
2013-10-21 12:44 DenisChenu Changeset attached => LimeSurvey 2.05 1c644b9e
2013-10-21 12:46 DenisChenu Changeset attached => LimeSurvey 2.05 8f5dd6ad
2013-10-21 12:47 DenisChenu Note Added: 26871
2013-10-22 18:52 DenisChenu Note Added: 26929
2013-10-22 18:52 DenisChenu Status assigned => resolved
2013-10-22 18:52 DenisChenu Fixed in Version => 2.05+
2013-10-22 18:52 DenisChenu Resolution open => fixed
2013-10-23 14:39 c_schmitz Note Added: 26947
2013-10-23 14:39 c_schmitz Status resolved => closed
2019-02-13 00:03 DenisChenu Assigned To DenisChenu => dominikvitt
2019-02-13 00:03 DenisChenu Status closed => feedback
2019-02-13 00:03 DenisChenu Resolution fixed => reopened
2019-02-13 09:44 dominikvitt Note Added: 50538
2019-02-13 09:49 DenisChenu Note Added: 50539
2019-03-14 11:27 dominikvitt Note Added: 50978
2019-03-14 11:31 DenisChenu Status feedback => closed
2019-03-14 11:31 DenisChenu Note Added: 50980