View Issue Details

IDProjectCategoryView StatusLast Update
07726Bug reportsCentral participant databasepublic2013-04-23 16:30
Reporterjopsvanthof Assigned Toc_schmitz  
PrioritylowSeveritytrivial 
Status closedResolutionfixed 
Product Version2.00+ 
Fixed in Version2.00+ 
Summary07726: Value for participant attribute could be "select one", or so it seems
Description* attribute type = drop down box (e.g. attribute "Group" in attache survey/CPDB)
When you want to set the value for an attribute for a new participant (i.e. participant has no value set for the attribute yet) and one leaves the pull down box set to "select one", then presses the little "save button", it seems that the value for that attribute becomes "select one".

However, when you refresh the overview of the participants (attribute is visible as a column), the value for the attribute is empty.

If you do this for a participant who already has the attribute set to a particular value (e.g. "A"), change it to "select one", press the little save button, then refresh the view, the attribute will have the old value "A" still.
Steps To Reproduce1) open the CPDD panel
2) click "display participants"
3) click on the little "+"-sign (on the far left end of the screen, next to the check box for this participant)
4) click on the little "pen" sign to "edit selected row" of the "Group" attribute
5) leave the pulldown box set to "Select One"
6) press the little "disk" sign to "submit" this change
7) notice that the value for the attribute "Group" seems to be "Select One"
8) click the "double arrow" button at the bottom of the list (3rd from left) to "refresh list"
9) notice that the value for the attribute "Group" for participant "John D" is still empty
TagsNo tags attached.
Complete LimeSurvey version number (& build)130325
I will donate to the project if issue is resolvedNo
BrowserSafari - Version 6.0.2 (7536.26.17)
Database & DB-VersionMySQL - version 5.5.30-cll
Server OS (if known)linux
Webserver software & version (if known)Apache - version 2.2.22
PHP Version5.3.15

Activities

jopsvanthof

jopsvanthof

2013-04-02 19:01

reporter  

Archive.zip (4,986 bytes)
c_schmitz

c_schmitz

2013-04-19 16:45

administrator   ~24991

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12307
c_schmitz

c_schmitz

2013-04-22 14:21

administrator   ~25038

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12323
c_schmitz

c_schmitz

2013-04-23 16:30

administrator   ~25086

2.00+ Build 130424 release

Related Changesets

LimeSurvey: master 680c92e2

2013-04-19 14:45:36

c_schmitz

Details Diff
Fixed issue 07726: Value for participant attribute could be "select one", or so it seems Affected Issues
07726
mod - scripts/admin/displayParticipant.js Diff File

LimeSurvey: 2.05 57d7a82e

2013-04-19 14:45:36

c_schmitz

Details Diff
Fixed issue 07726: Value for participant attribute could be "select one", or so it seems Affected Issues
07726
mod - scripts/admin/displayParticipant.js Diff File

Issue History

Date Modified Username Field Change
2013-04-02 19:01 jopsvanthof New Issue
2013-04-02 19:01 jopsvanthof File Added: Archive.zip
2013-04-19 16:44 c_schmitz Assigned To => c_schmitz
2013-04-19 16:44 c_schmitz Status new => assigned
2013-04-19 16:45 c_schmitz Changeset attached => LimeSurvey master 680c92e2
2013-04-19 16:45 c_schmitz Note Added: 24991
2013-04-19 16:45 c_schmitz Resolution open => fixed
2013-04-19 16:45 c_schmitz Status assigned => resolved
2013-04-19 16:45 c_schmitz Fixed in Version => 2.00+
2013-04-22 14:21 c_schmitz Changeset attached => LimeSurvey 2.05 57d7a82e
2013-04-22 14:21 c_schmitz Note Added: 25038
2013-04-23 16:30 c_schmitz Note Added: 25086
2013-04-23 16:30 c_schmitz Status resolved => closed