View Issue Details

IDProjectCategoryView StatusLast Update
07650Bug reportsSurvey editingpublic2013-06-13 12:35
Reporterpucitss Assigned Toc_schmitz  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version2.00+ 
Fixed in Version2.05 RC 
Summary07650: Copying a survey does not copy the start date time/Expiry date/time
DescriptionEven in version 2.00.130305, copying a survey that has an existing "Start date/time" and "Expiry date/time" does not copy these attributes into the new survey. In previous versions to 2.00 this feature worked successfully.
Steps To ReproduceStart with a survey that has the "Start date/time" and "Expiry date/time" entered on the Publication and access control. Use the option "Copy a survey" to copy this particular survey. After copy is created look at the properties. The Start and Expiry dates are null, the original dates are not retained.
TagsNo tags attached.
Complete LimeSurvey version number (& build)130305
I will donate to the project if issue is resolvedNo
BrowserFirefox 19
Database & DB-VersionMySQL 5.1.66
Server OS (if known)Debian
Webserver software & version (if known)Apache/2.2.16 (Debian)
PHP Version5.3.3-7+squeeze15

Activities

c_schmitz

c_schmitz

2013-03-08 21:59

administrator   ~24601

This is not exactly true. In 1.92 when copying a survey the start date would be reset, but not the end date. We decided to have both reset because usually copying a survey means that you want to start a new one based on an old one.
c_schmitz

c_schmitz

2013-04-22 14:21

administrator   ~25035

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12320

Related Changesets

LimeSurvey: 2.05 baa889d8

2013-04-22 12:21:12

c_schmitz

Details Diff
New feature: When copying a survey you can choose if you want to include/exclude start/end date/time
Fixed issue 07650: Copying a survey does not copy the start date time/Expiry date/time
Affected Issues
07650
mod - application/controllers/admin/surveyadmin.php Diff File
mod - application/views/admin/survey/subview/tabCopy_view.php Diff File

Issue History

Date Modified Username Field Change
2013-03-08 21:35 pucitss New Issue
2013-03-08 21:59 c_schmitz Note Added: 24601
2013-03-08 21:59 c_schmitz Status new => closed
2013-03-08 21:59 c_schmitz Assigned To => c_schmitz
2013-03-08 21:59 c_schmitz Resolution open => won't fix
2013-04-11 11:51 c_schmitz Status closed => assigned
2013-04-22 14:21 c_schmitz Status assigned => resolved
2013-04-22 14:21 c_schmitz Fixed in Version => 2.05 RC
2013-04-22 14:21 c_schmitz Changeset attached => LimeSurvey 2.05 baa889d8
2013-04-22 14:21 c_schmitz Note Added: 25035
2013-04-22 14:21 c_schmitz Resolution won't fix => fixed
2013-06-13 12:35 c_schmitz Status resolved => closed
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing