View Issue Details

IDProjectCategoryView StatusLast Update
06849Development Statisticspublic2013-03-05 16:29
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynormalSeverityminor 
Status closedResolutionfixed 
Product Version2.00 
Target VersionFixed in Version2.00 
Summary06849: Review default fonts for statistics graph
Description

Some statitics langage make square for caracters (Belaussian/hebrew/Korean/Greek for example)

Steps To Reproduce

Test graph statistics with Belaussian/hebrew/Korean/Greek

Additional Information

I test with DejaVuSans.ttf (http://dejavu-fonts.org/) and it's OK for Greek, Belaussian, Hebrew, Arabic too. Not for Chinese.

I think we can replace vera.ttf default font for DejaVuSans.ttf (GPL font) without problem.

For chinese :> http://ftp.gnu.org/non-gnu/chinese-fonts-truetype/ seems Good.

TagsNo tags attached.

Relationships

related to 06845 closedDenisChenu Bug reports PDF statistics don't get pdfdefaultfont and pdffontsize 
child of 06846 closedc_schmitz Bug reports Graph statitistics in arabic are bad 

Activities

DenisChenu

DenisChenu

2012-11-11 13:58

developer   ~22054

For 2.0; it's an easy job, but add to remove fonts file and add fonts file.

DenisChenu

DenisChenu

2012-11-11 13:59

developer   ~22055

Linked with 06845, because same can be applied : use dejavusans by default

DenisChenu

DenisChenu

2012-11-11 14:04

developer   ~22056

Think we can include DejaVu for whole language,

except Chinese/ Korean/ Japanese
( http://www.texmacs.org/tmweb/download/fonts.en.html#fonts-complete )

c_schmitz

c_schmitz

2012-11-11 14:15

administrator   ~22057

Firefly is a font which works perfectly for Chinese: http://sourceforge.jp/projects/sfnet_chinesepuppy/downloads/ChineseSupport/Fonts/fireflysung-1.3.0.tar.gz/
That's what the .txt file also says in the /fonts folder ;).

Good idea to check on the other languages.

DenisChenu

DenisChenu

2012-11-11 15:09

developer   ~22062

Last edited: 2012-11-11 15:10

View 2 revisions

emacs include Firefly too.

We can include dejavusans by default : Belarussian/hebrew/Greek are OK with (deutch,french ... too). With vera : Belarussian/hebrew/Greek are squared.

Think leave actual fonts in directiry (if someone put it in gis config.php).

Denis

c_schmitz

c_schmitz

2012-11-11 15:11

administrator   ~22063

dejavusans sounds ok (hope it is not too big). I just never included the firefly file in the LimeSurvey package because it is a whopping 10MB file.

DenisChenu

DenisChenu

2012-11-11 15:25

developer   ~22064

DejaVuSans.ttf : 720,0 kb :)

DenisChenu

DenisChenu

2012-11-12 12:11

developer   ~22083

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10242

DenisChenu

DenisChenu

2012-11-12 12:19

developer   ~22084

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10243

Related Changesets

LimeSurvey: master 54c41e70

2012-11-12 11:09:35

DenisChenu

Details Diff
Fixed issue 06849: Bad caracter for statistics graph in some language
Dev: review default font, DejaVus Sans seems best, FreeSans can be a good alternative
Dev: Add a array of alternate fonts files for specific language. Don't include fonts files for specific language
Affected Issues
06849
mod - application/config/config-defaults.php Diff File
mod - application/helpers/admin/statistics_helper.php Diff File
add - fonts/DejaVuSans - CREDITS Diff File
add - fonts/DejaVuSans.ttf Diff File
add - fonts/FreeSans - CREDITS Diff File
add - fonts/FreeSans.ttf Diff File
rm - fonts/KacstFarsi.ttf Diff File
rm - fonts/KacstOffice.ttf Diff File
add - fonts/TlwgTypist - Thai.ttf.txt Diff File
add - fonts/UnBatang - Korean.ttf.txt Diff File
add - fonts/migmix-1p-regular - Japanese.ttf.txt Diff File
rm - fonts/vera.ttf Diff File
rm - fonts/verabd.ttf Diff File
rm - fonts/verait.ttf Diff File

LimeSurvey: 2.1 b1b71392

2012-11-12 11:09:35

DenisChenu

Details Diff
Fixed issue 06849: Bad caracter for statistics graph in some language
Dev: review default font, DejaVus Sans seems best, FreeSans can be a good alternative
Dev: Add a array of alternate fonts files for specific language. Don't include fonts files for specific language
Dev: Resolved Conflicts: application/helpers/admin/statistics_helper.php
Affected Issues
06849
mod - application/config/config-defaults.php Diff File
mod - application/helpers/admin/statistics_helper.php Diff File
add - fonts/DejaVuSans - CREDITS Diff File
add - fonts/DejaVuSans.ttf Diff File
add - fonts/FreeSans - CREDITS Diff File
add - fonts/FreeSans.ttf Diff File
rm - fonts/KacstFarsi.ttf Diff File
rm - fonts/KacstOffice.ttf Diff File
add - fonts/TlwgTypist - Thai.ttf.txt Diff File
add - fonts/UnBatang - Korean.ttf.txt Diff File
add - fonts/migmix-1p-regular - Japanese.ttf.txt Diff File
rm - fonts/vera.ttf Diff File
rm - fonts/verabd.ttf Diff File
rm - fonts/verait.ttf Diff File

Issue History

Date Modified Username Field Change
2012-11-11 13:58 DenisChenu New Issue
2012-11-11 13:58 DenisChenu Relationship added child of 06846
2012-11-11 13:58 DenisChenu Note Added: 22054
2012-11-11 13:59 DenisChenu Relationship added related to 06845
2012-11-11 13:59 DenisChenu Note Added: 22055
2012-11-11 14:04 DenisChenu Note Added: 22056
2012-11-11 14:15 c_schmitz Note Added: 22057
2012-11-11 15:09 DenisChenu Note Added: 22062
2012-11-11 15:10 DenisChenu Note Edited: 22062 View Revisions
2012-11-11 15:11 c_schmitz Note Added: 22063
2012-11-11 15:15 c_schmitz Assigned To => DenisChenu
2012-11-11 15:15 c_schmitz Status new => assigned
2012-11-11 15:25 DenisChenu Note Added: 22064
2012-11-12 12:11 DenisChenu Changeset attached => LimeSurvey master 54c41e70
2012-11-12 12:11 DenisChenu Note Added: 22083
2012-11-12 12:11 DenisChenu Resolution open => fixed
2012-11-12 12:19 DenisChenu Changeset attached => LimeSurvey 2.1 b1b71392
2012-11-12 12:19 DenisChenu Note Added: 22084
2012-11-12 12:26 DenisChenu Status assigned => resolved
2012-11-12 12:26 DenisChenu Fixed in Version => 2.00
2013-03-05 16:29 c_schmitz Status resolved => closed