View Issue Details

IDProjectCategoryView StatusLast Update
04793Bug reports[All Projects] Survey takingpublic2010-12-09 23:57
ReporterdragxslayAssigned Toc_schmitz 
PriorityhighSeveritymajor 
Status closedResolutionwon't fix 
Product Version1.90+ 
Target VersionFixed in Version 
Summary04793: Question Type Array (Numbers) Mandatory Checking Not Functioning
DescriptionI've got an Array (Numbers) type question that is set as mandatory, but I'm able to bypass the question without answering it.

I've created a survey in a dev environment to show the problem:
http://www.araxam.com/limesurvey/index.php?sid=76251&lang=en

Question 2 is the problematic question. I would be happy to provide additional info, just let me know what you need.
Steps To ReproduceCreate a survey with an array (numbers) question type, make it mandatory and under advanced options set it to checkboxes. When you take the survey, the mandatory is not enforced.
TagsNo tags attached.
Complete LimeSurvey version number (& build)9561
I will donate to the project if issue is resolvedYes
BrowserFireFox, IE, Chrome - Doesn't work in any
Database & DB-VersionMySQL
Operating System (Server)CentOs
Webserver software & versionApache
PHP Version5+

Relationships

duplicate of 04042 closedc_schmitz Array (Multi Flexible) (Numbers), checkbox layout not enforcing mandatory behavior 

Activities

Mazi

Mazi

2010-12-06 12:48

developer   ~13700

Please attach a simple sample survey which we can use for testing.

Thanks!
dragxslay

dragxslay

2010-12-06 21:17

reporter   ~13703

Yes, I included a link to a sample I setup in the description. If i should provide this differently please let me know how. Thank you!
Mazi

Mazi

2010-12-06 23:13

developer   ~13704

Please atach the survey as exported .lss file here so we can download it for testing locally.
c_schmitz

c_schmitz

2010-12-07 14:11

administrator   ~13707

dragxslay?
dragxslay

dragxslay

2010-12-07 14:23

reporter  

limesurvey_survey_76251.lss (20,975 bytes)
dragxslay

dragxslay

2010-12-07 14:23

reporter   ~13722

Please see attached survey.
c_schmitz

c_schmitz

2010-12-09 23:57

administrator   ~13740

Sorry, not a bug. Please see the explanation at 04042.

Issue History

Date Modified Username Field Change
2010-12-06 01:51 dragxslay New Issue
2010-12-06 12:48 Mazi Note Added: 13700
2010-12-06 21:17 dragxslay Note Added: 13703
2010-12-06 23:13 Mazi Note Added: 13704
2010-12-07 14:11 c_schmitz Note Added: 13707
2010-12-07 14:11 c_schmitz Assigned To => c_schmitz
2010-12-07 14:11 c_schmitz Status new => feedback
2010-12-07 14:23 dragxslay File Added: limesurvey_survey_76251.lss
2010-12-07 14:23 dragxslay Note Added: 13722
2010-12-07 14:23 dragxslay Status feedback => assigned
2010-12-09 23:56 c_schmitz Relationship added duplicate of 04042
2010-12-09 23:57 c_schmitz Note Added: 13740
2010-12-09 23:57 c_schmitz Status assigned => closed
2010-12-09 23:57 c_schmitz Resolution open => won't fix