View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
19561Bug reports_ Unknownpublic2024-05-22 16:23
Reporterritapas Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status resolvedResolutionfixed 
Product Version6.5.x 
Summary19561: popup messages come with HTML inside
Description

popup messages come with HTML inside, at least in this case

Steps To Reproduce

Steps to reproduce

create a new user, set an empty password and press save

Expected result

message about password policy is shown in formatted text and it stays

Actual result

message about password policy is shown in unformatted text with html tags inside it. Moreover, it disappears quite quickly
(please see picture)

TagsNo tags attached.
Attached Files
popup_with_html.PNG (51,999 bytes)   
popup_with_html.PNG (51,999 bytes)   
Bug heat6
Complete LimeSurvey version number (& build) 6.5.4 (build 240422)
I will donate to the project if issue is resolvedNo
Browser
Database type & version Database driver pgsql Database driver version 13.5
Server OS (if known)
Webserver software & version (if known)
PHP Version PHP version 7.4.33

Users monitoring this issue

ritapas

Activities

tibor.pacalat

tibor.pacalat

2024-05-13 16:00

administrator   ~80095

I can confirm this.

DenisChenu

DenisChenu

2024-05-13 17:49

developer   ~80097

Last edited: 2024-05-13 17:50

I can move the create user on a single page ?

Form in dialog must be forbidden !

tibor.pacalat

tibor.pacalat

2024-05-14 10:34

administrator   ~80099

Why?

DenisChenu

DenisChenu

2024-05-14 12:03

developer   ~80102

Because have a so little form is badly usable

But OK, this one just need to be bigger.

DenisChenu

DenisChenu

2024-05-15 11:59

developer   ~80112

https://github.com/LimeSurvey/LimeSurvey/pull/3848

DenisChenu

DenisChenu

2024-05-15 12:04

developer   ~80113

A good way to test too (with empty password)

tes@éxample.net for email : accepted by email input, disable by PHPMailer.

I have another issue : only one error retuirn for

  1. Passwords do not match
  2. Plugin password restriction

But really minor :)

tibor.pacalat

tibor.pacalat

2024-05-16 15:51

administrator   ~80119

Needs code review, but I have tested the fix successfully.

DenisChenu

DenisChenu

2024-05-16 16:11

developer   ~80120

Last edited: 2024-05-16 16:12

@tibor.pacalat : i don't know if i still assign to Gabriel by default ?

tibor.pacalat

tibor.pacalat

2024-05-16 17:47

administrator   ~80122

@DenisChenu I'll ask him, but I did for now since it is better like that, then there is no one assigned to review.

DenisChenu

DenisChenu

2024-05-22 16:23

developer   ~80150

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=36365

DenisChenu

DenisChenu

2024-05-22 16:23

developer   ~80151

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=36366

Related Changesets

LimeSurvey: master f4404c9b

2024-05-22 16:23:34

DenisChenu


Committer: GitHub Details Diff
Fixed issue 19561: popup messages come with HTML inside (03848) Affected Issues
19561
mod - application/controllers/UserManagementController.php Diff File
mod - assets/packages/usermanagement/js/usermanagement.js Diff File

LimeSurvey: master f4404c9b

2024-05-22 16:23:34

DenisChenu


Committer: GitHub Details Diff
Fixed issue 19561: popup messages come with HTML inside (03848) Affected Issues
19561
mod - application/controllers/UserManagementController.php Diff File
mod - assets/packages/usermanagement/js/usermanagement.js Diff File

Issue History

Date Modified Username Field Change
2024-05-13 15:20 ritapas New Issue
2024-05-13 15:20 ritapas File Added: popup_with_html.PNG
2024-05-13 16:00 tibor.pacalat Assigned To => tibor.pacalat
2024-05-13 16:00 tibor.pacalat Status new => confirmed
2024-05-13 16:00 tibor.pacalat Note Added: 80095
2024-05-13 16:00 tibor.pacalat Bug heat 0 => 2
2024-05-13 16:01 tibor.pacalat Assigned To tibor.pacalat => DenisChenu
2024-05-13 17:49 DenisChenu Note Added: 80097
2024-05-13 17:49 DenisChenu Bug heat 2 => 4
2024-05-13 17:50 DenisChenu Note Edited: 80097
2024-05-14 10:34 tibor.pacalat Note Added: 80099
2024-05-14 10:35 ritapas Issue Monitored: ritapas
2024-05-14 10:35 ritapas Bug heat 4 => 6
2024-05-14 12:03 DenisChenu Note Added: 80102
2024-05-15 11:59 DenisChenu Note Added: 80112
2024-05-15 12:04 DenisChenu Note Added: 80113
2024-05-16 09:58 DenisChenu Assigned To DenisChenu => tibor.pacalat
2024-05-16 09:58 DenisChenu Status confirmed => ready for code review
2024-05-16 15:51 tibor.pacalat Note Added: 80119
2024-05-16 16:11 DenisChenu Note Added: 80120
2024-05-16 16:12 DenisChenu Note Edited: 80120
2024-05-16 17:47 tibor.pacalat Note Added: 80122
2024-05-20 19:04 gabrieljenik Status ready for code review => ready for testing
2024-05-22 16:23 DenisChenu Changeset attached => LimeSurvey master f4404c9b
2024-05-22 16:23 DenisChenu Changeset attached => LimeSurvey master f4404c9b
2024-05-22 16:23 DenisChenu Note Added: 80150
2024-05-22 16:23 DenisChenu Note Added: 80151
2024-05-22 16:23 DenisChenu Assigned To tibor.pacalat => DenisChenu
2024-05-22 16:23 DenisChenu Assigned To tibor.pacalat => DenisChenu
2024-05-22 16:23 DenisChenu Resolution open => fixed
2024-05-22 16:23 DenisChenu Resolution open => fixed
2024-05-22 16:23 tibor.pacalat Status ready for testing => resolved