View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18354Bug reportsUser / Groups / Rolespublic2022-09-27 21:45
Reporterknorke Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionno change required 
Product Version3.28.x 
Summary18354: editing survey permissions do need superadministrator rights
Description

Survey owners can not edit nor see survey permissions without superadministrator rights anymore.

Steps To Reproduce

Expected result

A survey owner should be able to add users to his survey with at least "users view/read" rights.

A survey owner should be able to see if other users have permissions on his survey.

Actual result

It seems that only superadministrator rights can achieve the expected result.

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build) 3.28.28+220912
I will donate to the project if issue is resolvedNo
Browser
Database type & version10.4.26-MariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4.30

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

knorke

knorke

2022-09-15 13:55

reporter  

1.png (110,698 bytes)
2.png (28,845 bytes)   
2.png (28,845 bytes)   
3.png (101,054 bytes)
4.png (35,708 bytes)   
4.png (35,708 bytes)   
ollehar

ollehar

2022-09-15 14:16

administrator   ~71766

Does this issue exist in LimeSurvey 5.4?

DenisChenu

DenisChenu

2022-09-15 15:35

developer   ~71767

Last edited: 2022-09-15 15:36

Related to "Group member can only see own group" : https://manual.limesurvey.org/Global_settings/en#Security
user can not see any user because "Group member can only see own group" set to Yes.

Please control with this option to false.

Or with 2 user in same group

knorke

knorke

2022-09-16 11:33

reporter   ~71782

Thx for clarification.

DenisChenu

DenisChenu

2022-09-16 12:17

developer   ~71784

It's OK if user are in same group ?

We really need to document this feature more.

And : when there are no UserGroup : maybe it's best to disable this system (and use only User Global Permission ?)

knorke

knorke

2022-09-16 12:57

reporter   ~71787

Yes, works perfect if users are in the same group. It's a good feature, though not very intuitive to use.

Issue History

Date Modified Username Field Change
2022-09-15 13:55 knorke New Issue
2022-09-15 13:55 knorke File Added: 1.png
2022-09-15 13:55 knorke File Added: 2.png
2022-09-15 13:55 knorke File Added: 3.png
2022-09-15 13:55 knorke File Added: 4.png
2022-09-15 14:16 ollehar Note Added: 71766
2022-09-15 14:16 ollehar Bug heat 0 => 2
2022-09-15 14:17 ollehar Assigned To => ollehar
2022-09-15 14:17 ollehar Status new => feedback
2022-09-15 15:35 DenisChenu Note Added: 71767
2022-09-15 15:35 DenisChenu Bug heat 2 => 4
2022-09-15 15:36 DenisChenu Note Edited: 71767
2022-09-16 11:33 knorke Note Added: 71782
2022-09-16 11:33 knorke Bug heat 4 => 6
2022-09-16 11:33 knorke Status feedback => assigned
2022-09-16 12:17 DenisChenu Note Added: 71784
2022-09-16 12:57 knorke Note Added: 71787
2022-09-16 14:17 DenisChenu Status assigned => resolved
2022-09-16 14:17 DenisChenu Resolution open => no change required
2022-09-27 21:45 c_schmitz Status resolved => closed