View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18261Bug reportsStatisticspublic2022-08-08 09:16
Reporterjelen1 Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18261: Simple statistics, "Array (5 point choice)" dont show subquestions
Description

The graphs with the results are only titled with the text of the question, but the text of the subquestion is missing.

Steps To Reproduce

Steps to reproduce

Do any survey and only one question type "Array (5 point choice)"
Start it and fill some sorveys.
Then press statistics -> simple mode.

Expected result

Question + subquestion as tittles of charts

Actual result

The same main question only titled every chart. No subquestion text.

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)Version 5.3.26+220720
I will donate to the project if issue is resolvedNo
Browser
Database type & versionMysql 10.3.35
Server OS (if known)
Webserver software & version (if known)
PHP Version7.4.30

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

jelen1

jelen1

2022-07-19 14:04

reporter  

charts without subq.jpg (264,179 bytes)
jelen1

jelen1

2022-07-19 14:08

reporter   ~71014

one of five.jpg (53,339 bytes)   
one of five.jpg (53,339 bytes)   
gabrieljenik

gabrieljenik

2022-07-21 15:12

manager   ~71078

BY the screenshots, this can be confirmed

jelen1

jelen1

2022-07-26 14:59

reporter   ~71141

I've tried other array questions and it looks like they all have the same problem.

gabrieljenik

gabrieljenik

2022-08-01 19:36

manager   ~71279

PR: https://github.com/LimeSurvey/LimeSurvey/pull/2554

gabrieljenik

gabrieljenik

2022-08-03 16:01

manager   ~71309

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33704

LimeBot

LimeBot

2022-08-08 09:16

administrator   ~71363

Fixed in Release 5.3.30+220808

Related Changesets

LimeSurvey: master 46331830

2022-08-03 16:01:52

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18261: Simple statistics, 'Array (5 point choice)' dont show subquestions (#2554)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
18261
mod - application/helpers/admin/statistics_helper.php Diff File
mod - application/views/admin/export/generatestats/simplestats/_statisticsoutput_header.php Diff File

Issue History

Date Modified Username Field Change
2022-07-19 14:04 jelen1 New Issue
2022-07-19 14:04 jelen1 File Added: charts without subq.jpg
2022-07-19 14:08 jelen1 Note Added: 71014
2022-07-19 14:08 jelen1 File Added: one of five.jpg
2022-07-19 14:08 jelen1 Bug heat 0 => 2
2022-07-21 15:12 gabrieljenik Status new => confirmed
2022-07-21 15:12 gabrieljenik Note Added: 71078
2022-07-21 15:12 gabrieljenik Bug heat 2 => 4
2022-07-25 21:51 gabrieljenik Assigned To => gabrieljenik
2022-07-25 21:51 gabrieljenik Status confirmed => assigned
2022-07-26 14:59 jelen1 Note Added: 71141
2022-08-01 19:36 gabrieljenik Status assigned => feedback
2022-08-01 19:36 gabrieljenik Note Added: 71279
2022-08-01 19:37 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-08-01 19:37 gabrieljenik Status feedback => ready for code review
2022-08-01 19:40 gabrieljenik Issue cloned: 18299
2022-08-03 16:01 gabrieljenik Changeset attached => LimeSurvey master 46331830
2022-08-03 16:01 gabrieljenik Note Added: 71309
2022-08-03 16:01 gabrieljenik Assigned To DenisChenu => gabrieljenik
2022-08-03 16:01 gabrieljenik Resolution open => fixed
2022-08-03 16:02 ollehar Status ready for code review => resolved
2022-08-08 09:16 LimeBot Note Added: 71363
2022-08-08 09:16 LimeBot Status resolved => closed
2022-08-08 09:16 LimeBot Bug heat 4 => 6