View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18222Bug reportsAssetspublic2022-08-03 18:24
Reporteradelphisurveys Assigned Togabrieljenik  
PrioritynoneSeveritycrash 
Status closedResolutionunable to reproduce 
Product Version5.3.x 
Summary18222: Error 500 - Can't open Assessment
Description

I have updated LimeSurvey from version 3.28.16+220621 to version 5.3.22+220628. In the process, I have now noticed that under
"Surveys" → "A Survey" → "Assessment"
I can't open it. So it loads and loads, but it doesn't get to the end. I didn't find anything in my apache error log about this either. In Limesurvey I set the debug mode to 2, also there I don't get any error about it. In the developer console I get the following:

AdminCore Triggering panel animation
pjax.js:433 GET test-environment.adelphi.de/index.php/su...lugins&1656426806919 500
doRequest @ pjax.js:433
loadUrl @ pjax.js:1673
linkAction @ pjax.js:652
(anonymous) @ pjax.js:668
pjax.js:433 XHR failed loading: GET " test-environment.adelphi.de/index.php/su...lugins&1656426806919 ".

So when I throw the url - which LimeSurvey actually wants to call itself - into the browser line - I get the following error message:

/index.php/admin/assessments/sa/index/surveyid/68xx19

404 Nicht gefunden
Das System konnte die angeforderte Action "assessments" nicht finden.
Die angeforderte URL wurde auf diesem Server nicht gefunden. Wenn Sie die URL manuell eingegeben haben, überprüfen Sie bitte Ihre Rechtschreibung und versuchen Sie es erneut.

Wenn Sie glauben, dass dies ein Serverfehler ist, wenden Sie sich an adelphi Webmaster.

#0 /srv/www/test-environment/home/www/framework/web/CController.php(270): CController->missingAction()
#1 /srv/www/test-environment/home/www/application/controllers/AdminController.php(202): CController->run()
#2 /srv/www/test-environment/home/www/framework/web/CWebApplication.php(282): AdminController->run()
#3 /srv/www/test-environment/home/www/framework/web/CWebApplication.php(141): CWebApplication->runController()
#4 /srv/www/test-environment/home/www/framework/base/CApplication.php(185): CWebApplication->processRequest()
#5 /srv/www/test-environment/home/www/index.php(192): CApplication->run()
#6 {main}

Can anyone help me? I have also deactivated all LS plugins and all browser addons. But that did not help.

Steps To Reproduce

I have updated LimeSurvey from version 3.28.16+220621 to version 5.3.22+220628. In the process, I have now noticed that under
"Surveys" → "A Survey" → "Assessment"
I can't open it. So it loads and loads, but it doesn't get to the end. I didn't find anything in my apache error log about this either. In Limesurvey I set the debug mode to 2, also there I don't get any error about it.

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.3.22+220628
I will donate to the project if issue is resolvedNo
BrowserChrome, Firefox, Edge
Database type & versionmysql Ver 15.1 Distrib 10.5.15-MariaDB, for debian-linux-gnu (x86_64)
Server OS (if known)Debian 11.3
Webserver software & version (if known)
PHP VersionPHP 7.4.30 (cli) (built: Jun 27 2022 08:14:10) ( NTS )

Users monitoring this issue

User List adelphisurveys

Activities

adelphisurveys

adelphisurveys

2022-06-29 15:10

reporter  

Lime Survey error.png (75,609 bytes)   
Lime Survey error.png (75,609 bytes)   
Lime Survey error2.png (60,512 bytes)   
Lime Survey error2.png (60,512 bytes)   
adelphisurveys

adelphisurveys

2022-06-30 15:59

reporter   ~70635

I even have the menu item "Participant Settings" twice. I can open the first one normally and I cannot open the second menu item. I get the following error, maybe this will help.

gabrieljenik

gabrieljenik

2022-07-02 01:39

manager   ~70688

Hi,

Can you please try resetting the menus and try again?
https://manual.limesurvey.org/Menu_configuration/en#Reset_to_default_values

Thanks

adelphisurveys

adelphisurveys

2022-07-07 14:27

reporter   ~70786

So the problem with the two duplicate menu links I could already solve myself. I simply removed one of them, the one that doesn't work.
However, I still have the menu item Simple plugins.
Before the upgrade to the 5 it was from the plugin AuditLog.
You can also see in the first screenshot from the 3 version.
But in the 5 er I can't open it anymore. When I copy the link from the menu to the browser line, I get the error message in the last screenshot.
But if I see this correctly, the plugin no longer exists in the 5 er version or has passed into another plugin?
Should I remove it?

AuditLog.png (55,365 bytes)   
AuditLog.png (55,365 bytes)   
LimeSurveyPlugins1.png (26,824 bytes)   
LimeSurveyPlugins1.png (26,824 bytes)   
LimeSurveyPlugins2.png (26,194 bytes)   
LimeSurveyPlugins2.png (26,194 bytes)   
Simple Plugin error.png (80,641 bytes)   
Simple Plugin error.png (80,641 bytes)   
gabrieljenik

gabrieljenik

2022-07-11 18:17

manager   ~70876

Hi @adelphisurveys,

Have you tried resetting the menus? From the messages, I am not sure if you have done that.

Also, can yu save the screenshot with the bug and stacktrace in a PDF so we can see all the stack trace?

Thanks!

gabrieljenik

gabrieljenik

2022-08-03 18:24

manager   ~71315

Hello adelphisurveys,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

gabrieljenik

Issue History

Date Modified Username Field Change
2022-06-29 15:10 adelphisurveys New Issue
2022-06-29 15:10 adelphisurveys File Added: Lime Survey error.png
2022-06-29 15:10 adelphisurveys File Added: Lime Survey error2.png
2022-06-30 15:53 adelphisurveys Issue Monitored: adelphisurveys
2022-06-30 15:53 adelphisurveys Bug heat 0 => 2
2022-06-30 15:59 adelphisurveys Note Added: 70635
2022-06-30 15:59 adelphisurveys File Added: 2022-06-30 15_39_26-CException.png
2022-06-30 15:59 adelphisurveys File Added: 2022-06-30 15_56_44-adelphi LimeSurvey.png
2022-06-30 15:59 adelphisurveys Bug heat 2 => 4
2022-07-02 01:39 gabrieljenik Assigned To => gabrieljenik
2022-07-02 01:39 gabrieljenik Status new => feedback
2022-07-02 01:39 gabrieljenik Note Added: 70688
2022-07-02 01:39 gabrieljenik Bug heat 4 => 6
2022-07-07 14:27 adelphisurveys Note Added: 70786
2022-07-07 14:27 adelphisurveys File Added: AuditLog.png
2022-07-07 14:27 adelphisurveys File Added: LimeSurveyPlugins1.png
2022-07-07 14:27 adelphisurveys File Added: LimeSurveyPlugins2.png
2022-07-07 14:27 adelphisurveys File Added: Simple Plugin error.png
2022-07-07 14:27 adelphisurveys Status feedback => assigned
2022-07-11 18:17 gabrieljenik Note Added: 70876
2022-07-11 18:17 gabrieljenik Status assigned => feedback
2022-08-03 18:24 gabrieljenik Status feedback => closed
2022-08-03 18:24 gabrieljenik Resolution open => unable to reproduce
2022-08-03 18:24 gabrieljenik Note Added: 71315