View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
18221Bug reportsInstallationpublic2022-07-18 15:29
Reporter_uname_ Assigned Togabrieljenik  
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18221: Post-installation problems, inability to create survey and save settings
Description

Tested with 5.3.x and 3.28.x.

just finished the installation, everything went smoothly, when I try from admin to create a new survey, it turns me to a page with just this text at the top:

"redirecturl:"/index.php/questionAdministration/view?surveyid=643834&gid=4&qid=4&landOnSideMenuTab=structure"

I also noticed that it doesn't save my settings.

It appeared that parts of the code were not loaded

SOLUTION

The problem was the PHP "short_open_tag" (must be ON).

"Maybe we need to check it at installation … and put in in manual." DC

Steps To Reproduce

Steps to reproduce

installation with "short_open_tag" settings in OFF in the php.ini

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)5.3.20 and 3.28.17
I will donate to the project if issue is resolvedNo
Browsersafari, firefox, chrome
Database type & versionpercona 8.0.20
Server OS (if known)ubuntu bionic
Webserver software & version (if known)apache 2.4.29
PHP Versionphp 7.4.30

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2022-06-29 15:06

developer   ~70611

DC is me ;)

Yes : we don't «fix» it claerly
But

  1. Need to be in manual
  2. Must check (or inform) on install
gabrieljenik

gabrieljenik

2022-07-18 15:29

manager   ~71002

Updated in manual
https://manual.limesurvey.org/Installation_-_LimeSurvey_CE

Issue History

Date Modified Username Field Change
2022-06-29 14:45 _uname_ New Issue
2022-06-29 15:06 DenisChenu Note Added: 70611
2022-06-29 15:06 DenisChenu Bug heat 0 => 2
2022-07-02 01:41 gabrieljenik Status new => confirmed
2022-07-18 15:29 gabrieljenik Note Added: 71002
2022-07-18 15:29 gabrieljenik Bug heat 2 => 4
2022-07-18 15:29 gabrieljenik Assigned To => gabrieljenik
2022-07-18 15:29 gabrieljenik Status confirmed => closed
2022-07-18 15:29 gabrieljenik Resolution open => fixed