View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18185Bug reportsComfortUpdatepublic2022-06-27 14:03
ReporterEinkauf.ZIT Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18185: Cannot update to 220607 - Error
Description

I get the following error after/in the step "Sicherung":

Sie haben einen Fehler in Ihrer lokalen Installation von LimeSurvey. Siehe:
{"success":false,"message":"Weder Update noch zugeh\u00f6rige Behavior haben einen Scope \"_renderErrorString\".","error":{"code":500,"type":"CException","errorCode":0,"message":"Weder Update noch zugeh\u00f6rige Behavior haben einen Scope \"_renderErrorString\".","file":"E:\WWW\UMFRAGE\framework\base\CComponent.php","line":266,"trace":"#0 E:\WWW\UMFRAGE\application\controllers\admin\update.php(405): CComponent->__call('_renderErrorStr...', Array)\n#1 [internal function]: Update->step4()\n#2 E:\WWW\UMFRAGE\framework\web\actions\CAction.php(115): ReflectionMethod->invokeArgs(Object(Update), Array)\n#3 E:\WWW\UMFRAGE\application\core\SurveyCommonAction.php(83): CAction->runWithParamsInternal(Object(Update), Object(ReflectionMethod), Array)\n#4 E:\WWW\UMFRAGE\framework\web\CController.php(308): SurveyCommonAction->runWithParams(Array)\n#5 E:\WWW\UMFRAGE\framework\web\CController.php(286): CController->runAction(Object(Update))\n#6 E:\WWW\UMFRAGE\framework\web\CController.php(265): CController->runActionWithFilters(Object(Update), Array)\n#7 E:\WWW\UMFRAGE\application\controllers\AdminController.php(202): CController->run('update')\n#8 E:\WWW\UMFRAGE\framework\web\CWebApplication.php(282): AdminController->run('update')\n#9 E:\WWW\UMFRAGE\framework\web\CWebApplication.php(141): CWebApplication->runController('admin\/update\/sa...')\n#10 E:\WWW\UMFRAGE\framework\base\CApplication.php(185): CWebApplication->processRequest()\n#11 E:\WWW\UMFRAGE\index.php(192): CApplication->run()\n#12 {main}","traces":[{"file":"E:\WWW\UMFRAGE\application\controllers\admin\update.php","line":405,"function":"__call","class":"CComponent","type":"->","args":["_renderErrorString",["cant_remove_deleted_files"]]},{"function":"step4","class":"Update","type":"->","args":[],"file":"unknown","line":0},{"file":"E:\WWW\UMFRAGE\framework\web\actions\CAction.php","line":115,"function":"invokeArgs","class":"ReflectionMethod","type":"->","args":[{},[]]},{"file":"E:\WWW\UMFRAGE\application\core\SurveyCommonAction.php","line":83,"function":"runWithParamsInternal","class":"CAction","type":"->","args":[{},{"name":"step4","class":"Update"},{"r":"admin\/update\/sa\/step4","sa":"step4"}]},{"file":"E:\WWW\UMFRAGE\framework\web\CController.php","line":308,"function":"runWithParams","class":"SurveyCommonAction","type":"->","args":[{"r":"admin\/update\/sa\/step4","sa":"step4"}]},{"file":"E:\WWW\UMFRAGE\framework\web\CController.php","line":286,"function":"runAction","class":"CController","type":"->","args":[{}]},{"file":"E:\WWW\UMFRAGE\framework\web\CController.php","line":265,"function":"runActionWithFilters","class":"CController","type":"->","args":[{},[]]},{"file":"E:\WWW\UMFRAGE\application\controllers\AdminController.php","line":202,"function":"run","class":"CController","type":"->","args":["update"]},{"file":"E:\WWW\UMFRAGE\framework\web\CWebApplication.php","line":282,"function":"run","class":"AdminController","type":"->","args":["update"]},{"file":"E:\WWW\UMFRAGE\framework\web\CWebApplication.php","line":141,"function":"runController","class":"CWebApplication","type":"->","args":["admin\/update\/sa\/step4"]},{"file":"E:\WWW\UMFRAGE\framework\base\CApplication.php","line":185,"function":"processRequest","class":"CWebApplication","type":"->","args":[]},{"file":"E:\WWW\UMFRAGE\index.php","line":192,"function":"run","class":"CApplication","type":"->","args":[]}]}}

Steps To Reproduce

Steps to reproduce

Restart the comfort update

Expected result

Finish comfort update successfully

Actual result

Comfort update stops at error

TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.3.14+220516
I will donate to the project if issue is resolvedNo
BrowserEvery browser
Database type & versionMySQL 5.7.12
Server OS (if known)Windows Server 2012 R2 Standard Edition
Webserver software & version (if known)IIS 8.5
PHP Version7.3.20

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Einkauf.ZIT

Einkauf.ZIT

2022-06-13 11:07

reporter   ~70344

Any information?

Einkauf.ZIT

Einkauf.ZIT

2022-06-20 11:15

reporter   ~70415

No help?

c_schmitz

c_schmitz

2022-06-21 21:39

administrator   ~70468

Problem seems to be this: "cant_remove_deleted_files"
There is a file that cannot be removed, probably due to permissions.

c_schmitz

c_schmitz

2022-06-21 21:44

administrator   ~70469

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33588

c_schmitz

c_schmitz

2022-06-21 21:45

administrator   ~70470

Try to apply the fix manually, then run the update again and a proper error message should be shown along with the file name of the problematic file.

LimeBot

LimeBot

2022-06-27 14:03

administrator   ~70555

Fixed in Release 5.3.22+220628

Related Changesets

LimeSurvey: master 297841a9

2022-06-21 21:44:21

c_schmitz

Details Diff
Fixed issue 18185: Error message "No scope _renderErrorString" when trying to update Affected Issues
18185
mod - application/controllers/admin/Update.php Diff File

Issue History

Date Modified Username Field Change
2022-06-09 11:34 Einkauf.ZIT New Issue
2022-06-13 11:07 Einkauf.ZIT Note Added: 70344
2022-06-13 11:07 Einkauf.ZIT Bug heat 0 => 2
2022-06-20 11:15 Einkauf.ZIT Note Added: 70415
2022-06-21 21:39 c_schmitz Note Added: 70468
2022-06-21 21:39 c_schmitz Bug heat 2 => 4
2022-06-21 21:44 c_schmitz Changeset attached => LimeSurvey master 297841a9
2022-06-21 21:44 c_schmitz Note Added: 70469
2022-06-21 21:44 c_schmitz Assigned To => c_schmitz
2022-06-21 21:44 c_schmitz Resolution open => fixed
2022-06-21 21:45 c_schmitz Status new => resolved
2022-06-21 21:45 c_schmitz Note Added: 70470
2022-06-27 14:03 LimeBot Note Added: 70555
2022-06-27 14:03 LimeBot Status resolved => closed
2022-06-27 14:03 LimeBot Bug heat 4 => 6