View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
18155Bug reportsTranslationpublic2022-07-25 10:15
Reporterjelen1 Assigned Togabrieljenik  
PrioritynoneSeveritytext 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18155: Translation missing in question editor
Description

Untranslated phrase (not in the translate.limesurvey.org project) in question editor

  • Array filter style: - switch options and help
  • Relevance help for printable survey (this phrase)
  • Others - SPSS for export - pulldown menu entries
Steps To Reproduce

Czech interface is fully translated, but those phrases still in english (after interface language is changed to czech).

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)5.3.17+220525
I will donate to the project if issue is resolvedNo
Browser
Database type & versionmysql 10.3.34-MariaDB-cll-lve
Server OS (if known)
Webserver software & version (if known)
PHP Version 7.4.29

Relationships

parent of 18198 closedgabrieljenik Translation not seen: "Warn and move on" 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

jelen1

jelen1

2022-05-27 16:04

reporter   ~70068

Next untranslated (and not available in translate project to transtate):

  • "Position for 'Other:' option" + pullup menu entries + help
  • "Answer code for 'After specific answer option' " + help
gabrieljenik

gabrieljenik

2022-06-03 19:52

manager   ~70218

https://github.com/LimeSurvey/LimeSurvey/pull/2456

There were two problems.
1- There were options of the settings type "buttongroup" and "singleselect" that were not being translated.
2 - There were texts that were only in the config.xml (some because they were new and others because they changed) and so they are not included in the translation modules

gabrieljenik

gabrieljenik

2022-06-27 01:26

manager   ~70539

Tested it.
Translated text is not visible, of course, as the strings are not present yet to be translated, as the changes are not merged yet.

DenisChenu

DenisChenu

2022-06-27 15:12

developer   ~70562

1- There were options of the settings type "buttongroup" and "singleselect" that were not being translated.

To avoid this : best is to translate it in https://github.com/LimeSurvey/LimeSurvey/blob/master/application/extensions/AdvancedSettingWidget/AdvancedSettingWidget.php

gabrieljenik

gabrieljenik

2022-06-27 15:24

manager   ~70564

Some time ago with Olle we said to have a central place where to locate these kind of strings which are not detected by the robot.
https://github.com/LimeSurvey/LimeSurvey/pull/2456/files#diff-2a53578ef545195e185f082a9a75bc01df2f9dc49f5b7e7e105f6c91f1b70724

DenisChenu

DenisChenu

2022-07-11 17:32

developer   ~70875

I try to times to relaunch CI issue.

Maybe something related to QuestionTheme ?
(for information : data return by question theme are not the always the same than core …)

gabrieljenik

gabrieljenik

2022-07-20 14:56

manager   ~71054

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=33664

LimeBot

LimeBot

2022-07-25 10:15

administrator   ~71114

Fixed in Release 5.3.27+220725

Related Changesets

LimeSurvey: master 6dceacfe

2022-07-20 14:56:34

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 18155: Translation missing in question editor Affected Issues
18155
mod - application/extensions/AdvancedSettingWidget/AdvancedSettingWidget.php Diff File
mod - application/helpers/twig_translation_helper.php Diff File

Issue History

Date Modified Username Field Change
2022-05-27 11:37 jelen1 New Issue
2022-05-27 16:04 jelen1 Note Added: 70068
2022-05-27 16:04 jelen1 Bug heat 0 => 2
2022-05-27 22:27 gabrieljenik Assigned To => gabrieljenik
2022-05-27 22:27 gabrieljenik Status new => assigned
2022-06-03 19:52 gabrieljenik Status assigned => ready for code review
2022-06-03 19:52 gabrieljenik Note Added: 70218
2022-06-03 19:52 gabrieljenik Bug heat 2 => 4
2022-06-27 01:26 gabrieljenik Note Added: 70539
2022-06-27 01:26 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-06-27 15:12 DenisChenu Assigned To DenisChenu => gabrieljenik
2022-06-27 15:12 DenisChenu Status ready for code review => in code review
2022-06-27 15:12 DenisChenu Note Added: 70562
2022-06-27 15:12 DenisChenu Bug heat 4 => 6
2022-06-27 15:24 gabrieljenik Note Added: 70564
2022-07-05 15:15 gabrieljenik Assigned To gabrieljenik => DenisChenu
2022-07-06 15:13 DenisChenu Status in code review => ready for testing
2022-07-11 17:32 DenisChenu Status ready for testing => assigned
2022-07-11 17:32 DenisChenu Note Added: 70875
2022-07-14 00:19 gabrieljenik Relationship added parent of 18198
2022-07-18 14:55 gabrieljenik Status assigned => ready for testing
2022-07-20 08:56 DenisChenu Assigned To DenisChenu => gabrieljenik
2022-07-20 08:56 DenisChenu Status ready for testing => ready for merge
2022-07-20 14:56 gabrieljenik Changeset attached => LimeSurvey master 6dceacfe
2022-07-20 14:56 gabrieljenik Note Added: 71054
2022-07-20 14:56 gabrieljenik Resolution open => fixed
2022-07-25 10:15 LimeBot Note Added: 71114
2022-07-25 10:15 LimeBot Status ready for merge => closed
2022-07-25 10:15 LimeBot Bug heat 6 => 8