View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17576Bug reportsOtherpublic2021-09-07 16:37
Reporterjr_limesurvery_statconsult_de Assigned Top_teichmann  
PrioritynoneSeverityblock 
Status closedResolutionduplicate 
Product Version5.x 
Summary17576: PHP Error[8]: Undefined index: type ... updatedb_helper.php at line 4708
DescriptionWe're following

https://bugs.limesurvey.org/view.php?id=17568

and just checked with 5.1.7.

It unfortunately still does not work when it comes to updating the database - it now emits:

php limesurvey5.1.7_210908/application/commands/console.php updatedb
Update pgsql:host=localhost;port=5432;user=aaa;password=secret;dbname=aaa; with prefix :lime_ from 449 to 472
PHP Error[8]: Undefined index: type
    in file /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/application/helpers/update/updatedb_helper.php at line 4708
#0 /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/application/commands/UpdateDbCommand.php(45): db_upgrade_all()
#1 /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/framework/console/CConsoleCommandRunner.php(71): UpdateDBCommand->run()
#2 /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/framework/console/CConsoleApplication.php(92): CConsoleCommandRunner->run()
#3 /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/framework/base/CApplication.php(185): ConsoleApplication->processRequest()
#4 /var/www/virtual_hosts/bbb/docs/limesurvey5.1.7_210908/application/commands/console.php(69): ConsoleApplication->run()



Steps To ReproduceTry updating to most recent 5.1.x release.
Additional Informationinitially reported in 17568
TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)5.1.7
I will donate to the project if issue is resolvedNo
BrowserFF
Database type & versionPostgreSQL 11 / 11.12-0+deb10u1
Server OS (if known)Debian Buster x64 / 10.10
Webserver software & version (if known)Apache / 2.4.38-3+deb10u5
PHP VersionPHP7 / 7.3.29-1~deb10u1

Relationships

duplicate of 17568 closedp_teichmann PHP Error[2]: Invalid argument supplied for foreach() ... updatedb_helper.php at line 4954 / function decryptArchivedTables450 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

p_teichmann

p_teichmann

2021-09-07 16:25

administrator   ~66380

Last edited: 2021-09-07 16:25

View 2 revisions

Hello sorry for the trouble, there is small typo which prevents the update. We will release another version tomorrow,

However if you are feeling up to it you could apply the fix yourself beforehand. In the link on github is the commit with the string fix.
https://github.com/LimeSurvey/LimeSurvey/commit/630cfd5fa6245b986a8ef48ff49a6f9353560173

Hope i could be of help
jr_limesurvery_statconsult_de

jr_limesurvery_statconsult_de

2021-09-07 16:37

reporter   ~66381

No worries - thankyou! Your hard work keeping this nice piece of software always uptodate is really appreciated!!!
Again - thankyou all - we'll just wait for the release ;)

Issue History

Date Modified Username Field Change
2021-09-07 14:47 jr_limesurvery_statconsult_de New Issue
2021-09-07 15:18 c_schmitz Assigned To => p_teichmann
2021-09-07 15:18 c_schmitz Status new => assigned
2021-09-07 15:22 c_schmitz Relationship added duplicate of 17568
2021-09-07 15:22 c_schmitz Status assigned => closed
2021-09-07 15:22 c_schmitz Resolution open => duplicate
2021-09-07 16:25 p_teichmann Note Added: 66380
2021-09-07 16:25 p_teichmann Bug heat 0 => 2
2021-09-07 16:25 p_teichmann Note Edited: 66380 View Revisions
2021-09-07 16:37 jr_limesurvery_statconsult_de Note Added: 66381
2021-09-07 16:37 jr_limesurvery_statconsult_de Bug heat 2 => 4