View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
17514Bug reportsComfortUpdatepublic2021-09-29 12:11
ReporterMazi Assigned Toc_schmitz  
PrioritynoneSeveritypartial_block 
Status closedResolutionreopened 
Product Version3.25.20 
Summary17514: LS3 is marked as unstable at ComfortUpdate
DescriptionWhen running ComfortUpdate at Version 3.27.7+210713 I see LS 3 marked as unstable, see screenshot.
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)Version 3.27.7+210713
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMySQL
Server OS (if known)Ubuntu 20
Webserver software & version (if known)Apache
PHP Version7.3

Relationships

duplicate of 17510 closedc_schmitz Updates for 3.x in ComfortUpdate listed as unstable 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Mazi

Mazi

2021-08-16 14:19

partner  

image.png (67,861 bytes)   
image.png (67,861 bytes)   
ollehar

ollehar

2021-08-16 14:24

administrator   ~65996

Should be fixed in latest release. Can you check again, please? Latest release as in 10 min ago. ;)
Mazi

Mazi

2021-09-13 11:10

partner   ~66467

When checking for updates an an older 3.26.x version, LS3.x is still marked as unstable.
image-2.png (30,293 bytes)   
image-2.png (30,293 bytes)   
ollehar

ollehar

2021-09-13 12:42

administrator   ~66468

I think you need to update the system to a later version to get rid of the "unstable" tag.
Mazi

Mazi

2021-09-13 14:42

partner   ~66470

@ollehar, can you provide some background information about this issue? Why is LS3.x suddenly shown as instable? This must be a bug with the updater system? Because until a few weeks ago, new 3.x releases were marked as stable just fine. How can this suddenly happen? It is confusing for many users.

BTW, I updated that system and even after having updated the updater first, it was still showing wrong.
ollehar

ollehar

2021-09-13 14:43

administrator   ~66471

This is absolutely just a small mistake. Nothing insidious to make people switch to LS5 faster.

Ping @c_schmitz for more info.
Mazi

Mazi

2021-09-29 12:05

partner   ~66648

@ollehar / @c_schmitz, any nws on this? Still when updating our systems we are presented LS 3.x as unstable. We also receive requests from our customers why that is a one had taken that as an indication to switch to LS 5.x which has caused him many problems because custom developed features were not working anymore.

Can we get rid of this confusing "instable" tag?
c_schmitz

c_schmitz

2021-09-29 12:10

administrator   ~66651

Last edited: 2021-09-29 12:11

View 2 revisions

This was fixed with version Release 3.27.12+210816.
Because it is hardcoded, you will need to update first to at least that version.

Related Changesets

LimeSurvey: 3.x-LTS 03644539

2021-08-13 17:03:24

c_schmitz

Details Diff
Fixed issue: LTS branch shown as unstable in ComfortUpdate Affected Issues
17514
mod - application/views/admin/update/check_updates/update_buttons/_updatesavailable.php Diff File

Issue History

Date Modified Username Field Change
2021-08-16 14:19 Mazi New Issue
2021-08-16 14:19 Mazi File Added: image.png
2021-08-16 14:21 Mazi Relationship added child of 17510
2021-08-16 14:24 ollehar Note Added: 65996
2021-08-16 14:24 ollehar Bug heat 0 => 2
2021-08-16 14:25 ollehar Assigned To => ollehar
2021-08-16 14:25 ollehar Status new => feedback
2021-08-17 08:59 c_schmitz Relationship replaced duplicate of 17510
2021-08-17 08:59 c_schmitz Status feedback => closed
2021-08-17 08:59 c_schmitz Resolution open => duplicate
2021-09-13 11:10 Mazi Note Added: 66467
2021-09-13 11:10 Mazi File Added: image-2.png
2021-09-13 11:10 Mazi Bug heat 2 => 4
2021-09-13 11:10 Mazi Status closed => new
2021-09-13 11:10 Mazi Resolution duplicate => reopened
2021-09-13 12:01 galads Status new => assigned
2021-09-13 12:42 ollehar Note Added: 66468
2021-09-13 14:42 Mazi Note Added: 66470
2021-09-13 14:43 ollehar Note Added: 66471
2021-09-29 12:05 Mazi Note Added: 66648
2021-09-29 12:09 c_schmitz Changeset attached => LimeSurvey 3.x-LTS 03644539
2021-09-29 12:10 c_schmitz Note Added: 66651
2021-09-29 12:10 c_schmitz Bug heat 4 => 6
2021-09-29 12:11 c_schmitz Note Edited: 66651 View Revisions
2021-09-29 12:11 c_schmitz Assigned To ollehar => c_schmitz
2021-09-29 12:11 c_schmitz Status assigned => closed