View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
17366Bug reportsSurvey takingpublic2021-07-12 11:53
ReporterJR_1234 Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version5.x 
Summary17366: Dual Matrix - Standard view - Dynamic generation of row labels is broken
DescriptionSiehe: https://forums.limesurvey.org/forum/german-forum/124738-matrix-dynamische-zeilen-label-limesurvey-version-5

Bei der Verwendung von Referenzen für die Labels einer Dual Matrix wird in der Standard-Ansicht anstelle des entsprechenden Wertes die Referenz ausgegeben. Also anstelle von des eingetragenen Wertes steht in der Umfrage z.B. '{Q2a_SQ01}'.

En: When using references for the labels of a dual matrix, the reference is output in the standard view instead of the corresponding value. So instead of the entered value the survey shows e.g. '{Q2a_SQ01}'.
Steps To ReproduceDas Beispiel von der Anleitung (https://manual.limesurvey.org/Question_type_-_Ranking#Array_filter_.28array_filter.29) laden. Hier kann es nachvollzogen werden.
Additional InformationNormale Matrix / Dual Matrix mit Drop Down funktionieren wie erwartet
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.0.4+210614
I will donate to the project if issue is resolvedNo
BrowserSafari
Database & DB-Version5.0.4+210614
Server OS (if known)Linux Debian
Webserver software & version (if known)Apache 2.0
PHP VersionPHP Version 7.3.27-1~deb10u1

Activities

JR_1234

JR_1234

2021-06-15 08:56

reporter  

limesurvey_question_516.lsq (10,350 bytes)   
<?xml version="1.0" encoding="UTF-8"?>
<document>
 <LimeSurveyDocType>Question</LimeSurveyDocType>
 <DBVersion>449</DBVersion>
 <languages>
  <language>en</language>
 </languages>
 <questions>
  <fields>
   <fieldname>qid</fieldname>
   <fieldname>parent_qid</fieldname>
   <fieldname>sid</fieldname>
   <fieldname>gid</fieldname>
   <fieldname>type</fieldname>
   <fieldname>title</fieldname>
   <fieldname>preg</fieldname>
   <fieldname>other</fieldname>
   <fieldname>mandatory</fieldname>
   <fieldname>encrypted</fieldname>
   <fieldname>question_order</fieldname>
   <fieldname>scale_id</fieldname>
   <fieldname>same_default</fieldname>
   <fieldname>relevance</fieldname>
   <fieldname>modulename</fieldname>
  </fields>
  <rows>
   <row>
    <qid><![CDATA[516]]></qid>
    <parent_qid><![CDATA[0]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[Q]]></type>
    <title><![CDATA[Products]]></title>
    <preg/>
    <other><![CDATA[N]]></other>
    <mandatory><![CDATA[N]]></mandatory>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[0]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance><![CDATA[1]]></relevance>
   </row>
  </rows>
 </questions>
 <subquestions>
  <fields>
   <fieldname>qid</fieldname>
   <fieldname>parent_qid</fieldname>
   <fieldname>sid</fieldname>
   <fieldname>gid</fieldname>
   <fieldname>type</fieldname>
   <fieldname>title</fieldname>
   <fieldname>preg</fieldname>
   <fieldname>other</fieldname>
   <fieldname>mandatory</fieldname>
   <fieldname>encrypted</fieldname>
   <fieldname>question_order</fieldname>
   <fieldname>scale_id</fieldname>
   <fieldname>same_default</fieldname>
   <fieldname>relevance</fieldname>
   <fieldname>modulename</fieldname>
   <fieldname>id</fieldname>
   <fieldname>question</fieldname>
   <fieldname>help</fieldname>
   <fieldname>script</fieldname>
   <fieldname>language</fieldname>
  </fields>
  <rows>
   <row>
    <qid><![CDATA[566]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ1]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[0]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[586]]></id>
    <question><![CDATA[Product 1]]></question>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[567]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ2]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[1]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[587]]></id>
    <question><![CDATA[Product 2]]></question>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[568]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ3]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[2]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[588]]></id>
    <question><![CDATA[Product 3]]></question>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[569]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ4]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[3]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[589]]></id>
    <question><![CDATA[Product 4]]></question>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[570]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ5]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[4]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[590]]></id>
    <question><![CDATA[Product 5]]></question>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[571]]></qid>
    <parent_qid><![CDATA[516]]></parent_qid>
    <sid><![CDATA[192149]]></sid>
    <gid><![CDATA[20]]></gid>
    <type><![CDATA[T]]></type>
    <title><![CDATA[SQ6]]></title>
    <other><![CDATA[N]]></other>
    <encrypted><![CDATA[N]]></encrypted>
    <question_order><![CDATA[5]]></question_order>
    <scale_id><![CDATA[0]]></scale_id>
    <same_default><![CDATA[0]]></same_default>
    <relevance/>
    <id><![CDATA[591]]></id>
    <question><![CDATA[Product 6]]></question>
    <language><![CDATA[en]]></language>
   </row>
  </rows>
 </subquestions>
 <question_l10ns>
  <fields>
   <fieldname>id</fieldname>
   <fieldname>qid</fieldname>
   <fieldname>question</fieldname>
   <fieldname>help</fieldname>
   <fieldname>script</fieldname>
   <fieldname>language</fieldname>
  </fields>
  <rows>
   <row>
    <id><![CDATA[536]]></id>
    <qid><![CDATA[516]]></qid>
    <question><![CDATA[Which products do you like?]]></question>
    <help/>
    <script/>
    <language><![CDATA[en]]></language>
   </row>
  </rows>
 </question_l10ns>
 <question_attributes>
  <fields>
   <fieldname>qid</fieldname>
   <fieldname>attribute</fieldname>
   <fieldname>value</fieldname>
   <fieldname>language</fieldname>
  </fields>
  <rows>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[array_filter]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[array_filter_exclude]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[array_filter_style]]></attribute>
    <value><![CDATA[0]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[clear_default]]></attribute>
    <value><![CDATA[N]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[cssclass]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[display_rows]]></attribute>
    <value/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[em_validation_q]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[em_validation_q_tip]]></attribute>
    <value/>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[em_validation_sq]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[em_validation_sq_tip]]></attribute>
    <value/>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[exclude_all_others]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[hidden]]></attribute>
    <value><![CDATA[0]]></value>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[hide_tip]]></attribute>
    <value><![CDATA[0]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[input_size]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[label_input_columns]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[max_answers]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[maximum_chars]]></attribute>
    <value/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[min_answers]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[numbers_only]]></attribute>
    <value><![CDATA[0]]></value>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[page_break]]></attribute>
    <value><![CDATA[0]]></value>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[prefix]]></attribute>
    <value/>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[question_template]]></attribute>
    <value><![CDATA[core]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[random_group]]></attribute>
    <value/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[random_order]]></attribute>
    <value><![CDATA[0]]></value>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[save_as_default]]></attribute>
    <value><![CDATA[N]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[statistics_graphtype]]></attribute>
    <value><![CDATA[0]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[statistics_showgraph]]></attribute>
    <value><![CDATA[1]]></value>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[suffix]]></attribute>
    <value/>
    <language><![CDATA[en]]></language>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[text_input_columns]]></attribute>
    <value/>
    <language/>
   </row>
   <row>
    <qid><![CDATA[516]]></qid>
    <attribute><![CDATA[text_input_width]]></attribute>
    <value/>
   </row>
  </rows>
 </question_attributes>
</document>
limesurvey_question_516.lsq (10,350 bytes)   
ollehar

ollehar

2021-06-15 11:12

administrator   ~64913

1) Please write in English next time.

2) Please attach a survey lss file, not just a question. It can be hard to import an lsq question file since primary language has to be correct in the survey.
ollehar

ollehar

2021-06-15 11:58

administrator   ~64914

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=32083
JR_1234

JR_1234

2021-06-15 14:08

reporter   ~64919

Works for me. Many thanks for the quick response!
ollehar

ollehar

2021-06-15 14:09

administrator   ~64920

Great, will be released next Monday.
c_schmitz

c_schmitz

2021-07-12 11:53

administrator   ~65338

Release done.

Related Changesets

LimeSurvey: master 21e5c962

2021-06-15 11:58:40

ollehar

Details Diff
Fixed issue 17366: Dual Matrix - Dynamic generation of row labels is broken Affected Issues
17366
mod - application/views/survey/questions/answer/arrays/dualscale/answer.twig Diff File

Issue History

Date Modified Username Field Change
2021-06-15 08:56 JR_1234 New Issue
2021-06-15 08:56 JR_1234 File Added: limesurvey_question_516.lsq
2021-06-15 11:12 ollehar Note Added: 64913
2021-06-15 11:14 ollehar Summary Dual Matrix - Standard Ansicht - Dynamisches generieren von Zeilen-Labels ist kaputt => Dual Matrix - Standard view - Dynamic generation of row labels is broken
2021-06-15 11:14 ollehar Description Updated View Revisions
2021-06-15 11:58 ollehar Changeset attached => LimeSurvey master 21e5c962
2021-06-15 11:58 ollehar Note Added: 64914
2021-06-15 11:58 ollehar Assigned To => ollehar
2021-06-15 11:58 ollehar Resolution open => fixed
2021-06-15 12:01 ollehar Status new => resolved
2021-06-15 14:08 JR_1234 Note Added: 64919
2021-06-15 14:09 ollehar Note Added: 64920
2021-07-12 11:53 c_schmitz Note Added: 65338
2021-07-12 11:53 c_schmitz Bug heat 4 => 6
2021-07-12 11:53 c_schmitz Status resolved => closed