View Issue Details

IDProjectCategoryView StatusLast Update
17277Bug reportsTranslationpublic2021-05-07 11:31
Reporterhopechc Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version3.25.20 
Summary17277: Tools>Quick-Translation opens blank page
DescriptionProduct version is actually 3.26.1+210427 Unable to select correct build.

Tools>Quick-translation opening a blank page after the most recent update. It was working before the update we ran on Monday but failed right afterwards. Have checked other surveys and all on the system are having this issue. I am not finding any meaningful information in the logs. It generates a Internal Server Error 500 but nothing beyond that. Currently running latest available patch using Comfort Update.
Steps To ReproduceCreate Survey, add additional language, go to tools and Quick-translate
Tagstranslation
Complete LimeSurvey version number (& build) 3.26.1+210427
I will donate to the project if issue is resolvedNo
BrowserFirefox 88.0 and Chromium 89.0.4389.114
Database & DB-VersionMySql 5.7.33
Server OS (if known)Ubuntu 18.04LTS
Webserver software & version (if known)Apache2 2.4.29
PHP Version7.2

Activities

ollehar

ollehar

2021-04-29 17:03

administrator   ~64191

Can you enable debug = 2 in application/config/config.php and try again, please? Paste the complete error message here.
hopechc

hopechc

2021-04-29 17:08

reporter   ~64192

Last edited: 2021-05-07 11:20

Fatal error: Cannot redeclare getInlineEditor() (previously declared in /home/hopechc/public_html/application/helpers/admin/htmleditor_helper.php:190) in /home/hopechc/public_html/application/helpers/admin/htmleditor_helper.php on line 190

Sorry I would have included that it I had known how to turn it on.
ollehar

ollehar

2021-04-29 17:10

administrator   ~64193

Last edited: 2021-05-07 11:20

Sounds like a file got imported twice. Can you give us a longer stacktrace?
ollehar

ollehar

2021-04-29 17:16

administrator   ~64194

Last edited: 2021-05-07 11:20

Can reproduce with this error:


Fatal error: Cannot redeclare initKcfinder() (previously declared in /var/www/html/application/helpers/admin/htmleditor_helper.php:20) in /var/www/html/application/helpers/admin/htmleditor_helper.php on line 18
hopechc

hopechc

2021-04-29 17:17

reporter   ~64195

Last edited: 2021-05-07 11:20

Could you point me in the direction of the steps to get that stack trace in the form that you are looking for. Sorry, network engineer not a PHP coder, too many years since programing.
ollehar

ollehar

2021-04-29 17:18

administrator   ~64196

Last edited: 2021-05-07 11:20

I expected debug = 2 would give a stacktrace, but it didn't, actually.
ollehar

ollehar

2021-04-29 17:34

administrator   ~64197

Last edited: 2021-05-07 11:20

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31649
ollehar

ollehar

2021-04-29 17:36

administrator   ~64198

Last edited: 2021-05-07 11:20

Removed duplicated calls to Yii::app()->loadHelper("admin/htmleditor"). Very weird I didn't notice this in my previous fix.
hopechc

hopechc

2021-04-29 17:52

reporter   ~64199

Last edited: 2021-05-07 11:20

So I can drop those calls in both files and it should fix it for now and then be incorporated in the next update?
hopechc

hopechc

2021-04-29 17:56

reporter   ~64200

Last edited: 2021-05-07 11:20

Removed and tested. System appears to be working as it should. Thank you for your quick response and help. What do you need from me to close this issue?
ollehar

ollehar

2021-04-29 20:45

administrator   ~64201

Last edited: 2021-05-07 11:20

Great!

The issue will be closed automatically at next release.

Related Changesets

LimeSurvey: 3.x-LTS 34754f0a

2021-04-29 17:34:22

ollehar

Details Diff
Fixed issue 17277: Tools>Quick-Translation opens blank page Affected Issues
17277
mod - application/controllers/admin/translate.php Diff File
mod - application/views/admin/translate/translatetabs_view.php Diff File

Issue History

Date Modified Username Field Change
2021-04-29 16:47 hopechc New Issue
2021-04-29 17:03 ollehar Assigned To => ollehar
2021-04-29 17:03 ollehar Status new => feedback
2021-04-29 17:03 ollehar Note Added: 64191
2021-04-29 17:08 hopechc Note Added: 64192
2021-04-29 17:08 hopechc Status feedback => assigned
2021-04-29 17:10 ollehar Note Added: 64193
2021-04-29 17:16 ollehar Note Added: 64194
2021-04-29 17:17 hopechc Note Added: 64195
2021-04-29 17:18 ollehar Note Added: 64196
2021-04-29 17:34 ollehar Changeset attached => LimeSurvey 3.x-LTS 34754f0a
2021-04-29 17:34 ollehar Note Added: 64197
2021-04-29 17:34 ollehar Resolution open => fixed
2021-04-29 17:35 ollehar Status assigned => testing
2021-04-29 17:36 ollehar Note Added: 64198
2021-04-29 17:52 hopechc Note Added: 64199
2021-04-29 17:56 hopechc Note Added: 64200
2021-04-29 18:43 hopechc Tag Attached: translation
2021-04-29 20:45 ollehar Note Added: 64201
2021-05-07 11:31 ollehar Status testing => resolved