View Issue Details

IDProjectCategoryView StatusLast Update
17257Bug reportsSurvey editingpublic2021-04-22 17:19
ReporterMazi Assigned Toollehar  
PriorityhighSeverityblock 
Status resolvedResolutionfixed 
Product Version4.5.x 
Summary17257: Can't edit question code of activated survey
DescriptionAfter having activated my survey I am not able to edit the question code, the field is disabled. At LS3.x this was no problem at all and often you simply have to edit the code, even if the survey is active.
Only after deactiving the survey I was able to edit the questin code.
Steps To ReproduceActivate a test survey.
Try editing a question code.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.5.1+210420
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 20
Webserver software & version (if known)Apache 2.0
PHP Version7.3

Activities

ollehar

ollehar

2021-04-19 20:06

administrator   ~64015

Wait, is this really safe? Question code is part of the response table. @Shnoulle?
ollehar

ollehar

2021-04-19 20:07

administrator   ~64016

@DenisChenu
Mazi

Mazi

2021-04-19 20:12

partner   ~64017

@ollehar, then the DB layout must have changed a lot. At LS3.x the question code never was part of the lime_survey_123456 tables. Only subquestion codes were listed there. These are disabled at LS3.x which is fine. The question codes you could always edit!
ollehar

ollehar

2021-04-19 20:14

administrator   ~64018

No, that part is unchanged between LS3 and LS4. Response table should be in format surveyidXquestionidXgroupid. Uh, OK, maybe it's id and not code? Will check tomorrow when I'm back at work.
DenisChenu

DenisChenu

2021-04-20 06:32

developer   ~64026

Its allowed since years and clearly : it's NEEDED !
DenisChenu

DenisChenu

2021-04-20 06:33

developer   ~64027

Else : even for subquestion code : we can not, but if we can : it's better to allow edition …
ollehar

ollehar

2021-04-20 10:16

administrator   ~64029

Alright, everybody relax, haha. We'll fix it.
DenisChenu

DenisChenu

2021-04-20 10:58

developer   ~64032

Sorry for uppercase :( , really soory.

I'm relaxed :)

To remind : if possible : it can be great to allow edition on whole survey if it's activated.

Maybe with :
- A checkbox somewhere : 'allow edit' => not saved, just in session
- A confirmation for dangerous part (delete a question : move data from this question)
- Some more warning (currently : delete answers don't send warning : but it can broke analysis).

:)
ollehar

ollehar

2021-04-20 11:35

administrator   ~64035

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31604
ollehar

ollehar

2021-04-20 11:35

administrator   ~64036

Pull and review, please.

Related Changesets

LimeSurvey: master eb9229e2

2021-04-20 11:35:19

ollehar

Details Diff
Fixed issue 17257: Can't edit question code of activated survey Affected Issues
17257
mod - application/views/questionAdministration/codeAndType.php Diff File

Issue History

Date Modified Username Field Change
2021-04-19 20:04 Mazi New Issue
2021-04-19 20:06 ollehar Priority none => high
2021-04-19 20:06 ollehar Severity crash => block
2021-04-19 20:06 ollehar Note Added: 64015
2021-04-19 20:07 ollehar Note Added: 64016
2021-04-19 20:12 Mazi Note Added: 64017
2021-04-19 20:14 ollehar Note Added: 64018
2021-04-20 06:32 DenisChenu Note Added: 64026
2021-04-20 06:33 DenisChenu Note Added: 64027
2021-04-20 10:16 ollehar Note Added: 64029
2021-04-20 10:58 DenisChenu Note Added: 64032
2021-04-20 11:35 ollehar Changeset attached => LimeSurvey master eb9229e2
2021-04-20 11:35 ollehar Note Added: 64035
2021-04-20 11:35 ollehar Assigned To => ollehar
2021-04-20 11:35 ollehar Resolution open => fixed
2021-04-20 11:35 ollehar Status new => testing
2021-04-20 11:35 ollehar Note Added: 64036
2021-04-22 17:19 ollehar Status testing => resolved