View Issue Details

IDProjectCategoryView StatusLast Update
17121Bug reportsSurvey editingpublic2021-03-29 12:31
Reportertpartner Assigned Toc_schmitz  
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.4.7 
Summary17121: Custom question preview image not shown
DescriptionThe preview image for custom question themes does not work, it did in 3.x

See attached images and custom theme.
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.9
I will donate to the project if issue is resolvedNo
Browsern/a
Database & DB-Version10.3.16-MariaDB
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Activities

tpartner

tpartner

2021-02-23 14:34

developer  

Net-Promoter-Score.zip (55,367 bytes)
capture_2.png (29,887 bytes)   
capture_2.png (29,887 bytes)   
capture_3.png (4,608 bytes)   
capture_3.png (4,608 bytes)   
gabrieljenik

gabrieljenik

2021-03-02 21:32

manager   ~62624

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1790

This issue was caused by a missuse of the publicurl. I think we should review when to use it or how to use it as to be consistent.
There other places where this can popup
gabrieljenik

gabrieljenik

2021-03-11 18:18

manager   ~63318

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31314
lime_release_bot

lime_release_bot

2021-03-15 15:37

administrator   ~63372

Fixed in Release 4.4.13+210315
tpartner

tpartner

2021-03-15 18:09

developer   ~63384

This is still not fixed. Please see attachments.
Net-Promoter-Score-2.zip (55,367 bytes)
capture_4.png (85,550 bytes)   
capture_4.png (85,550 bytes)   
capture_6.png (9,274 bytes)   
capture_6.png (9,274 bytes)   
capture_5.png (5,505 bytes)   
capture_5.png (5,505 bytes)   
gabrieljenik

gabrieljenik

2021-03-19 16:55

manager   ~63486

The problem is solved, partially. :)

The issue was generated when the plugin was installed.
That generated data with broken links in the system

New question themes shouldn't show the same issue.

For already installed question themes, @c_schmitz, should we do a script to fix it that could be run on a minor upgrade?
It should review all manifests, and try to overwrite the broken link piece of data.
Not as straightforward as a SQL but not rocket science.
What do you think?
c_schmitz

c_schmitz

2021-03-19 17:45

administrator   ~63487

Upgrade script sounds fine.
gabrieljenik

gabrieljenik

2021-03-22 17:09

manager   ~63551

After upgrade, refresh question theme preview pictures.
https://github.com/LimeSurvey/LimeSurvey/pull/1810
gabrieljenik

gabrieljenik

2021-03-25 14:43

manager   ~63605

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31383
tpartner

tpartner

2021-03-25 14:58

developer   ~63608

I cannot test because, after a fresh pull, I get this.
capture_4-2.png (47,844 bytes)   
capture_4-2.png (47,844 bytes)   
tpartner

tpartner

2021-03-25 15:02

developer   ~63609

capture_5-2.png (21,608 bytes)   
capture_5-2.png (21,608 bytes)   
capture_6-2.png (9,690 bytes)   
capture_6-2.png (9,690 bytes)   
c_schmitz

c_schmitz

2021-03-25 16:14

administrator   ~63613

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31390
tpartner

tpartner

2021-03-25 16:41

developer   ~63618

Thank Carsten.

Also, a quick test of the bug shows it fixed.
gabrieljenik

gabrieljenik

2021-03-26 21:45

manager   ~63657

@tpartner: Should we persuit the errors in those pictures?
tpartner

tpartner

2021-03-27 11:07

developer   ~63660

@gabrieljenik, no thanks, it was something Carsten did. He fixed it.
lime_release_bot

lime_release_bot

2021-03-29 12:31

administrator   ~63683

Fixed in Release 4.4.15+210329

Related Changesets

LimeSurvey: master d8dbbebd

2021-03-11 18:07:45

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17121: Customq question preview image not shown (#1790) Affected Issues
17121
mod - application/models/QuestionTheme.php Diff File

LimeSurvey: master 8100d018

2021-03-25 14:33:24

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17121: Custom question preview image not shown (#1810) Affected Issues
17121
mod - application/helpers/update/updatedb_helper.php Diff File
mod - application/models/QuestionTheme.php Diff File

LimeSurvey: master ce27e0db

2021-03-25 15:59:56

c_schmitz

Details Diff
Fixed issue 17121: Custom question preview image not shown (#1810) Affected Issues
17121
mod - application/helpers/update/updatedb_helper.php Diff File

Issue History

Date Modified Username Field Change
2021-02-23 14:34 tpartner New Issue
2021-02-23 14:34 tpartner File Added: Net-Promoter-Score.zip
2021-02-23 14:34 tpartner File Added: capture_2.png
2021-02-23 14:34 tpartner File Added: capture_3.png
2021-02-23 15:45 gabrieljenik Assigned To => gabrieljenik
2021-02-23 15:45 gabrieljenik Status new => assigned
2021-03-02 21:32 gabrieljenik Note Added: 62624
2021-03-11 18:18 gabrieljenik Changeset attached => LimeSurvey master d8dbbebd
2021-03-11 18:18 gabrieljenik Note Added: 63318
2021-03-11 18:18 gabrieljenik Resolution open => fixed
2021-03-15 15:37 lime_release_bot Note Added: 63372
2021-03-15 15:37 lime_release_bot Status assigned => closed
2021-03-15 18:09 tpartner Note Added: 63384
2021-03-15 18:09 tpartner File Added: Net-Promoter-Score-2.zip
2021-03-15 18:09 tpartner File Added: capture_4.png
2021-03-15 18:09 tpartner File Added: capture_6.png
2021-03-15 18:09 tpartner File Added: capture_5.png
2021-03-15 19:24 tpartner Status closed => feedback
2021-03-15 19:24 tpartner Resolution fixed => reopened
2021-03-15 19:25 tpartner Summary Customq question preview image not shown => Custom question preview image not shown
2021-03-19 16:55 gabrieljenik Note Added: 63486
2021-03-19 17:45 c_schmitz Note Added: 63487
2021-03-22 17:09 gabrieljenik Note Added: 63551
2021-03-25 14:33 c_schmitz Status feedback => resolved
2021-03-25 14:33 c_schmitz Resolution reopened => fixed
2021-03-25 14:43 gabrieljenik Changeset attached => LimeSurvey master 8100d018
2021-03-25 14:43 gabrieljenik Note Added: 63605
2021-03-25 14:58 tpartner Note Added: 63608
2021-03-25 14:58 tpartner File Added: capture_4-2.png
2021-03-25 15:02 tpartner Note Added: 63609
2021-03-25 15:02 tpartner File Added: capture_5-2.png
2021-03-25 15:02 tpartner File Added: capture_6-2.png
2021-03-25 16:14 c_schmitz Changeset attached => LimeSurvey master ce27e0db
2021-03-25 16:14 c_schmitz Note Added: 63613
2021-03-25 16:14 c_schmitz Assigned To gabrieljenik => c_schmitz
2021-03-25 16:41 tpartner Note Added: 63618
2021-03-26 21:45 gabrieljenik Note Added: 63657
2021-03-27 11:07 tpartner Note Added: 63660
2021-03-29 12:31 lime_release_bot Note Added: 63683
2021-03-29 12:31 lime_release_bot Status resolved => closed