View Issue Details

IDProjectCategoryView StatusLast Update
17110Bug reportsSurvey participants (Tokens)public2021-02-18 17:16
Reporterritapas Assigned Toollehar  
PrioritynoneSeveritycrash 
Status closedResolutionunable to reproduce 
Product Version3.25.12 
Summary17110: problem with resume later in anonymous token based survey
Description

When you make an anonymous token-based survey with invitation, you can allow users to save and resume later with token persistance.
But when they try to do that and create a custom account they get this error:

500: Internal Server Error
The active record cannot be inserted to database because it is not new.

Steps To Reproduce

Import .lss survey, create a participant table and invite yourself.
Open the survey and click on Resume later.
Just insert username and password, no email, like an anonymous user would.
Click save now.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.25.14
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browser
Database & DB-Versiondo not know
Server OS (if known)
Webserver software & version (if known)
PHP Versiondo not know

Activities

ritapas

ritapas

2021-02-18 14:56

reporter  

testsavevanon.lss (15,391 bytes)
DenisChenu

DenisChenu

2021-02-18 15:08

developer   ~62356

Last edited: 2021-02-18 15:09

View 2 revisions

I can not reproduce on 3.25.14

  1. Create 5 token
  2. Private windows with token #1 : save with Denis/Chenu : OK
  3. New private with token #2 : save with Denis/Chenu : "This name was alerady … unique …"
  4. Save with Denis2/Chenu
  5. New private with token #2 : load : put Denis2/Chenu : OK
ritapas

ritapas

2021-02-18 15:30

reporter   ~62357

this is weird.
I've been using a completely different name to invite myself and to register myself. It fails right at first try.

DenisChenu

DenisChenu

2021-02-18 15:32

developer   ~62358

Can you actuvate debug mode and send the complete HTML file ?

ritapas

ritapas

2021-02-18 15:37

reporter   ~62359

I think I can not. I have this version only in my LS Pro instance.

ollehar

ollehar

2021-02-18 15:37

administrator   ~62360

Please provide us with a screenshot of the error. Thank you.

DenisChenu

DenisChenu

2021-02-18 15:39

developer   ~62361

LS Pro instance

You mean SAAS version ?

ollehar

ollehar

2021-02-18 15:53

administrator   ~62362

Yes, hosting was called LimeSurvey Professional before (now LimeSurvey Cloud).

ritapas

ritapas

2021-02-18 15:55

reporter   ~62363

@DenisChenu: yes.

@everybody:

I've just tried again to get the screenshot and now it works :-\

This happened in my ls, which was older, so I tried to replicate this in the SAAS and it did that again.

But now, I've been trying many times, cannot tell what happened.

ollehar

ollehar

2021-02-18 16:19

administrator   ~62364

Will close it for now, feel free to contact us should the issue appear again.

ritapas

ritapas

2021-02-18 17:16

reporter   ~62366

Thank you, I am very sorry but I've been able to reproduce it many times before submitting this report.

Issue History

Date Modified Username Field Change
2021-02-18 14:56 ritapas New Issue
2021-02-18 14:56 ritapas File Added: testsavevanon.lss
2021-02-18 15:08 DenisChenu Note Added: 62356
2021-02-18 15:09 DenisChenu Note Edited: 62356 View Revisions
2021-02-18 15:30 ritapas Note Added: 62357
2021-02-18 15:32 DenisChenu Note Added: 62358
2021-02-18 15:36 ollehar Assigned To => ollehar
2021-02-18 15:36 ollehar Status new => feedback
2021-02-18 15:36 ollehar Product Version => 3.25.12
2021-02-18 15:37 ritapas Note Added: 62359
2021-02-18 15:37 ritapas Status feedback => assigned
2021-02-18 15:37 ollehar Note Added: 62360
2021-02-18 15:39 DenisChenu Note Added: 62361
2021-02-18 15:53 ollehar Note Added: 62362
2021-02-18 15:54 ollehar Status assigned => feedback
2021-02-18 15:55 ritapas Note Added: 62363
2021-02-18 15:55 ritapas Status feedback => assigned
2021-02-18 16:19 ollehar Status assigned => closed
2021-02-18 16:19 ollehar Resolution open => unable to reproduce
2021-02-18 16:19 ollehar Note Added: 62364
2021-02-18 17:16 ritapas Note Added: 62366