View Issue Details

IDProjectCategoryView StatusLast Update
17102Bug reportsComfortUpdatepublic2021-03-08 19:38
Reporterbbraeuer Assigned Toc_schmitz  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.4.7 
Fixed in Version4.4.12 
Summary17102: (4.4.8) installedthemes.php deleted by Comfort Update
DescriptionHi,
I have just installed 4.4.8 - the Comfort Update has deleted application/views/themeOptions/installedthemes.php and did not replace it!

Please check this.

Kind regards
Benny
Additional InformationSee https://bugs.limesurvey.org/view.php?id=17061
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.4.8+210217
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL 5.6.51-log
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.24-0ubuntu0.18.04.7

Relationships

duplicate of 17061 closedc_schmitz Themes editor cannot be opened 

Activities

bbraeuer

bbraeuer

2021-02-16 16:37

reporter  

bbraeuer

bbraeuer

2021-02-16 16:39

reporter   ~62291

Addition: Now the themes editor cannot be opened anymore, see 17061 for reference
bbraeuer

bbraeuer

2021-02-16 16:43

reporter   ~62292

Addition: also the manual adding of the file will make the theme editor work again. It's broken again :(
So we are back at the beginning of issue 17061
ollehar

ollehar

2021-02-16 17:21

administrator   ~62293

Thanks for reporting, we'll have a look.
c_schmitz

c_schmitz

2021-02-16 17:48

administrator   ~62296

The files installed /installedthemes.php is supposed to be deleted.
There should be a file installedthemelist.php which seems to be also missing in your installation (resulting from a previous update error).
You can downlad it at https://raw.githubusercontent.com/LimeSurvey/LimeSurvey/bb02d30a78e7c926cbd9cc36e9afe3f83e25cfb1/application/views/themeOptions/installedthemelist.php
bbraeuer

bbraeuer

2021-02-17 09:20

reporter   ~62306

Thanks, thats working now for me :-)

Issue History

Date Modified Username Field Change
2021-02-16 16:37 bbraeuer New Issue
2021-02-16 16:37 bbraeuer File Added: Bildschirmfoto 2021-02-16 um 16.37.22.png
2021-02-16 16:39 bbraeuer Note Added: 62291
2021-02-16 16:43 bbraeuer Note Added: 62292
2021-02-16 17:21 ollehar Note Added: 62293
2021-02-16 17:25 ollehar Product Version => 4.4.7
2021-02-16 17:25 ollehar Description Updated View Revisions
2021-02-16 17:33 c_schmitz Assigned To => c_schmitz
2021-02-16 17:33 c_schmitz Status new => assigned
2021-02-16 17:48 c_schmitz Status assigned => resolved
2021-02-16 17:48 c_schmitz Resolution open => fixed
2021-02-16 17:48 c_schmitz Note Added: 62296
2021-02-17 00:11 c_schmitz Relationship added duplicate of 17061
2021-02-17 09:20 bbraeuer Note Added: 62306
2021-03-08 19:31 c_schmitz Fixed in Version => 4.4.12
2021-03-08 19:38 c_schmitz Status resolved => closed