View Issue Details

IDProjectCategoryView StatusLast Update
17100Bug reportsSurvey editingpublic2021-04-19 18:13
ReporterJHoeck Assigned Togabrieljenik  
PriorityhighSeverityminor 
Status resolvedResolutionfixed 
Product Version4.4.7 
Summary17100: New question will be added to the wrong group
DescriptionFresh created question will be added to wrong group. (If you have more than one group in your survey)
Steps To Reproduce1. Create or select survey
2. Create two groups
3. Select second group as active groupe
4. Click on 'create question' button
5. Create question
6. Question will be inside the wrong one.
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.8 (latest master)
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionnot needed
Server OS (if known)
Webserver software & version (if known)
PHP Versionnot needed

Relationships

has duplicate 17209 closedc_schmitz adding new question looses group context when changing questiontype in 4.4 
related to 17229 confirmedc_schmitz Question group information is lost when selecting a different question type 

Activities

gabrieljenik

gabrieljenik

2021-03-22 16:25

developer   ~63546

This is not reproducble on master
JHoeck

JHoeck

2021-03-22 18:15

developer   ~63557

Can't reproduce it also - will close this ticket.
gabrieljenik

gabrieljenik

2021-04-07 17:00

developer   ~63856

Reopening reviewing with these steps

1. Create two question groups
2. Select group 2
3. Add a question to group 2
4. Check that "group 2" appears as the selected "Question group"
5. Select a different question type
4. "Question group" should now display "group 1" instead of "group 2"
gabrieljenik

gabrieljenik

2021-04-15 22:59

developer   ~63983

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1847

Reassigning group after part of the screen s refreshed
gabrieljenik

gabrieljenik

2021-04-15 23:01

developer   ~63984

The issue might as well be happening with other attributes as the problem is that the attributes panels are being refreshed and their values are from DB.
So, if attribute A is changed before changing the question theme or type, the attrbite A will be reverted to its DB value.

I believe we should add some kind of warning sign sayng any non-saved attribute will be lost..
Or, move the theme and type to another place of the screen that will probably allow people to be aware their non saved changes will be lost?.
DenisChenu

DenisChenu

2021-04-16 13:40

developer   ~63987

> The issue might as well be happening with other attributes as the problem is that the attributes panels are being refreshed and their values are from DB.

I think we muts remove unecessary attribute for example advanced settings (except theme) can be out of this create form.
gabrieljenik

gabrieljenik

2021-04-17 01:32

developer   ~63997

> I think we muts remove unecessary attribute for example advanced settings (except theme) can be out of this create form.

It is not only when creating, also when editing.
I think "theme and type" should be on a separate place, as for highlighting their importance and preponderance over other attributes
DenisChenu

DenisChenu

2021-04-17 09:18

developer   ~63998

Yes !!!!!

100 000 % yes.

Primary : Code + Text + General options (like in 3.X, see screenshot)
Secondary : Sub questions and Answers
Tertiary (or lesser) : Other advanced settings
gabrieljenik

gabrieljenik

2021-04-19 17:27

developer   ~64007

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31603

Related Changesets

LimeSurvey: master 53599d85

2021-04-19 17:27:21

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17100: New question will be added to the wrong group (#1847) Affected Issues
17100
mod - assets/scripts/admin/questionEditor.js Diff File

Issue History

Date Modified Username Field Change
2021-02-16 15:18 JHoeck New Issue
2021-02-16 15:18 JHoeck Status new => assigned
2021-02-16 15:18 JHoeck Assigned To => JHoeck
2021-03-22 15:10 c_schmitz Priority none => high
2021-03-22 16:25 gabrieljenik Note Added: 63546
2021-03-22 18:15 JHoeck Note Added: 63557
2021-03-22 18:15 JHoeck Status assigned => closed
2021-03-22 18:15 JHoeck Resolution open => unable to reproduce
2021-04-07 08:16 c_schmitz Relationship added related to 17229
2021-04-07 17:00 gabrieljenik Assigned To JHoeck => gabrieljenik
2021-04-07 17:00 gabrieljenik Status closed => feedback
2021-04-07 17:00 gabrieljenik Resolution unable to reproduce => reopened
2021-04-07 17:00 gabrieljenik Note Added: 63856
2021-04-08 17:34 c_schmitz Relationship added has duplicate 17209
2021-04-08 17:35 c_schmitz Status feedback => assigned
2021-04-15 22:59 gabrieljenik Note Added: 63983
2021-04-15 23:01 gabrieljenik Note Added: 63984
2021-04-16 13:40 DenisChenu Note Added: 63987
2021-04-17 01:32 gabrieljenik Note Added: 63997
2021-04-17 09:18 DenisChenu Note Added: 63998
2021-04-17 09:18 DenisChenu File Added: Capture d’écran_2021-04-17_09-17-38.png
2021-04-19 17:27 gabrieljenik Changeset attached => LimeSurvey master 53599d85
2021-04-19 17:27 gabrieljenik Note Added: 64007
2021-04-19 17:27 gabrieljenik Resolution reopened => fixed
2021-04-19 18:13 ollehar Status assigned => resolved