View Issue Details

This bug affects 1 person(s).
 2
IDProjectCategoryView StatusLast Update
17074Bug reportsSurvey participants (Tokens)public2022-08-05 17:18
Reporterandreabersi Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionunable to reproduce 
Product Version3.25.12 
Summary17074: Encoding string in token's table
Description

If i add a participiant and in the filed i adda a apostrophe, in teh tabkle of databasse the apostrophe is written as html entity (");
for this, in the list view or in the edit view the value is showed as " (See attachmemt)

Steps To Reproduce

Create survey, add participiant and in the firstname or lastname filed (the same happens in the attribute field) insert a "'" (apostrophe) or a double quote character. Save and go in the list the value appear broken

TagsNo tags attached.
Bug heat2
Complete LimeSurvey version number (& build)Version 3.25.12+210211
I will donate to the project if issue is resolvedNo
BrowserAll
Database type & version10.4.6-MariaDB-1
Server OS (if known)
Webserver software & version (if known)
PHP Version7.2.24

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

andreabersi

andreabersi

2021-02-10 09:22

reporter  

gabrieljenik

gabrieljenik

2022-08-05 17:18

manager   ~71351

Hello andreabersi,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

gabrieljenik

Issue History

Date Modified Username Field Change
2021-02-10 09:22 andreabersi New Issue
2021-02-10 09:22 andreabersi File Added: Schermata 2021-02-10 alle 09.04.14.jpg
2022-08-05 17:18 gabrieljenik Status new => feedback
2022-08-05 17:18 gabrieljenik Note Added: 71351
2022-08-05 17:18 gabrieljenik Bug heat 0 => 2
2022-08-05 17:18 gabrieljenik Assigned To => gabrieljenik
2022-08-05 17:18 gabrieljenik Status feedback => closed
2022-08-05 17:18 gabrieljenik Resolution open => unable to reproduce