View Issue Details

IDProjectCategoryView StatusLast Update
17058Bug reportsSurvey participants (Tokens)public2021-04-15 13:07
Reportertanja_d Assigned Toc_schmitz  
PriorityhighSeverityminor 
Status closedResolutionduplicate 
Product Version4.3.34 
Summary17058: Access code length definition/inheritance not working anymore
DescriptionAfter upgrading from 4.2.4 to 4.3.34 (same effect tested in 4.2.8 and 4.3.33) the defined length of the access code is shown as -1 in the frontend (should be 15, as shown in the old version with the same database) and Inherit is shown as "Off" ("On" in the old version with the same database). Setting Inherit to "On" doesn't change the value to 15 and "Save" is ignored.
Generating access codes therefore creates new access codes with 3 characters and not 15 as in the old version.
As we use access codes for all surveys we can't upgrade our production environment.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.3.34 Build 210119
I will donate to the project if issue is resolvedNo
BrowserOpera + Firefox
Database & DB-VersionMS SQL Server 13.0.5103.6
Server OS (if known)Linux 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64
Webserver software & version (if known)Apache/2.4.38 (Debian)
PHP Version7.3.19-1~deb10u1

Relationships

duplicate of 17233 resolvedc_schmitz Question index is broken for the attached survey (postgres only) 

Activities

tanja_d

tanja_d

2021-03-15 11:49

reporter   ~63358

This is still an issue in 4.4.12
c_schmitz

c_schmitz

2021-03-18 15:43

administrator   ~63436

Last edited: 2021-03-31 14:06

View 2 revisions

Hello tanja_d,
This should already be fixed in 4.4.13
Can you please check if this issue still exists in the latest version of LimeSurvey and let us know?
Thank you!
tanja_d

tanja_d

2021-03-19 13:09

reporter   ~63475

Last edited: 2021-03-31 14:06

This is still an issue in 4.4.13.
c_schmitz

c_schmitz

2021-03-19 16:08

administrator   ~63482

Last edited: 2021-03-31 14:06

I cannot reproduce the issue with your attached survey attached.
Can you please give me the exact steps what to do after importing the survey?
You can also use our https://demo.limesurvey.org/admin to test the steps yourself.
tanja_d

tanja_d

2021-03-31 11:12

reporter   ~63736

Last edited: 2021-03-31 14:06

This is still an issue in 4.4.15.
Attached for explanation screenshots before and after the update of the LimeSurvey version, same database, same server, nothing else changed.
c_schmitz

c_schmitz

2021-04-15 13:06

administrator   ~63950

Closing because it is a duplicate. Thank you.

Issue History

Date Modified Username Field Change
2021-02-04 12:35 tanja_d New Issue
2021-02-04 12:35 tanja_d File Added: limesurvey_survey_592375.lss
2021-03-15 11:49 tanja_d Note Added: 63358
2021-03-18 15:39 c_schmitz Priority none => high
2021-03-18 15:39 c_schmitz Description Updated View Revisions
2021-03-18 15:43 c_schmitz Assigned To => c_schmitz
2021-03-18 15:43 c_schmitz Status new => feedback
2021-03-18 15:43 c_schmitz Note Added: 63436
2021-03-18 15:44 c_schmitz Note Edited: 63436 View Revisions
2021-03-19 13:09 tanja_d Note Added: 63475
2021-03-19 13:09 tanja_d Status feedback => assigned
2021-03-19 16:08 c_schmitz Note Added: 63482
2021-03-19 16:08 c_schmitz Status assigned => feedback
2021-03-31 11:12 tanja_d Note Added: 63736
2021-03-31 11:12 tanja_d File Added: ls_accesscode_before_update_1.png
2021-03-31 11:12 tanja_d File Added: ls_accesscode_after_update_1.png
2021-03-31 11:12 tanja_d Status feedback => assigned
2021-04-14 16:08 c_schmitz Relationship added related to 17233
2021-04-15 13:05 c_schmitz Relationship replaced duplicate of 17233
2021-04-15 13:06 c_schmitz Status assigned => resolved
2021-04-15 13:06 c_schmitz Resolution open => duplicate
2021-04-15 13:06 c_schmitz Note Added: 63950
2021-04-15 13:06 c_schmitz File Deleted: limesurvey_survey_592375.lss
2021-04-15 13:06 c_schmitz View Status private => public
2021-04-15 13:07 c_schmitz Status resolved => closed