View Issue Details

This bug affects 1 person(s).
 12
IDProjectCategoryView StatusLast Update
17042Bug reportsOtherpublic2022-09-21 21:52
Reporterollehar Assigned Togabrieljenik  
PrioritynormalSeverityminor 
Status closedResolutionno change required 
Product Version3.25.10 
Summary17042: Bug in integrity controller
Description

Line 541

                                $sNvColName = $oSurvey->sid . 'X'. $oQuestion->groups->gid . 'X' . $sDirtyQid;

groups is an array but treated as an object. Bugfix should figure out the correct group index.

TagsNo tags attached.
Bug heat12
Complete LimeSurvey version number (& build)3.x-LTS
I will donate to the project if issue is resolvedNo
Browser-
Database type & version-
Server OS (if known)-
Webserver software & version (if known)-
PHP Version-

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

cdorin

cdorin

2021-02-01 15:18

manager   ~61847

@gabrieljenik, can you please check if that's the case in LS4 as well?

gabrieljenik

gabrieljenik

2022-08-11 20:36

manager   ~71423

Happens on Master as well

gabrieljenik

gabrieljenik

2022-09-16 17:06

manager   ~71801

Only in 3.x

DenisChenu

DenisChenu

2022-09-16 17:15

developer   ~71802

Must use $sNvColName = $oSurvey->sid . 'X' . $sGid . 'X' . $oQuestion->qid;

No ?

gabrieljenik

gabrieljenik

2022-09-16 17:27

manager   ~71804

I think $oQuestion->gid
$sGid is the current GID in the DB, which is missmatching with the question model.

DenisChenu

DenisChenu

2022-09-16 17:44

developer   ~71805

Oh yes

gabrieljenik

gabrieljenik

2022-09-21 21:52

manager   ~71880

The issue is finally not a bug.
The relationship name is "groups" and it refers to the parent group.

The relationship name is not the best pick, but still, doesn't seem to create a bug.

As per the comments, will be closing the ticket.
Please add any comments in case it should be reopened.
Thanks

Issue History

Date Modified Username Field Change
2021-02-01 15:15 ollehar New Issue
2021-02-01 15:15 ollehar Status new => assigned
2021-02-01 15:15 ollehar Assigned To => gabrieljenik
2021-02-01 15:17 cdorin Priority none => normal
2021-02-01 15:17 cdorin Status assigned => confirmed
2021-02-01 15:17 cdorin Sync to Zoho Project => |Yes|
2021-02-01 15:18 cdorin Note Added: 61847
2021-02-01 15:29 cdorin Assigned To gabrieljenik =>
2021-02-01 15:29 cdorin Sync to Zoho Project Yes => |Yes|
2021-02-01 15:29 cdorin Sync to Zoho Project Yes =>
2021-02-01 15:30 cdorin Sync to Zoho Project => |Yes|
2022-08-11 20:36 gabrieljenik Note Added: 71423
2022-08-11 20:36 gabrieljenik Bug heat 8 => 10
2022-08-11 20:37 gabrieljenik Assigned To => gabrieljenik
2022-08-11 20:37 gabrieljenik Status confirmed => assigned
2022-08-17 09:48 sedropper Bug heat 10 => 12
2022-08-17 09:50 ollehar Bug heat 12 => 10
2022-09-16 17:06 gabrieljenik Note Added: 71801
2022-09-16 17:15 DenisChenu Note Added: 71802
2022-09-16 17:15 DenisChenu Bug heat 10 => 12
2022-09-16 17:27 gabrieljenik Note Added: 71804
2022-09-16 17:44 DenisChenu Note Added: 71805
2022-09-21 21:52 gabrieljenik Status assigned => closed
2022-09-21 21:52 gabrieljenik Resolution open => no change required
2022-09-21 21:52 gabrieljenik Note Added: 71880